HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Nov 11, 2013, 01:19 PM
Registered User
Joined Nov 2013
15 Posts
Discussion
Rotor Beeping when connecting to ESC and Battery

Hey,

I'm currently building a Quad based around the Spidex v2 frame. This is my first quad so everything is new to me. But this question is not specific to Spidex..

I connected one of the motors to the ESC, and the ESC to the LIPO to see what happens, and I'm getting a beep, beep, beep from the motor itself every second. Nothing else was connected.

What does this exactly mean?

Relevant items for the issue:
  • Gens Ace 3300 41SP 14.8V 25C LiPo battery.
  • DJI 30A Opto ESC
  • LM3506SM 630KV Motor
Amorgos is offline Find More Posts by Amorgos
Last edited by Amorgos; Nov 11, 2013 at 03:02 PM.
Reply With Quote
Sign up now
to remove ads between posts
Old Nov 11, 2013, 07:54 PM
Registered User
United Kingdom, England, Warrington
Joined Jul 2013
739 Posts
Quote:
Originally Posted by Amorgos View Post
Hey,

I'm currently building a Quad based around the Spidex v2 frame. This is my first quad so everything is new to me. But this question is not specific to Spidex..

I connected one of the motors to the ESC, and the ESC to the LIPO to see what happens, and I'm getting a beep, beep, beep from the motor itself every second. Nothing else was connected.

What does this exactly mean?

Relevant items for the issue:
  • Gens Ace 3300 41SP 14.8V 25C LiPo battery.
  • DJI 30A Opto ESC
  • LM3506SM 630KV Motor
AFAIK If there is no PWM input (in your case) or other error then it beeps an error code
cosmic2112 is online now Find More Posts by cosmic2112
Reply With Quote
Old Nov 11, 2013, 09:43 PM
Joined Oct 2013
44 Posts
Have you calibrated the Transmitter?
Ideafly apollo is offline Find More Posts by Ideafly apollo
Reply With Quote
Old Nov 13, 2013, 03:02 AM
Registered User
United States, VA
Joined Sep 2013
3,063 Posts
Do you have the ESC plugged into a receiver? If so, reverse the servo plug. If not, plug the ESC into the throttle channel of the receiver. The beeping sound like the ESC is not getting a signal.
KC_703 is offline Find More Posts by KC_703
Reply With Quote
Old Nov 13, 2013, 04:37 PM
Registered User
Joined Nov 2013
15 Posts
That is correct. The ESCs were not connected to the FC yet so this is hopefully why it's making a beep.

Thanks.
Amorgos is offline Find More Posts by Amorgos
Reply With Quote
Old Nov 13, 2013, 06:51 PM
Registered User
United States, VA
Joined Sep 2013
3,063 Posts
Quote:
Originally Posted by Amorgos View Post
That is correct. The ESCs were not connected to the FC yet so this is hopefully why it's making a beep.

Thanks.
Yep... I ran into this the other night. I had the servo leads from the ESC turned around and they were beeping/complaining of no signal.

Good luck!
KC_703 is offline Find More Posts by KC_703
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion ESCs smoked when connecting battery Kolb Multirotor Power Systems 3 Aug 04, 2013 11:53 AM
Discussion Battery To ESC Sparks When Connecting. notime_3001 Power Systems 10 May 20, 2013 09:05 PM
Discussion Electric Connections When Programming ESCs daskim Multirotor Electronics 6 Jan 21, 2013 07:42 PM
Discussion Burn out when connecting battery to ESC derp express Power Systems 7 Jan 03, 2013 05:44 AM
Discussion Lama 4 Rotor starts spinning when connecting 900mah 15 c battery dw850 Coaxial Helicopters 4 Jul 16, 2008 10:30 PM