SMALL - espritmodel.com SMALL - Telemetry SMALL - Radio
Reply
Thread Tools
Old May 08, 2012, 03:36 PM
Registered User
United States, MA, Waltham
Joined Dec 2001
7,130 Posts
Discussion
Flash 5X noises when OFF!

posted also to vendor section:

Was driving in my car today with Flash 5x tx on board. Noticed it was making noises. Clicks, buzzes, and beeps. Not all the time or all that often, although there might be single clicks fairly often. I've got it on my desk right now, after several hours, and it still clicks now and then, very quietly. It still has 10.3 volts. The top and bottom of the 0 in the 10.3 volts don't show up very well. (I actually saw that the other day, but didn't think much of it.) It's never happened before, but today the switch seems flaky. If I don't press down on the switch, it doesn't always turn on. Once I turned it on and got a steady beep with nothing in the display. That went away when I turned it off and on again.

Any idea what this is? Could a flaky power switch cause this stuff somehow??

I've had this radio for a dozen years now, and up to now it's always been very reliable. I flew a glider at fairly long range (I'd guess 1,000 to 1,500 feet) with it a few days ago with no glitches, even though there was some kind of radio tower about 1500 feet away from where I was standing (per Google Maps).
lincoln is offline Find More Posts by lincoln
RCG Plus Member
Sign up now
to remove ads between posts
Old May 08, 2012, 04:49 PM
Registered User
Joined Aug 2002
5,811 Posts
Quote:
Originally Posted by lincoln View Post
posted also to vendor section:
Was driving in my car today with Flash 5x tx on board. Noticed it was making noises. Clicks, buzzes, and beeps. Not all the time or all that often, although there might be single clicks fairly often. I've got it on my desk right now, after several hours, and it still clicks now and then, very quietly. It still has 10.3 volts. The top and bottom of the 0 in the 10.3 volts don't show up very well. (I actually saw that the other day, but didn't think much of it.) It's never happened before, but today the switch seems flaky. If I don't press down on the switch, it doesn't always turn on. Once I turned it on and got a steady beep with nothing in the display. That went away when I turned it off and on again. Any idea what this is? Could a flaky power switch cause this stuff somehow?? I've had this radio for a dozen years now, and up to now it's always been very reliable. I flew a glider at fairly long range (I'd guess 1,000 to 1,500 feet) with it a few days ago with no glitches, even though there was some kind of radio tower about 1500 feet away from where I was standing (per Google Maps).
Crosspost Answered Manufacturer's forum.

Alan T.
Alan's Hobby, Model & RC FAQ Web Links (quick search = Ctrl+F)
A.T. is offline Find More Posts by A.T.
Reply With Quote
Old May 09, 2012, 04:00 PM
Registered User
United States, MA, Waltham
Joined Dec 2001
7,130 Posts
Got some reasonable ideas* in mfr's forum but also interested if there are other good ideas about it.


*switch trouble and/or black wire corrosion
lincoln is offline Find More Posts by lincoln
RCG Plus Member
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Mini-HowTo Frsky on hitec flash 5x AAleXX Radios 29 Sep 27, 2012 12:10 AM
Sold Hitec Flash 5X 72mhz 5ch transmitter $35 shipped pach Aircraft - General - Radio Equipment (FS/W) 1 May 02, 2012 09:12 AM
Sold Hitec Flash 5X with 4 RX's Boofer Aircraft - General - Radio Equipment (FS/W) 2 Apr 02, 2012 03:45 PM
Sold Hitec Flash 5X system with 4 receivers Boofer Aircraft - General - Radio Equipment (FS/W) 1 Nov 04, 2011 12:46 PM
Sold Hitec Flash 5X System rkirchner Aircraft - General - Radio Equipment (FS/W) 3 Sep 05, 2011 04:46 PM