HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Dec 09, 2013, 06:41 PM
Flying the TBS Discovery quad
Spyderarm's Avatar
United States, CA, Los Angeles
Joined Jan 2013
37 Posts
Discussion
TBS Discovery NAZA Crash - Power cuts out - NEED ADVICE

CRASH FOOTAGE
Crash footage from TBS Discovery - NEED ADVICE (0 min 58 sec)



I need some help figuring out what happened on this recent accident. Any advice appreciated. Here's the facts:


I did a full pre-flight of the craft that morning. Everything normal and charged up.

I was taking video of some trapeze artists on a windy day, flying on and off, three one minute flights, then landing and stopping engines each time, and then a four and a half minute flight. All this occurred on the same Turnigy 5000 mah lipo battery.

At 4:30 seconds in the original video of the last flight, after hovering in the same place for a while, not near any wires or anything, the craft suddenly loses power. On the Go Pro video, the engine sound just stops, the props stop spinning while the craft tips backward and hits ground. 3 props were broken, and both batteries - the main, and the video, popped off the craft. The JR receiver popped open.

I was not taking DVR recordings with telemetry at the time, mostly because I was within a few dozen feet of the craft the entire time, so the only footage is from the Go Pro.

At first, I thought it was a dead battery, but when I got it home, the battery showed at 11.34 volts, with 28% showing remaining in the voltmeter. Additionally, I was watching the craft religiously because I knew I must have been approaching the first level voltage warning on the NAZA, which I checked was set at 10.6 volts, 10.2 loaded. There was no flashing red light at all on the NAZA - it showed yellow because it was in attitude mode. Second, even if I somehow misinterpreted the yellow light, the craft is programmed to gradually slow down, get sluggish, and land itself. It's not supposed to just drop out of the sky.

Other things: the craft was operating pretty well recently, nothing unusual. However, the day before I did this flight, I changed the left rear motor out - the standard DJI 920kv. It seemed to operate normally in a driveway test. When I got home after the crash, everything worked - the battery, the NAZA, all four motors. The video and the Eagle Tree telemetry still work fine. Nothing else looks damaged other than the receiver which popped open (but still works), the left rear engine (gash), the Turnigy 5000 mah battery, and three broken props.

So, that's my concern now. I can't really tell what happened, and I need some advice to figure it out so I can do everything I can to make sure it doesn't happen again. Here, I was watching, and it didn't hurt anyone. I worry if this happens over the open ocean, or over people, or over areas that are closed off to me. Any advice appreciated.

Here's the last 30 seconds of the 4:30 video. Below is a list of my equipment:


Using the TBS Discovery quadcopter
NAZA flight controller
10 inch Gemfan props
JR 9503 2.4 Ghz transmitter
1.2 Ghz RMRC 300 mw video equipment
IBCrazy's Circular Polarized antennas on both sides
12 DB gain patch antenna and V transmit antenna for distance flights
600 line RMRC FPV camera
Go Pro Hero 3 Black camera for video recording
Eagle Tree telemetry and On Screen Display (OSD)
RMRC onboard barometric altimeter
RMRC DVR recorder for telemetry (shown in this video)
Loc8tor Lost Model Alarm
2 GPS Devices on board - NAZA and Eagle Tree
Turnigy 5000 mah lipo batteries
Adobe Premiere Elements Video Editing
Lenovo laptop computers
Go Pro Professional Cases

Spyderarm
Spyderarm is offline Find More Posts by Spyderarm
Reply With Quote
Sign up now
to remove ads between posts
Old Dec 09, 2013, 06:46 PM
Registered User
United States, KS, Overland Park
Joined May 2013
56 Posts
How old is the battery, I had a similar incident on a new battery. Just fell like a rock, battery completely shut off when it got low. However out of a 3000mah battery charger recharged it 2550. I did a few test after that and all did same thing, just stopped working when it got low. Now on the same batteries 5 months later, when they get low they slow reduce power. They did not do that when they were newer.
inis is online now Find More Posts by inis
Reply With Quote
Old Dec 10, 2013, 02:05 PM
Flying the TBS Discovery quad
Spyderarm's Avatar
United States, CA, Los Angeles
Joined Jan 2013
37 Posts
Battery

Thanks for the observation - YES - the battery would be considered fairly old - maybe 100, 150 charges on it. Your observation could be exactly what happened - that over time, the 4000 mah that I cound on getting out of it could slowly drop and suddenly at 3500 mah the battery is too low to continue. HOWEVER, the voltage should trigger the NAZA warnings and the craft should land, no? Even if it came down to 10.2 volts after 1000 mah, the warning should kick in regardless?
Spyderarm is offline Find More Posts by Spyderarm
Reply With Quote
Old Dec 10, 2013, 02:47 PM
Registered User
Canada, BC, Vancouver
Joined Aug 2011
17 Posts
Sudden power loss

Sorry about your crash. The power loss was very sudden so I'm not sure if it was due to a old battery.

It sounded like you had lost power instantly. I would check all my connections especially to the PDB.

For a while, my quad would fall out of the sky due to instant power loss and it turned out to be the Deans connector (authentic), aka nylon T-Connector. The little metal "reed" that acts as a spring to provide friction to keep the connector connected, became flattened, thus not providing any tension. I tried to bend the reed back into shape, but it would just flatten again with use. While flying, the connector only has to vibrate loose for a moment, to cause a crash.
I have since replaced all my Deans connectors with the XT60's and have been flying problem free since.

Hope this helps
hotspur is offline Find More Posts by hotspur
Last edited by hotspur; Dec 11, 2013 at 03:30 AM.
Reply With Quote
Old Dec 14, 2013, 04:12 PM
Registered User
Canada, BC, Vancouver
Joined Aug 2011
17 Posts
Common problem with Deans

I just found this post about a very similar experience to you. His Dean connectors were at fault. The youtube video on his post shows the problem during a bench test.

http://www.rcgroups.com/forums/showthread.php?t=2056009
hotspur is offline Find More Posts by hotspur
Last edited by hotspur; Dec 15, 2013 at 02:36 AM.
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Cheap TBS Discovery Pro, TBS Discovery, TBS 900Kv motors and ESC's, Graupner props dr.felegis Aircraft - Electric - Multirotor (FS/W) 9 Jun 25, 2014 10:18 PM
Sold TBS Discovery Pro Gimbal Quadcopter - T-Motor, TBS69, Naza M + GPS, EzoSD, Dragonlink Hmerly Aircraft - Electric - Multirotor (FS/W) 2 Nov 24, 2013 12:39 PM
Discussion need help setting up tbs discovery with naza and dx8 nsolcis Multirotor Talk 3 Jun 30, 2013 12:57 AM
Discussion tbs discovery build : need some advice from you pros nsolcis Multirotor Talk 1 Jun 18, 2013 03:50 AM
Sold Tbs discovery part out w/Naza GPS DbleX Aircraft - Electric - Multirotor (FS/W) 6 Feb 27, 2013 07:34 PM