HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Aug 15, 2014, 09:55 AM
Registered User
Joined Mar 2004
8 Posts
Question
All my optima receiver acting up.

Hi all

I figured out a part of the problem after writing all this, skip summary and question if you want.


I have been flying with a Minima in a glider and Optima 7 in a electric jet, for over a year, with no problems.
I decided to change the rest of my receivers to 2.4 Ghz so i got 3 more receivers.
I like to have telemetry on my glider, so I change the Minima for a Optima 6 lite.
When testing the glider, the elevator doesn't work very well and the tow release and rudder, is jumping around, the other servos works, but if i operate them quickly, the same thing happens.
The blue LED gives some weak flashes, when all this happens.
Another thing thing is, the elevator servo has very little holding power and if i move it, the same thing happens (servo jumping)
power supply is 4 cell NiMh, at 5v and 4.8v under load (A9 display)
I tried Optima 6, 6 lite, 7 and 9.. all with same result.
Changing back to Mine and all is working.

Ok test setup. 3 servos from the drawer, and almost same result.

New test, Testet with 2 reciver packs one for the reciver and one for servo side, and know it working.. hmm...
ok testet with, the other battery pack and know it works... hmm


Summary........
Battery pack 1 works with Minima not Optima xx (5.0v and 4.6 under load external voltmeter)
Battery pack 2 works With Minima and Optima xx (5.4v)

I have not update firmware on the receivers......
ofcurse i could go with Minima in all my models, but I'm disappointed, if Optima handels the voltage so badly.

Any input on this?
Elfly is offline Find More Posts by Elfly
Last edited by Elfly; Aug 15, 2014 at 10:02 AM.
Reply With Quote
Sign up now
to remove ads between posts
Old Aug 15, 2014, 10:09 AM
-----
Woodstock 1's Avatar
Ireland, County Kerry, Kerry
Joined Dec 2005
6,994 Posts
All your optima receiver belong to us

Sorry, couldn't resist ...
Woodstock 1 is offline Find More Posts by Woodstock 1
Reply With Quote
Old Aug 15, 2014, 10:22 AM
Registered User
Joined Mar 2004
8 Posts
Quote:
Originally Posted by Woodstock 1 View Post
Sorry, couldn't resist ...
At the moment, you cane have them, I not sure I want to fly with them, maybe in a model with ESC/BEC..
Elfly is offline Find More Posts by Elfly
Reply With Quote
Old Aug 15, 2014, 10:59 AM
-----
Woodstock 1's Avatar
Ireland, County Kerry, Kerry
Joined Dec 2005
6,994 Posts
I have had nothing but stellar performance from all my Hitec 2.4 receivers over a good 4 + years now, , so I'd be happy to take them off your hands!
Woodstock 1 is offline Find More Posts by Woodstock 1
Reply With Quote
Old Aug 16, 2014, 12:31 PM
Registered User
Joined Mar 2004
8 Posts
Is the operating voltage for optima 4.8v ?

Anyone using 4 NiMh receiver pack on optima?
Elfly is offline Find More Posts by Elfly
Reply With Quote
Old Aug 16, 2014, 02:09 PM
most exalted one
Canada, BC, Blind Bay
Joined Aug 2002
3,603 Posts
People definitely are. Depending on servo draw etc the NiMH may go low, but that is for you to determine. Life 6.6 work for our local crowd with any tx Rx set up.
4*60 is offline Find More Posts by 4*60
Reply With Quote
Old Aug 17, 2014, 01:32 PM
Registered User
Joined Mar 2004
8 Posts
Quote:
Originally Posted by 4*60 View Post
People definitely are. Depending on servo draw etc the NiMH may go low, but that is for you to determine. Life 6.6 work for our local crowd with any tx Rx set up.
Don't think my servos will survive 6.6 V....
Elfly is offline Find More Posts by Elfly
Reply With Quote
Old Aug 22, 2014, 10:30 AM
Registered User
Canada, ON, Ottawa
Joined Mar 2000
1,136 Posts
You've said the optima receivers work with one pack that maintains 5.4v and doesn't work with one that only maintains 4.6v under load. Why wouldn't you just replace the battery that is suspicious rather than suspecting that the receivers are all bad?
JeffD is offline Find More Posts by JeffD
Reply With Quote
Old Aug 22, 2014, 01:56 PM
Registered User
Joined Mar 2004
8 Posts
Quote:
Originally Posted by JeffD View Post
You've said the optima receivers work with one pack that maintains 5.4v and doesn't work with one that only maintains 4.6v under load. Why wouldn't you just replace the battery that is suspicious rather than suspecting that the receivers are all bad?

If I don't use a BEC, I use 4 NiMh 1.2v 4 = 4.8 v and that is too small a margin or?

The 5.4v is fresh from the charger..
Elfly is offline Find More Posts by Elfly
Reply With Quote
Old Aug 24, 2014, 12:34 AM
Registered User
Australia
Joined Oct 2007
7 Posts
When you changed to Optima did you rebind your Transmitter to Optima? I know that there is an individual link method for each of Optima (has telemetry) and Minima (no telemetry).

Hope this helps.
Chris De Jon is offline Find More Posts by Chris De Jon
Reply With Quote
Old Aug 24, 2014, 01:22 AM
Registered User
Joined Mar 2004
8 Posts
Quote:
Originally Posted by Chris De Jon View Post
When you changed to Optima did you rebind your Transmitter to Optima? I know that there is an individual link method for each of Optima (has telemetry) and Minima (no telemetry).

Hope this helps.
Yes I did rebind.
Elfly is offline Find More Posts by Elfly
Reply With Quote
Old Sep 02, 2014, 01:10 AM
Registered User
E-Challenged's Avatar
United States, CA, Garden Grove
Joined Oct 2000
12,229 Posts
Iv'e had some problems with binding A9 and Optima receivers. It is possible to unbind all of your receivers in the process of doing a range check such that you need to rebind all of your receivers to the A9 following the instructions to the letter and watching for correct LED "blinks" and "solids" and module beeps. Make sure that you have the A9 in "normal mode" (not "scan" mode)and do the binding EXACTLY as instructed in the confusing manual for "normal mode". It's much easier to bind receivers to A9 using a separate 4-cell battery pack and switch harness and a single servo as supplied with the complete system (Instead of binding with receiver inside in the model) I dislike the fussy A9/Optima binding procedure. If it is not done correctly, your model may act very strangely.
E-Challenged is online now Find More Posts by E-Challenged
Reply With Quote
Old Sep 02, 2014, 02:11 AM
most exalted one
Canada, BC, Blind Bay
Joined Aug 2002
3,603 Posts
Quote:
Originally Posted by Elfly View Post
If I don't use a BEC, I use 4 NiMh 1.2v 4 = 4.8 v and that is too small a margin or?

The 5.4v is fresh from the charger..
Depends on the pack. High capacity NIMH don't always put out like NICD or low capacity NIMH so when the draw starts voltage might go way down. Just because it might be 2500mah doesn't mean it'll give you 2.5 amps at good voltage.
4*60 is offline Find More Posts by 4*60
Reply With Quote
Old Sep 02, 2014, 02:13 AM
most exalted one
Canada, BC, Blind Bay
Joined Aug 2002
3,603 Posts
Quote:
Originally Posted by E-Challenged View Post
Iv'e had some problems with binding A9 and Optima receivers. It is possible to unbind all of your receivers in the process of doing a range check such that you need to rebind all of your receivers to the A9 following the instructions to the letter and watching for correct LED "blinks" and "solids" and module beeps. Make sure that you have the A9 in "normal mode" (not "scan" mode)and do the binding EXACTLY as instructed in the confusing manual for "normal mode". It's much easier to bind receivers to A9 using a separate 4-cell battery pack and switch harness and a single servo as supplied with the complete system (Instead of binding with receiver inside in the model) I dislike the fussy A9/Optima binding procedure. If it is not done correctly, your model may act very strangely.
The unbind occurs if you push the button too long and go past the range chack and into scan. Then you need to rebind. Don't hold the button beyond necessary.
4*60 is offline Find More Posts by 4*60
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Sold Hitec Optima Receivers, 1 Optima 6, 2 Optima 7 and 1 Optima 9 Gadget99 Aircraft - General - Radio Equipment (FS/W) 4 Jul 12, 2014 09:05 AM
Alert Approval of Affordable Care Act Inches Up.. They like it, even more Broken Wings Life, The Universe, and Politics 0 Oct 23, 2013 04:25 PM
Sold (all for $100) Hitec Recievers (2) Optima 6 and (1) Optima 7 ToxicBanana Aircraft - General - Radio Equipment (FS/W) 7 Oct 17, 2013 04:14 PM
Help! all servos acting crazy on throttle up janmykelg Beginner Training Area (Heli-Electric) 59 Dec 06, 2012 05:09 PM
Help! Superfreak Bat Rebuild Acting up and not flying at all!! albysurfin Slope 9 Jun 26, 2007 11:45 PM