HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Sep 13, 2012, 10:49 PM
Registered User
Joined Jan 2010
126 Posts
Discussion
smoked esc cause board failure?

So after 3 years of no real issues I changed the setup on my big quad. trying to get gps board and main board away from magnetic interference that was being cause by the main esc wires..well as things go for no reason I can see one of my 60a PLUSH escs smoked bigtime.

after replace the board will not control new esc

New esc has been tested to work fine.

so did the main board smoke as well? it looks and smells fine..flashes firmware fine.

thoughts?
obinolson is offline Find More Posts by obinolson
Reply With Quote
Sign up now
to remove ads between posts
Old Sep 13, 2012, 11:39 PM
USA, CA, Mountain View
Joined Dec 2008
612 Posts
Quote:
Originally Posted by obinolson View Post
So after 3 years of no real issues I changed the setup on my big quad. trying to get gps board and main board away from magnetic interference that was being cause by the main esc wires..well as things go for no reason I can see one of my 60a PLUSH escs smoked bigtime.

after replace the board will not control new esc

New esc has been tested to work fine.

so did the main board smoke as well? it looks and smells fine..flashes firmware fine.

thoughts?
Will the new esc work on any other board port?
Earl E Adobtr is offline Find More Posts by Earl E Adobtr
RCG Plus Member
Latest blog entry: Current Folding Quad Project
Reply With Quote
Old Sep 14, 2012, 07:37 AM
Al Ducharme
photronix's Avatar
Orlando, FL
Joined Jan 2005
734 Posts
Thats a good thing to try. Also, I would like to know what port burnt out (Yellow, Green, etc).
photronix is offline Find More Posts by photronix
Reply With Quote
Old Sep 14, 2012, 08:19 AM
Registered User
Joined Jan 2010
126 Posts
Board readings go nuts in setup client when main power is connected to proboard as well.
obinolson is offline Find More Posts by obinolson
Reply With Quote
Old Sep 14, 2012, 08:39 AM
Registered User
Joined Jan 2010
126 Posts
all front x8 motors do not fire and one back right bottom does not fire now

front top right esc smoked
obinolson is offline Find More Posts by obinolson
Reply With Quote
Old Sep 14, 2012, 08:44 AM
Registered User
Joined Jan 2010
126 Posts
purple orange yellw pink no longer power up..the esc just beep as if they are not getting a signal.
obinolson is offline Find More Posts by obinolson
Reply With Quote
Old Sep 22, 2012, 06:51 PM
Registered User
Joined Jan 2010
126 Posts
funny...brand new board acts the same...put all RED esc wires back connected to the board and it all works now.

I guess old board was probably fine as well.

still can't get compass calibrated though..trying everything. anyone have any problems w this? I have never one time had it working well. just removed all the metal from around the board....what is the basic distance that metal nuts or screws etc MUST be in order to not pull magnetic heading off?
obinolson is offline Find More Posts by obinolson
Reply With Quote
Old Sep 23, 2012, 09:40 AM
JZSlenker's Avatar
United States, PA, Harrisburg
Joined Aug 2011
377 Posts
If it works (now) with all the red escs connected you probably have one or two bad becs in the escs. You should only have one esc red wire connected. If you have more than one the regulators are actually working against each other. You could have a reset in mid air. Not good. I would connect only one red wire, one at a time and find out which esc(s) have bad becs. Then use one of the good ones. As for the mag. Ideally you want all ferrous metal off your bird. I replaced all fasteners with aluminum and noticed a huge difference. Also make sure the battery lines to your escs are parallel (and touching one another) or twisted. The further from the mag you can get these the better.
JZSlenker is offline Find More Posts by JZSlenker
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help! Burnt out Paraboard, WHAT HAPPENED. The fuse didn't burn out, the board was smoking jasper7821 Batteries and Chargers 61 Apr 23, 2012 02:18 PM
Discussion magic smoke: ESC killed motor, or motor ESC ? mopetista Power Systems 4 Mar 13, 2012 03:50 AM
Discussion servo failure caused receiver failure Jetskeeter Radios 1 Jul 03, 2008 12:15 PM
Can retarded motor timing cause controller failure? All__talk Electric Plane Talk 1 Jan 20, 2003 05:02 PM
Anyone see a HS81 fail and cause complete radio failure??? rparigoris Electric Plane Talk 1 Nov 21, 2002 10:09 PM