SMALL - Telemetry SMALL - Radio
Thread Tools
Old Jun 14, 2015, 06:58 AM
pete491 is offline
Find More Posts by pete491
Registered User
USA, MO, St Charles
Joined Dec 2006
53 Posts
Discussion
Aurora 9 Crash

Guys,

I was flying my T-rex700 yesterday having a great time as usual. I was hovering inverted in front of me about 15 feet up and suddenly lost power. It was like I had hit throttle hold. I still had control but no power. I had just enough time to turn it over then had a hard landing with broken gear and blades. No other damage.

When I got to the heli I could hear beeping. I'm not sure what this meant. When I got the heli home I powered everything up and all worked as it should. The motor initialized and ran.

What do you think happened?

Thanks!
pete491 is offline Find More Posts by pete491
Reply With Quote
Sign up now
to remove ads between posts
Old Jun 15, 2015, 06:18 AM
JeffD is offline
Find More Posts by JeffD
Registered User
Joined Mar 2000
1,190 Posts
Wouldn't blame the Aurora. Beeping from your heli probably means an issue with the speed control. What you describe sounds like your battery on the heli hit the ESCs low voltage cutoff and the ESC was set for a hard cutoff.
JeffD is offline Find More Posts by JeffD
Last edited by JeffD; Jun 16, 2015 at 10:13 AM.
Reply With Quote
Old Jun 16, 2015, 09:23 AM
Xpress.. is offline
Find More Posts by Xpress..
Hitec RCD CSR
Xpress..'s Avatar
United States, CA, Alpine
Joined Oct 2007
22,015 Posts
Sorry to hear about the crash! I know the feeling when your pride and joy goes in.

That being said, I don't think this was an issue with the radio system. The ESC likely sensed a low voltage and cut the power as JeffD stated. I would double check your ESC's settings and ensure the throttle cut is either turned off or set to soft.
Xpress.. is offline Find More Posts by Xpress..
Reply With Quote
Old Jun 16, 2015, 09:54 PM
pete491 is offline
Find More Posts by pete491
Registered User
USA, MO, St Charles
Joined Dec 2006
53 Posts
It was a low voltage issue. A bad solder was causing intermittent low voltage. All is good now.

Thanks!!
pete491 is offline Find More Posts by pete491
Reply With Quote


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
For Sale Complete Aurora 9 set, near new-lower price! c300 Aircraft - General - Radio Equipment (FS/W) 14 May 20, 2015 06:12 PM
For Sale Hitec Aurora 9 9-Channel 2.4GHz Tx/7-Channel Receiver yser Aircraft - General - Radio Equipment (FS/W) 0 May 10, 2015 10:46 AM
Careful! Aurora 9 Tx, Optima 9 Rx + TREES = Crash!? pardus Hitec/Multiplex USA 10 Oct 29, 2011 03:17 PM