SMALL - espritmodel.com SMALL - Telemetry SMALL - Radio
Reply
Thread Tools
Old Aug 15, 2012, 06:03 PM
Registered User
Joined Aug 2012
1 Posts
Discussion
KKMulticopter V5.5 Problems

Hey all, so I'm building a quadcopter and running into issues trying to get it to arm. If anyone has got the kkmulticopter V5.5 to run I can use some advice!
I'm using a kkmulticopter controller blackboard V5.5 with firmware V2.7. A Fly Sky transmitter model FS-CT6b and Fly Fky reciever Model FS-R6b.
Really though, I know the problem lies with the controller/the process I am using to start it up.
I have gotten it to give me the 3 beeps signaling that it is communicating, the 4motors will then fire up at the same speed and go faster as I increase the throttle. However, that is all that works. No aileron, elevator, or rudder will do anything. So it is a quadcopter that only has throttle control. As well, the yaw pot must be set all the way CCW or I get no response from the motors at all (even though the manual says to calibrate with Yaw at zero, but then go back to 50%).
The weird thing is when I hook up standard servos instead to the motors, the right-left (aileron, elevator, rudder) responds and the servos turn depending on the direction of the joystick. So I know the transmitter and reciever work. I flashed the controller with the latest firmware, then bought another board that came with firmware already on it and it does the exact same thing! HELP!
GhettoFlite is offline Find More Posts by GhettoFlite
Reply With Quote
Sign up now
to remove ads between posts
Old Nov 05, 2012, 08:55 PM
Registered User
Joined Nov 2012
2 Posts
Im also having the same problem! After calibrating the ESC throttle control, I return the yaw to 50%. Then next time I plug in the battery its like the throttle control was never set and I have to do it again and the only thing that works is the throttle.
Pleas help me too!
micjayger is offline Find More Posts by micjayger
Reply With Quote
Old Nov 05, 2012, 09:05 PM
Registered User
Joined Nov 2012
2 Posts
I figured it out! I feel really stupid now! You have to activate the board. by pushing throttle down all the way then the same stick to the right. If that doesn't work set your trim down some till the blue light stays on! good luck!
micjayger is offline Find More Posts by micjayger
Reply With Quote
Old Mar 05, 2013, 01:32 PM
Registered User
Joined Feb 2013
11 Posts
i'm having the same problem too. when i throttle up my motors don't even spin. I get all the beeps and binds fine, but nothing happens when i move the sticks. At what point do you throttle all the way down and right? after it binds(the stick is all the down at that point @power up) so just move it to the right? as for the yaw pot i also notice that I can spin the motors if the yaw pot is turned fully CCW. but when I turn it back nothing works.
lionels is offline Find More Posts by lionels
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion KKmulticopter V5.5 Controller BlackBoard V2.1 Program navihawk Multirotor Talk 3 Oct 04, 2013 02:57 AM
Sold KKMulticopter Controller V5.5 j5cub Aircraft - Electric - Multirotor (FS/W) 0 Jun 22, 2012 10:43 PM
Discussion MultiWii SE or KKmulticopter V5.5 - where should I go next wkm1 Multirotor Talk 5 May 31, 2012 01:40 PM
Discussion $22.9 Latest KKmulticopter controller V5.5 Board,V2.3 program coolmans Hot Online Deals 0 Apr 19, 2012 02:20 PM
Discussion X copter based on KK V5.5 board liftof problems riahut.com Multirotor Talk 1 Apr 07, 2012 11:41 PM