Thread Tools
Old May 19, 2015, 02:45 AM
dino_squirrel is offline
Find More Posts by dino_squirrel
Registered User
Joined Jan 2011
72 Posts
Get ready for this - Naza V2

So I built my Tarot 680pro, DJI E800 motors, Naza V2 flgight controller, and have a Pulse 6s 5500mah battery and have flown about 20 times. Only 20 times because I get such long flights that I get done what I need to get done.

So this weird thing happened....
I'm using the Airtronics 10G controller for flight and Aquila 6 for gimbal and the battery on my main controller went low so I got the alarm but the aircraft was feet away and doing simple maneuvers so I wasn't concerned. Well, about 17 mins in I noticed that full throttle did nothing but i still have control otherwise so i knew the controller wasn't dead. Either way, I landed, put fresh batteries in everything for safety and went to go back up - Nothing... GPS locked, motors checks, lights going, everything normal but it refused to arm the ESCs. I tried for ten minutes. I moved the sticks in every direction that would arm, I rebooted everything about 10 times, I moved the aircraft to a different location, i unplugged gps, i plugged in my emergency BEC, I literally did ever field service I could without computer.

So tonight I plug it into the computer to see if perhaps my radio was sending a different center stick position, but nope. All stick positions are calibrated properly. I reboot and go to try it, nothing, still no arming. GPS is flashing ONLY green, so I've got satellites for days. I again play with the sticks - All four corners opposite movement, top outside, center, then inside bottom, it armed! Dubya tee eff!? So I shut down, and try to re-arm the normal way, nothing. no matter how long I hold, nothing. So I do that spin thing again and it works, again.... So I abridge the motion, just top outsides on sticks, then inside bottom, nothing. I start centered, then top outside, then bottom inside, armed. Repeated this 5 times and it seemed to work... most of the time. I tried the normal arming procedure and nothing, not once had it worked.

summary - So, I flew, I landed, changed batteries, wouldn't arm. Took home, strange arming procedure produced shoddy results. Before I RMA this, is there something I don't know?

Also, a little side note. I was flying inside a VERY large warehouse shooting video close to an airport but I didn't even see one satellite so I flew slowly and all was fine. When I changed batteries, it wouldn't arm (this was a moth ago). So I held down the sticks for 10 seconds and then it finally armed. That new 10 second hold became the normal arming! WHY?! It changed for no reason.

Should I just send this sucker in?
dino_squirrel is offline Find More Posts by dino_squirrel
Reply With Quote
Sign up now
to remove ads between posts

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion RC pilots, get ready for THIS... jetmanhuss Simulators 1 May 02, 2015 01:28 AM
Help! Naza lite (v2) not getting a ANY sattelite fix, HELP! borgqueenx Multirotor Electronics 3 Feb 22, 2015 08:45 AM
Sold DJI 450 w/ Naza M V2 w/ GPS (**GoPro Ready**) Price Lowered $$ FlyingGorilla83 Aircraft - Electric - Multirotor (FS/W) 3 Aug 21, 2013 05:06 PM
Sold DJI 450 w/ Naza M V2 w/ GPS (**GoPro Ready**) FlyingGorilla83 Aircraft - Electric - Multirotor (FS/W) 4 Aug 19, 2013 11:18 PM
Yippee! Getting piccolo v2 ready for maiden! rozak08 Micro Helis 8 Aug 13, 2007 09:40 PM