HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Dec 05, 2012, 10:25 AM
Registered User
Joined Sep 2012
9 Posts
Discussion
Blade Nano CPX set up Help!!!!!!

Hello everyone. I purchased a new Nano and it is one incredible little bird BUT....... I have bound it to my new JR 9503 TX and used the settings used for the DX8 but I'm having an issue. During basic hover the tail holds fine but with trimmed as much as possible the Nano wants to basically hover on its own in a tight circle. If a person can visualize then it's like your behind the bird facing the tail and it wants to basically circle a dime with tail holding at 6 O'Clock.................................. I'm not sure if I'm missing a setting in the swash adjustment but when bound to a 6i there are no issues so it must be a setting on the TX just not sure what. Any help would be great. Thank you!
Coufalj is offline Find More Posts by Coufalj
Reply With Quote
Sign up now
to remove ads between posts
Old Dec 08, 2012, 10:18 AM
Registered User
United States, CA
Joined Jan 2012
1,385 Posts
Quote:
Originally Posted by Coufalj View Post
Hello everyone. I purchased a new Nano and it is one incredible little bird BUT....... I have bound it to my new JR 9503 TX and used the settings used for the DX8 but I'm having an issue. During basic hover the tail holds fine but with trimmed as much as possible the Nano wants to basically hover on its own in a tight circle. If a person can visualize then it's like your behind the bird facing the tail and it wants to basically circle a dime with tail holding at 6 O'Clock.................................. I'm not sure if I'm missing a setting in the swash adjustment but when bound to a 6i there are no issues so it must be a setting on the TX just not sure what. Any help would be great. Thank you!
It sounds like the feathering shaft nut is too tight. Take the blades off and use the two black tools that came with the heli to back the nut off until you have about a hair width of lateral play when you take hold of the blade grips and push in and out on them. It may take more than one adjustment to find the sweet spot.
J_skaggs is online now Find More Posts by J_skaggs
Reply With Quote
Old Apr 08, 2013, 05:20 PM
Registered User
United Kingdom, London
Joined Feb 2013
33 Posts
Quote:
Originally Posted by J_skaggs View Post
It sounds like the feathering shaft nut is too tight. Take the blades off and use the two black tools that came with the heli to back the nut off until you have about a hair width of lateral play when you take hold of the blade grips and push in and out on them. It may take more than one adjustment to find the sweet spot.
Tomorrow I'm gonna try this, if it helps fixing this issue I will ow you one forever
Gian8 is offline Find More Posts by Gian8
Reply With Quote
Old Apr 08, 2013, 11:31 PM
Heli's rule!
dacaur's Avatar
Midvale, Utah, USA
Joined Mar 2005
8,458 Posts
interesting that it doesnt do it when bound to the dx6i....

Try taking out all the trim, you should not be using any trim at all on this heli.... could definitely cause problems....
There really aren't any settings in the swash you can mess up, since it uses a basic 90 (1 servo) swash. all the ccpm mixing is done in the 3-in-1....
dacaur is offline Find More Posts by dacaur
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
New Product Blade nano CPX - even smaller than the mCPX! zadaw Micro Helis 9057 Today 06:52 AM
Discussion Setting up a Blade Nano CPX with a Spektrum DX18 transmitter problem earlwb Electric Heli Talk 4 Mar 08, 2014 11:04 PM
Help! I need help setting up my JR 9303 for Blade 450 3D jude165 Radios 2 Jan 20, 2013 10:16 PM
Discussion Need help setting up 3 blade head thenodemaster Scale Helicopters 8 Dec 14, 2012 01:15 PM
Discussion Needing help setting up Nano with DX7S kushal_22 Beginner Training Area (Heli-Electric) 31 Nov 01, 2012 12:26 AM