HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Sep 02, 2013, 06:59 AM
Registered User
Joined Sep 2013
1 Posts
Discussion
CC mamba calibration

Hi

I am having problem to calibrate the CC Mamba XL2.
Here is what I've done:
1. Radio on, Full throttle position
2. ESC on, light changed to green and armed
3. when red light flashing, applied full brake, another green and red both flashing
4. trying to set neutral, but no yellow light
after that there were a few tones then ONLY green flashing afterwards.
nothing blinded and only green flashing

Is there anything wrong on calibration or the ESC is fault unit?

Checked everything
- Using Futaba and set throttle to rev (also tried normal)
- Set all to EPA 100, Sub trim - 0 as neutral
- Receiver tested ok, motor connected, battery charged
- Wire connected in the correct sequence (orange, red, brown)
- Updated firmware using castle link

I can't think of anything else, any idea??
Bctech is offline Find More Posts by Bctech
Reply With Quote
Sign up now
to remove ads between posts
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
For Sale CC Mamba Monster 1/8 th esc with C link tconners Cars - Cars and Parts (FS/W) 5 May 25, 2013 03:28 PM
Discussion NAZA GPS Calibration ERROR inside calibration mode nuki Multirotor Electronics 2 Feb 20, 2013 01:40 AM
Discussion CC PHOENIX 35 and auto calibration throttle quenda Castle Creations 9 Dec 06, 2009 07:44 PM
Question CC-35 " auto calibrating" problem. TreeDiver Castle Creations 8 Jul 03, 2006 10:37 AM
CC phoenix auto calibrate throttle question NCguy Power Systems 12 Sep 27, 2005 09:44 AM