Espritmodel.com Telemetry Radio
Reply
Thread Tools
Old Jul 03, 2010, 03:52 PM
Registered User
Joined Apr 2010
43 Posts
Discussion
E-flite glitchy servo fixed

Greetings,

I have a brick from an E-Flite Blade MCX that I have installed into a micro sailboat.

The original heli was destroyed in a bad crash and I picked up the electronics cheap.

After installing the brick I discovered one of the servos would stick at one end of travel and was trying to fing that limit (it was still under power at the end of it's travel).

The other servo was real glitchy. I started with the jamming servo. I removed the 4 tiny screws that secured it to the board. Upon examination I found two strips under the servo and a small set of contacts on the servo carrier.

Both strips on the board were black and under a magnifing glass appeared rough. I cleaned the two strips with alcohol. One cleaned up silver and the other remained black. I reinstalled the servo and tested it. It operated very well. It was smooth and solid and no longer jammed.

On the glitchy servo the silver strip was only half black. I cleaned and reinstalled it. The glitchy behavior is gone. The servos both operate smooth and clean.

A new brick will run about $40. A half hour may save you from having to replace it.

Now the question is... Will it be reliable? I guess I'll see. It won't get to much exercise in my micro sailboat so I think for my purpose it will be fine.

Hope this helps someone

Good Luck
Glen
Grayco is offline Find More Posts by Grayco
Reply With Quote
Sign up now
to remove ads between posts
Old Jul 03, 2010, 04:49 PM
Registered User
UK, Midlothian, Edinburgh
Joined Jan 2010
455 Posts
Nice one! I might try that tomorrow as my servo on my msr is a little jittery . Cheers!
captaintomo is offline Find More Posts by captaintomo
Reply With Quote
Old Jul 03, 2010, 06:53 PM
Blade mSR freak
hydro_pyro's Avatar
Irish Hills - SE Michigan
Joined Jan 2010
2,054 Posts
Common problem, good fix. Should be reliable again, but the DO eventually wear out the tracks on the board.
hydro_pyro is offline Find More Posts by hydro_pyro
Reply With Quote
Old Jul 04, 2010, 09:20 AM
Registered User
UK, Midlothian, Edinburgh
Joined Jan 2010
455 Posts
Will white spirit work? The stuff for cleaning paintbrushes
captaintomo is offline Find More Posts by captaintomo
Reply With Quote
Old Jul 04, 2010, 05:24 PM
Kiwi in Germany
whakahere's Avatar
Germany
Joined Jun 2010
2,255 Posts
I am having this problem. With large movements it works but when I am doing micro movements it jams.

So let me get this right (new to heli's)

I need to take it off the board, clean the track and the put it back on again?
whakahere is offline Find More Posts by whakahere
Reply With Quote
Old Jul 04, 2010, 06:35 PM
Registered User
Joined Apr 2010
43 Posts
Don't know

Quote:
Originally Posted by captaintomo View Post
Will white spirit work? The stuff for cleaning paintbrushes
One of the tracks is black. I don't know what it is made of or if mineral spirits will attack it. I know alcohol worked well.
Grayco is offline Find More Posts by Grayco
Reply With Quote
Old Jul 04, 2010, 06:37 PM
Registered User
Joined Apr 2010
43 Posts
That's what I did

Quote:
Originally Posted by whakahere View Post
I am having this problem. With large movements it works but when I am doing micro movements it jams.

So let me get this right (new to heli's)

I need to take it off the board, clean the track and the put it back on again?
I just cleaned the two tracks. One cleaned to silver, the other remained black.
Grayco is offline Find More Posts by Grayco
Reply With Quote
Old Jul 05, 2010, 06:04 AM
Registered User
UK, Midlothian, Edinburgh
Joined Jan 2010
455 Posts
I done it with spirit. On the servo contacts there was bits of black on the contacts. On the strips on the board it was almost black, So i cleaned that and it turned silver. Let it dry and screwed the servosa back on. It was a whole lot better but the other servo jitters on full back stick. never done that before
captaintomo is offline Find More Posts by captaintomo
Reply With Quote
Old Jul 05, 2010, 01:37 PM
Registered User
Joined Apr 2010
43 Posts
Did You?

Quote:
Originally Posted by captaintomo View Post
I done it with spirit. On the servo contacts there was bits of black on the contacts. On the strips on the board it was almost black, So i cleaned that and it turned silver. Let it dry and screwed the servosa back on. It was a whole lot better but the other servo jitters on full back stick. never done that before
Did you clean them both or just the one?
Grayco is offline Find More Posts by Grayco
Reply With Quote
Old Jul 07, 2010, 02:56 AM
Registered User
UK, Midlothian, Edinburgh
Joined Jan 2010
455 Posts
Quote:
Originally Posted by Grayco View Post
Did you clean them both or just the one?
Both
captaintomo is offline Find More Posts by captaintomo
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion E-Flite Apprentice 15e replacement aileron servo arm, pushrod and clevis jono80 Beginner Training Area (Aircraft-Electric) 14 Feb 25, 2012 07:15 PM
Discussion E-Flite Pro 25 ESC - will not arm with Futaba 9C - Fixed Henna_Ojisan Power Systems 29 May 05, 2011 01:04 AM
Question Equivalant servo for the E-flite MN48 flying jeep Radios 7 Apr 08, 2010 05:21 PM
Sold E-Flite G110 gyro & E-Flite DS75H servo combo Mike_Then Aircraft - Electric - Helis (FS/W) 6 May 28, 2009 03:44 PM
Sold NIP E-flite F-15 hardware/retracts/fixed gear corsair nut Aircraft - Electric - Jets (FS/W) 1 Jan 26, 2009 06:16 PM