New Products Flash Sale
Thread Tools
Old Oct 01, 2015, 03:02 AM
dragonblade is offline
Find More Posts by dragonblade
Registered User
dragonblade's Avatar
Joined Apr 2014
701 Posts
Ive just come back from my flight. There was one solid green bar and one flashing one on the battery. And the red LEDs were flashing as usual. And the quad was acting a bit strange. I put it in GPS mode but it was drifting heaps. And this was after I waited for a good GPS lock (no more red lights.) It was acting like it was in Atti mode except that it rose by itself early on. All of a sudden, it tipped over and fell out of the sky. I engaged CSC as quickly as I could and yet the blades still spun into the ground at least a second afterwards.

The instruction manual doesn't mention this but is CSC meant to stop the motors immediately or is there normally some delay afterwards? Yesterday, CSC did seem to stop the motors immediately when the Phantom was in trouble though I'm annoyed about what happened just now. I would like to keep the motors in good condition. I know that some people grab the landing gear of the Phantom during flight instead of landing it (not sure if I'm brave enough to do that – look what happened to Inrique Iglesias on stage.) Though in instances where the quad falls out of the sky without warning, I don't have a lot of faith in saving the motors from potential harm. With the cheap mini quads that I usually fly, it's so quick and easy to cut the throttle when I need to – just lower the throttle stick down.

Edit: actually I'm wondering why my Phantom fell out of the sky this afternoon. The motors did not cut out. The blades were still spinning when it hit the ground. It flipped over in mid air and landed on it's side with the motors still active.
dragonblade is offline Find More Posts by dragonblade
Last edited by dragonblade; Oct 01, 2015 at 04:05 AM.
Reply With Quote
Sign up now
to remove ads between posts
Old Oct 03, 2015, 08:46 AM
hs748 is online now
Find More Posts by hs748
Registered User
Canada, MB, Winnipeg
Joined Sep 2002
735 Posts

Two issues I am having with one of my V2's:

1)I am now getting a continually red flashing led on power up.

IMG 0119 (0 min 9 sec)

2) When performing the battery life test on a Phantom 2 lipo ( holding down the power button for 5 seconds), are you supposed two get the green blinking LED's? Three of my green led's on the battery stay on, one goes out. Think I may have a bad battery?

IMG 0122 (0 min 12 sec)
hs748 is online now Find More Posts by hs748
Reply With Quote
Old Oct 03, 2015, 09:08 AM
Cocreatr is offline
Find More Posts by Cocreatr
Beginner at Something
Cocreatr's Avatar
Japan, Kanagawa Prefecture, Yokohama
Joined Aug 2015
4 Posts
@dragonblade, did you get your P2 "connected"?

Originally Posted by dragonblade View Post
Ive discovered that Ive got another mini usb cable lying around. So I used that to connect the transmitter to the pc for my second attempt at switching over to Naza M mode. I then connected the Phantom as well with another usb connection. Though to my surprise, when I click on the 'Phantom' tab in the upper right hand corner of the screen in the Assistant software, I still get the message that says: "Please connect to the controller." This is despite having the transmitter connected via usb.

As such, I can't calibrate the transmitter with the software either.
What the manual means is you need to switch the RC controller (TX) on and if not done already, pair the receiver (RX) on the phantom with it, so the phantom connects to your controller. The TX USB connection is used to calibrate TX. Good idea to do that occasionally, skip it and the next step if it flies fine. Power on TX , power on Phantom, pair the RX (may be called binding in the manual).

With the TX and Rx paired and running, connect the Phantom to the PC and see the channel dials move when you move the sticks. Now you are connected to the controller and ready to calibrate the Phantom itself. Set modes as desired.
Cocreatr is offline Find More Posts by Cocreatr
Last edited by Cocreatr; Oct 03, 2015 at 09:09 AM. Reason: punctuation, duh.
Reply With Quote
Old Oct 03, 2015, 09:53 AM
startazz is offline
Find More Posts by startazz
RC plane addict ;-)
startazz's Avatar
United Kingdom, England, Norwich
Joined Aug 2008
2,001 Posts
Originally Posted by c-mac13 View Post
I did notice yesterday I was losing a bit of a signal and was actually thinking of doing a test like that. I was however flying off of a 17 story building and believe that was what most of the signal loss was from. Thanks for posting that.
No problem mate,even though the bloke in the video was using a different sort of quad it still applies,even though some might not think so,no matter how good the quality of the extension cable is you can still get some drop out on signal(VTX that is).

Originally Posted by Lizardking0069 View Post
Anyone thinking of getting the P3? Whats stopping you ?
Yeah i thought about getting one for about five minutes then thought i'm not doing the Apple thing like others do,which is upgrade every time a new model comes out,it can get expensive real fast that way,but that's just me.

So as long as my old faithful PH2 does what i want i'll be keeping it because the little added extras that comes with the PH3 can't justify me upgrading even if i wanted too,plus i also like to fly FPV with mine using FS goggles,it can be a great way to frame your shots and it's a more immersive feel than using a screen,but i can see why others would use a screen and the safety reason alone should be enough if flying on your own,but i always have a spotter as i also fly my mini (250) quads and there is no RTH with them bad boys,well not on mine that is.
startazz is offline Find More Posts by startazz
Reply With Quote
Old Oct 03, 2015, 12:40 PM
N1EDM is offline
Find More Posts by N1EDM
Registered User
N1EDM's Avatar
Brockton, MA
Joined Nov 2003
451 Posts
Does anyone make a 'keeper' for the GoPro/gimbal on the Phantom 2???


N1EDM is offline Find More Posts by N1EDM
Reply With Quote
Old Today, 09:17 AM
Robin466 is offline
Find More Posts by Robin466
Registered User
Joined Oct 2015
2 Posts
Hello Dear Phantom Pilots Colleague’s

A few months ago I bought a DJI Phantom 2 with a Futaba T8J TX I have owned several other Phantoms so I knew the product very well. But this one is different than the rest,
I can’t really calibrate the GPS by doing the DJI Dance… but when I waited I would get full satellite cover. So I went out and tried to fly. (I live in Holland so lots of big open spaces where I can fly.
Yep of course also a lot of Transmission towers but I have flown here before with a other phantom and never had a problem. ) So I went out Took off and watched how the drone flies. In the beginning nothing special but the drone didn’t hold position so good at 4 a 5 meters high.
Suddenly the drone lost height and I could just manage to land it… I looked at it and thought well maybe I did something wrong so checked everything and tried it again.
The drone went up and yeah again It didn’t keep position so good so I tried to go lower to the ground to see if it would go better. Nah you know the answer drone crash… no damage lucky.

But within a few days I would go to Croatia so I wanted to know what the problem was so I could fly over there and make some nice shots of the campsite and the area. I fixed the problem at last I thought so just by Recalibrating the Compass. In the DJI phantom Assistant software.
I do the DJI Dance and yeah lights go out and then 1green 2 red so less than 9 satellites but after a few seconds fast green flashes and after that It went on with 4 solid green flashes. So full satellite cover. So I thought I fixed the problem. Took the phantom, took off, made some pictures, fly over the sea, come back, try to land, all very steady.
Managed to do a few flights over there.
And It flew pretty good a bit Shockey at heights with steering’s and a little drift away.
So I thought Eureka! But coming back to the Netherlands same story cannot Calibrate the GPS/Compass. After the DJI dance Lights go in fast flashing Red so put it up to the computer and watched wat the software said. Same as every time error 27 GPS “GPS calibration failed or strong magnetic interference” so I tried it again but now being plugged in the computer to see what my sensors are doing. But see nothing strange the MOD keeps in the Save distance (below 750 or beyond 2250 is not good and error will pop up)

But after the calibration I saw a fast disappearing message saying Basic Calibration fail.
So I did the Basic IMU Calibration and to finishing it all I also did the Advanced IMU Calibration.

And guess what…
The calibration had succeeded so I powered the drone down. Took it outside powered it up did the dance and again Red flashes. So took my laptop outside hook it up same story. Now it seems that I can only calibrate the GPS if I do an Advanced IMU Calibration.
Sorry for the long story I will list everything below:
I hope someone of you knows the problem or knows what to change.

Setup :
• Dji Phantom 2
• Futaba T8J
• Feiyutech gimbal
• Go Pro Hero 3 +
• Immersion RC Vtx

• Drone can’t hold position so good.
• Drone drifts away.
• Can’t calibrate the GPS/Compass.

Things I tried :
• Change TX settings.
• Recalibrate GPS.
• Calibrate IMU.
Robin466 is offline Find More Posts by Robin466
Reply With Quote
Old Today, 07:41 PM
Alwayscrash is offline
Find More Posts by Alwayscrash
"you'll play to live "
Alwayscrash's Avatar
Canada, QC, Montreal
Joined Sep 2009
1,841 Posts
what's firmware was on it actually? also, did you try to do Advanced IMU calibration?
Alwayscrash is offline Find More Posts by Alwayscrash
Reply With Quote
Old Today, 09:43 PM
Experimental is online now
Find More Posts by Experimental
Professional Armchair Racer
United States, GA, Canton
Joined Aug 2010
27 Posts
Robin - I'd definitely be interested to know what firmware you have too.
Experimental is online now Find More Posts by Experimental
Reply With Quote

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
New Product DJI Propulsion System for Multirotor ***Developer and Owner Thread***** DJI INNOVATIONS Multirotor Talk 5857 Oct 02, 2015 05:12 PM
New Product DJI Phantom 2 Vision ***Owners Thread*** blade strike Multirotor Talk 11564 Sep 28, 2015 12:17 PM
New Product ZERO UAV E1100 RTF system ***Owners Thread*** Zero UAV Multirotor Talk 118 Jun 14, 2015 10:03 PM
Discussion An update thread for us Walkera X350 owners. Navy Jet Mech Multirotor Talk 92 Mar 20, 2014 06:40 PM
Discussion Phantom Owner in the Fayetteville North Carolina Area needed! Or Anywhere 2dogrc Multirotor Power Systems 8 Oct 04, 2013 09:02 PM