New Products Flash Sale
Thread Tools
Old Feb 22, 2016, 07:06 AM
Too Many Toys is online now
Find More Posts by Too Many Toys
Team WarpSquad [ L ] Learner
Too Many Toys's Avatar
Australia, VIC, Eurobin
Joined Jul 2014
1,186 Posts
Discussion
OpenTX 2.1.X, X4R SB, Non EU, Flashing, S.port, etc.

I posted this in another RCG thread, the original owner got his own answer and then closed the thread

Anyway ~

X4R SB, Flash External Device fails, OpenTx 2.1.7

I have a new Taranis+Plus, FW: opentx-taranis-plus, Ver: 2.1.7
I have a new X4R SB, I'm trying to flash the Rx with, X4R-X4RSB_cppm_non-EU_150630.frk
from the Taranis / SD card using the supplied S.port cable via the external Tx port pins on the back of the radio.
BTW both units are Non-EU types. Australia.

Everything looks good until I hit enter on the Flash External Device menu.
The writing bar briefly appears, then the screen goes blank, speaker clicks a couple
of times and I end up back at the main screen of the model that I started with.
If I go back to the SD card the menu it's blank, no folders, files, nothing.
When I reboot the radio the SD card menu / files are visible again.
I checked the X4R to see if the expected new PWM channels were assigned but unfortunately not.
Any help appreciated.

Member Ari33 replied with ~
Quote:
Some Taranis/Rec flashing methods that work with other X-series Recs dont work with the X4R for some reason.
Not sure which method you are using but try this one..
How to flash firmware to S.Port Receivers and Devices using Taranis. (1 min 16 sec)

Thanks Ari33,
That is the method that I tried but it failed unfortunately ~
This web page has the same steps also ~
https://quadmeup.shtr.eu/flash-firma...h-x9d-taranis/
https://quadmeup.shtr.eu/
If you don't have OpenTX 2.1.X, e.g. OpenTX 2.0.X the Flash External Devices
option may not be available when you select enter on a file in the SD card menu.
You will probably only get a Delete option.

This buy the same guy but thought it was a rather convoluted solution for my needs
as I may end up doing several of those X4Rs in the near future.
I just don't want to accidentally Brick my Tx in the process of updating an Rx.
I'd need to got back to Other FW to try it.
How to Flash Frsky X series receivers and devices using Taranis Tx. No serial adapters needed (4 min 31 sec)



So the question remains ?
Why didn' the process work, is it an OpenTx firmware issue or something
with the X4R SB only and other S.port may devices may work, it would be good to find the answer.
I have not tried any other S.port devices as yet.
I have an FrSkySPC- FUC-3, SPC, USB updater stick so may give that a go with
a modified cable to suit the supplied X4R S.Port cable.
I tried to register an Acc in OpenTX Forums but it must not like my e-mail or something.
Any thoughts on X4R, other S.Port Devices, OpenTX 2.1.X, Non EU and
troubleshooting welcome here.
Too Many Toys is online now Find More Posts by Too Many Toys
Last edited by Too Many Toys; Feb 22, 2016 at 07:29 AM.
Reply With Quote
Sign up now
to remove ads between posts
Old Feb 22, 2016, 09:57 AM
Allerhopp is online now
Find More Posts by Allerhopp
Registered User
Germany, RP
Joined Aug 2015
82 Posts
Some Taranis had recently problems with the bootloader. Download again the suitable OpenTX 2.1.7. Even if sounds weird and there is only a little probability, your problem is caused here, it is no risk, to flash the 2.1.7 bootloader (from sd-card, running OpenTX) and then test again. I would also rewrite OpenTX 2.1.7 itself and test again. I presume, your cable is OK and you use the correct pins. If you still have no success, there is probably a hardware problem.

Flashing S-Port devices with "frsky_update_Sport.exe" is the alternative, you own already the necessary hardware. It worked flawlessly for me, when i
1- select comport
2- load the firmware file, then immediately
3- power the S-port device -> flashing starts (but runs slowly - patience needed)
Allerhopp is online now Find More Posts by Allerhopp
Last edited by Allerhopp; Feb 22, 2016 at 09:58 AM. Reason: typo
Reply With Quote
Old Feb 22, 2016, 10:17 AM
Too Many Toys is online now
Find More Posts by Too Many Toys
Team WarpSquad [ L ] Learner
Too Many Toys's Avatar
Australia, VIC, Eurobin
Joined Jul 2014
1,186 Posts
I found the problem, it's me . Two cables, one had the Pos +, Neg- swapped.
One was left in original state and put away, guess which one I had put away.
I'm such a goose.
So if your X4R SB, or S.port device has an upgrade fail with the same symptoms
as above you'll know what to do.

The Flashing / Upgrade process now seemed to work correctly e.g. the
"writing" bar on the Tx completed and the Red, Green LEDs on the Rx were
flashing alternately. After re-binding with ch2 and ch3 pins jumpered, I now get
Tx ch9 on the Rx ch2 pins. I hope Tx ch10 is on Rx ch3 and SBUS on ch4 CPPM on ch1.
I'll check tomorrow it's late.
Too Many Toys is online now Find More Posts by Too Many Toys
Last edited by Too Many Toys; Feb 22, 2016 at 06:31 PM.
Reply With Quote
Old Feb 22, 2016, 10:26 AM
Too Many Toys is online now
Find More Posts by Too Many Toys
Team WarpSquad [ L ] Learner
Too Many Toys's Avatar
Australia, VIC, Eurobin
Joined Jul 2014
1,186 Posts
Quote:
Originally Posted by Allerhopp View Post
~
~
Flashing S-Port devices with "frsky_update_Sport.exe" is the alternative, you own already the necessary hardware. It worked flawlessly for me, when i
1- select comport
2- load the firmware file, then immediately
3- power the S-port device -> flashing starts (but runs slowly - patience needed)
Thanks for the reply Allerhopp.
I'll have to try the S.port.exe and the USB stick, first I'll need to make an adaptor cable.
Too Many Toys is online now Find More Posts by Too Many Toys
Reply With Quote
Old Feb 24, 2016, 02:11 AM
frater is offline
Find More Posts by frater
Registered User
Netherlands, NB, Helmond
Joined Aug 2014
1,514 Posts
Quote:
Originally Posted by Too Many Toys View Post
I found the problem, it's me . Two cables, one had the Pos +, Neg- swapped.
One was left in original state and put away, guess which one I had put away.
I'm such a goose.
I immediately tied a ribbon on that modified cable and also advised a friend to do the same.
Thanks for confirming this was a good idea.
frater is offline Find More Posts by frater
Reply With Quote


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion FrSky Taranis, Taranis Plus, Taranis E - OpenTX 2.1.X Jet_Flyer Radios 4347 Jul 29, 2016 01:18 PM
Help! Cannot bind new X4R-SB rx's to Taranis Typoman FrSky 16 Jul 12, 2016 02:35 AM
Discussion cannot flash X4R EU to international jyzoom Radios 3 Jan 23, 2016 07:34 AM
Discussion How to connect X4R-SB to a CC3D flashed with betaflight Felipe79 FPV Racing 0 Nov 28, 2015 05:16 AM
Discussion Trouble flashing X4R-SB firmware v81 Radios 4 Sep 08, 2015 07:57 PM