New Products Flash Sale
Thread Tools
Old Jan 02, 2014, 05:22 PM
charlesml3 is offline
Find More Posts by charlesml3
Registered User
Joined Aug 2006
35 Posts
Discussion
DX6i - Why is my elevator throw much less in one direction?

Gang,

I sure hope someone can help me with this because it's driving me CRAZY. Here's what I have:

- DX6i
- Acro Model
- D/R Expo is 100% and +75% for all three channels
- Travel Adjust is 100% for all channels
- Sub Trim is 0 for all channels
- No Flaps, No Mixes, No Differential
- All trims are in the middle.

- No Throttle Cut, No WingTail Mix
- D/R Switch is set to "Elev"

So I go into "Monitor" and only on the elevator, the "throw" isn't the same on both sides. If I pull back for up Elevator, I get a bit more than 1.5 bars. If I push forward, I get about 3/4 of a bar. Aileron is the same both ways. Rudder is the same both ways.

The only thing I've found that changes this is the Expo for the Elevator channel. If I set the Expo to INH I now get: 1.75 up Elevator and about 1.25 down elevator. Still different, but better.

This behavior is reflected on an airplane. The throws are not the same in both directions. Something isn't making sense to me here.

Anyone know what might be going on?

Thanks a ton!

-Charles
charlesml3 is offline Find More Posts by charlesml3
Reply With Quote
Sign up now
to remove ads between posts
Old Jan 03, 2014, 08:37 AM
freechip is offline
Find More Posts by freechip
Surface, Air & Water Rc Toys..
freechip's Avatar
Canada, ON, Ottawa
Joined Aug 2008
29,302 Posts
Check on a blank new model.

If it still persist you may have pot issues and need to have it serviced.
freechip is offline Find More Posts by freechip
Reply With Quote
Old Jan 03, 2014, 08:41 AM
Magic Dragon is offline
Find More Posts by Magic Dragon
Registered User
Magic Dragon's Avatar
Grapevine, Texas
Joined Mar 2011
15 Posts
Check your elevator server to make sure the arm is centered and has not come loose by checking the arm screw.
Magic Dragon is offline Find More Posts by Magic Dragon
Reply With Quote
Old Jan 03, 2014, 10:24 AM
charlesml3 is offline
Find More Posts by charlesml3
Registered User
Joined Aug 2006
35 Posts
Ahh... yes. I didn't think of that. I'll check those items when I get home. Thanks a ton!

-Charles
charlesml3 is offline Find More Posts by charlesml3
Reply With Quote
Old Jan 03, 2014, 10:27 AM
freechip is offline
Find More Posts by freechip
Surface, Air & Water Rc Toys..
freechip's Avatar
Canada, ON, Ottawa
Joined Aug 2008
29,302 Posts
Quote:
So I go into "Monitor" and only on the elevator, the "throw" isn't the same on both sides
If you see this issue in the servo monitor it's not going to be the servo horn
freechip is offline Find More Posts by freechip
Reply With Quote
Old Jan 03, 2014, 11:33 AM
jjkupinski is offline
Find More Posts by jjkupinski
TigreJohn
United States, CA, Corona
Joined Aug 2008
1,167 Posts
Don't know if the DX6i has this capability, but my Airtronics SD-10 has the capability of setting different end points on either end of a surface travel. Check your End Points on that channel by entering that function and exercising the stick. If their different, you should see the difference on the screen.
jjkupinski is offline Find More Posts by jjkupinski
Reply With Quote
Old Jan 03, 2014, 11:38 AM
charlesml3 is offline
Find More Posts by charlesml3
Registered User
Joined Aug 2006
35 Posts
Quote:
If you see this issue in the servo monitor it's not going to be the servo horn
Exactly. Something is still wrong. I went all the way out to Model 9 and did a Reset on it just in case. When I look at the elevator now with the Monitor screen, the travel is the same in both directions, but quite a bit less than the travel I see for Rudder and Ailerons. I then went in and dialed in +50% expo on all three which should NOT reduce the travel for any of them. For Ailerons and Rudder it doesn't. For Elevator, it does. With +50% Expo, both of the endpoints are significantly shorter. Weird.
charlesml3 is offline Find More Posts by charlesml3
Reply With Quote
Old Jan 03, 2014, 12:29 PM
freechip is offline
Find More Posts by freechip
Surface, Air & Water Rc Toys..
freechip's Avatar
Canada, ON, Ottawa
Joined Aug 2008
29,302 Posts
If something was wrong with the pot and the pot was limiting full travel then you would see changes when adding expo because the pot is technically still not at full travel.

Have it service.
freechip is offline Find More Posts by freechip
Reply With Quote
Old Jan 03, 2014, 12:31 PM
charlesml3 is offline
Find More Posts by charlesml3
Registered User
Joined Aug 2006
35 Posts
Quote:
If something was wrong with the pot and the pot was limiting full travel then you would see changes when adding expo because the pot is technically still not at full travel.
Yep, my thoughts exactly. I just fired up Phoenix and it also sees the elevator at less than full travel. Worse in one direction than the other.

I've been looking at a DX8 anyway so this gives me a good excuse to pull the trigger on it. I'll get this DX6i serviced anyway as a backup.

Thanks everyone!

-Charles
charlesml3 is offline Find More Posts by charlesml3
Reply With Quote
Old Jan 03, 2014, 12:53 PM
Reflex1 is offline
Find More Posts by Reflex1
X-Ikarus
Reflex1's Avatar
United Kingdom, North York
Joined Feb 2003
1,744 Posts
This may help

Spectrum DX6i service menu (calibration)
http://www.rcgroups.com/forums/showthread.php?t=905561

Worth a try before sending it for repair ?
Reflex1 is offline Find More Posts by Reflex1
Reply With Quote
Old Jan 03, 2014, 02:12 PM
charlesml3 is offline
Find More Posts by charlesml3
Registered User
Joined Aug 2006
35 Posts
Quote:
Worth a try before sending it for repair ?
Not only was it worth a try.... it totally fixed the problem. As soon as I got into the summary menu, it was obvious. The elevator Up was at 975 which was close to the rest. The Down was at 120 while the rest were in the low 30s. That's why I had so much less throw in that direction.

Thanks a ton!

-Charles
charlesml3 is offline Find More Posts by charlesml3
Reply With Quote
Old Jun 18, 2016, 10:15 PM
Chriddler is offline
Find More Posts by Chriddler
Registered User
Joined Jul 2015
2 Posts
I've just been searching for the answer to a very similar problem - my elevator had an asynchronous throw. When the stick was centred, the monitor showed the elevator at the left of the chart, at the zero position. This meant that down had to go into the negative, thus only had 25% travel. I couldn't find any setting that was weird in any way. In the end I just reset the model memory - problem solved
Chriddler is offline Find More Posts by Chriddler
Reply With Quote


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Quad flies normal but flips ony when rudder or yaw is used in one direction - why? hamsterchaos Mini Multirotors 0 Oct 11, 2013 05:04 PM
Help! Rudder servo limited throw in one direction shezza Beginner Training Area (Heli-Electric) 0 May 21, 2012 02:30 AM
Discussion Optic6 elevator only works in one direction?? KMKAZE Radios 2 Jun 11, 2011 08:06 PM
Discussion How much elevator throw is enough for a Siren? IFlySlow High Performance 16 May 09, 2006 06:59 AM
Full moving elevators How much throw? (sorry dont know the correct name for it) pipsta Electric Ducted Fan Jet Talk 27 Nov 15, 2005 01:01 PM