HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Apr 02, 2013, 04:16 PM
Registered User
Mooresville, NC
Joined Dec 2004
263 Posts
Discussion
Guardian 2d/3d not working correctly on a Stryker F27Q

I mounted a 2d/3d in a Stryker mainly for the takeoff stability and that works fine.

However when in 3d mode (as switched from my Futaba 14sg) the Stryker does not seem to function correctly. I am fighting the aileron gain and can only do a roll when the stick is in the extreme left or right - and when it does roll it is very fast like a snaproll. Also when I let go of the sticks to neutral the model is not held in its current attitude like it should be.

I also have a unit mounted in a Eagle 580 and that one seems to work much better. I am wondering if the problems in the Stryker are due to the unit having to mix channels. My setup is using two separate aileron channels (ail and aux).

Anyone else using this 2d/3d stabilizer in a Stryker with success? I don't know why the aileron channel does not work normally and wondering if I have a defective unit?
MichaelT1960 is offline Find More Posts by MichaelT1960
Reply With Quote
Sign up now
to remove ads between posts
Old Apr 03, 2013, 09:38 AM
Registered User
Mooresville, NC
Joined Dec 2004
263 Posts
Problem may be resolved

I checked thru my config and had the AUX input connected to my receiver's channel 5 output. According to the Guardian manual this input should be left disconnected when used with my type of wing configuration:
Elevon / V-Tail with no Ailerons
Model Control Type setting: Elevon
Guardian Receiver Inputs
o Receiver Aileron Output → Guardian Aileron In
o Receiver Elevator Output → Guardian Elevator In
o Receiver Rudder Output → Guardian Rudder In
o Guardian Aux-In is not connected
Output
o Guardian Aileron Out → Elevon Servo 1
o Guardian Elevator Out → Elevon Servo 2
o Guardian Rudder Out → Rudder Servo
o Guardian Aux Out is not connected


Now when testing on the ground everything seems to be working correctly in both modes (2d and 3d). Hopefully will get to test fly today with some wind.
MichaelT1960 is offline Find More Posts by MichaelT1960
Reply With Quote
Old Apr 03, 2013, 05:07 PM
Registered User
Mooresville, NC
Joined Dec 2004
263 Posts
Fixed!

Flew my Stryker F27Q today and now the Guardian 2d/3d works great....even in 3d mode! Make sure you do not connect any 2nd aileron output from the receiver to the guardian as it will cause the unit to not work the way it should!!!

Six flights today....wow!

Michael
MichaelT1960 is offline Find More Posts by MichaelT1960
Reply With Quote
Old Apr 04, 2013, 02:44 PM
billpa's Avatar
Joined Nov 2003
4,906 Posts
Great news, Michael! We flew the Guardian on our F27Q yesterday also. Man, that's fun!
billpa is offline Find More Posts by billpa
Site Sponsor
Reply With Quote
Old Jul 05, 2013, 07:13 PM
Registered User
United States, TX, Plano
Joined Jun 2013
360 Posts
I had to reverse the elevator and aileron in my TX (DX6i) to get it working right. I played with the directions of the gain controls and didn't get it to work correctly. Is this OK to do or I should never reverse the channels in the TX??
Thanks guys
flyingtxnewb is offline Find More Posts by flyingtxnewb
Reply With Quote
Old Jul 09, 2013, 11:14 AM
JohnET's Avatar
United States, NC, Charlotte
Joined Apr 2013
315 Posts
As long as your stick inputs move the control surfaces the correct way AND the Guardian moves the control surfaces the correct way when enabled and tested on the ground, then it is fine.

By testing on the ground I mean enable 3d mode, hold the plane in your hand and roll, pitch and yaw the plane. Do the control surfaces move to counteract the roll, pitch and yaw? If so then it is good. If not, you need to adjust the knobs on the Guardian for the axis that is not correct.
JohnET is offline Find More Posts by JohnET
Site Sponsor
Reply With Quote
Old Jul 10, 2013, 06:00 PM
Registered User
United States, TX, Plano
Joined Jun 2013
360 Posts
Ok thanks!! It's working fine with reversed channels
flyingtxnewb is offline Find More Posts by flyingtxnewb
Reply With Quote
Old Jul 18, 2013, 07:26 PM
Registered User
Joined Jul 2013
2 Posts
guardian

Hello guys. I tried to install my guardian to Yak 54 nitro. It seems to work fine. But there is lots of vibration for this stabilizer. I mounted it on a foam and Velcro. All surfaces are like crazy. How can I get rid of vibration. Prop is balanced.
Yevgeniy M is offline Find More Posts by Yevgeniy M
Reply With Quote
Old Jul 19, 2013, 06:39 AM
JohnET's Avatar
United States, NC, Charlotte
Joined Apr 2013
315 Posts
Hello Yevgeniy,

The best advice is to experiment with different foams and mounting surfaces. There was recently a lot of talk on this topic in the main thread and some users came up with some pretty good solutions. Take a look here; http://www.rcgroups.com/forums/showt...t#post25379893

John
JohnET is offline Find More Posts by JohnET
Site Sponsor
Reply With Quote
Old Nov 14, 2013, 07:48 AM
Registered User
United States, FL, Jacksonville
Joined Aug 2013
2 Posts
Mounting

Hey,

I just ordered an EagleTree Guardian for my F27Q Stryker and I was looking at mounting options. There isn't a lot of space available. Where did you guys mount the Guardian in your Strykers? Any pictures?

Thanks in advance,
Ed
Astacun is offline Find More Posts by Astacun
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help! Guardian 2d/3d issue stroudj Eagle Tree Systems 6 Apr 30, 2013 12:25 PM
Discussion The Guardian 2D/3D Stabilizer and elevon planes AJay Scratch Radios 0 Jan 22, 2013 12:53 PM
Wanted EagleTree Guardian 2D/3D Inertial Flight Stabilizer guyst Aircraft - General - Radio Equipment (FS/W) 0 Jan 13, 2013 03:27 PM
Sold Eagletree Guardian 2D/3D Stabilizer Dan777 Aircraft - General - Radio Equipment (FS/W) 2 Jan 05, 2013 03:04 PM
Discussion Guardian 2D/3D on stick travels less for same deflection Tim Green Eagle Tree Systems 3 Sep 27, 2012 02:15 PM