SMALL - espritmodel.com SMALL - Telemetry SMALL - Radio
Reply
Thread Tools
Old Jan 21, 2013, 05:42 PM
Unregistered User
helipilot23's Avatar
Joined Oct 2012
379 Posts
Discussion
need help.setting up.

So I can get the swashplate to move up and down with the throttle but the cyclics are reversed. I need help.

Btw I'm using a dx7s a ar6100e and a esky hbk4/3
helipilot23 is offline Find More Posts by helipilot23
Reply With Quote
Sign up now
to remove ads between posts
Old Jan 21, 2013, 06:00 PM
WOS
Registered User
United States, IN, Michigan City
Joined Nov 2003
808 Posts
Sounds like you have a few of the servos plugged into the wrong slot on the rx. try moving the servo plugs around and play with the servo reversing
WOS is offline Find More Posts by WOS
Reply With Quote
Old Jan 21, 2013, 06:14 PM
Registered User
Australia, VIC
Joined Dec 2011
1,107 Posts
Yeah , either moving in the wrong direction - or plugged into the wrong port in the Rx ...

Aaaah , dont you love setting up cyclic the very first time ?
old4570 is offline Find More Posts by old4570
Reply With Quote
Old Jan 21, 2013, 06:15 PM
WOS
Registered User
United States, IN, Michigan City
Joined Nov 2003
808 Posts
If the swash is moving in the right direction for the pitch than you def. have a servo or two or three in the wrong port. Start swapping ports and playing with your reversing. As old one says.....CYCLICS ARE FUN!
WOS is offline Find More Posts by WOS
Reply With Quote
Old Jan 22, 2013, 03:37 PM
Unregistered User
helipilot23's Avatar
Joined Oct 2012
379 Posts
Haha lol... Thanks. I ll try that.
helipilot23 is offline Find More Posts by helipilot23
Reply With Quote
Old Jan 22, 2013, 03:40 PM
Unregistered User
helipilot23's Avatar
Joined Oct 2012
379 Posts
I mean. The servos move as if it was a trex 450 pro swashplate with 2 servos in the front. But this swashplate has two servos in the back..
helipilot23 is offline Find More Posts by helipilot23
Reply With Quote
Old Jan 22, 2013, 04:10 PM
A&P in training
ASTREA1's Avatar
United States, CA, Vacaville
Joined Dec 2008
1,258 Posts
Quote:
Originally Posted by helipilot23 View Post
I mean. The servos move as if it was a trex 450 pro swashplate with 2 servos in the front. But this swashplate has two servos in the back..
You may have to mess with the Swash mix(- or +) in the TX in order to get the desired results..You'll get it eventually. I remember setting up the cyclic on my TH9x for the first time..Took about an hour to get everything where it needed to be.
ASTREA1 is offline Find More Posts by ASTREA1
Reply With Quote
Old Jan 23, 2013, 12:52 AM
unlicensed helicopter nut
zen@lanset.com's Avatar
Berkeley, California
Joined Jan 2007
3,699 Posts
It depends on the radio you are using, but the 120 swash plate that E_sky uses is generally set up with aileron as the front left servo, pitch the right front, and elevator the rear servo. Aileron and pitch can go the other way too, but this is the schema. It is almost always necessary to reverse a servo or two to get the cyclic movements right plus collective pitch in the right directions. But if you know which channels of your radio control aileron, pitch, and elevator the rest will fall into place.
zen@lanset.com is offline Find More Posts by zen@lanset.com
Reply With Quote
Old Jan 23, 2013, 02:40 AM
Registered User
Letchworth, Great Britain (UK)
Joined Jul 2004
11,586 Posts
Quote:
Originally Posted by helipilot23 View Post
I mean. The servos move as if it was a trex 450 pro swashplate with 2 servos in the front. But this swashplate has two servos in the back..
You first need to check that you've selected the correct swash mode in your trannie menu. My Futaba has 120 degree with rear elevator, 120 degree with front elevator, 90 degree, and a few others to select from.
abenn is offline Find More Posts by abenn
Reply With Quote
Old Jan 23, 2013, 10:05 AM
unlicensed helicopter nut
zen@lanset.com's Avatar
Berkeley, California
Joined Jan 2007
3,699 Posts
Good point. That is where it starts.
zen@lanset.com is offline Find More Posts by zen@lanset.com
Reply With Quote
Old Jan 23, 2013, 12:03 PM
banging head on wall
skyeblu's Avatar
Joined Feb 2010
1,200 Posts
Have you tried reversing all three servo directions from where they are now ( norm / rev ) and then reversing the swash mix from a minus to a positive or the other way round . Thats if your controls work for aileron and elevator but are reversed. Just a thought I think I remember I had to do that a few times with different builds crs you know
skyeblu is offline Find More Posts by skyeblu
Reply With Quote
Old Jan 23, 2013, 01:44 PM
Unregistered User
helipilot23's Avatar
Joined Oct 2012
379 Posts
I dont know where te swash mix is... (noob comment)
helipilot23 is offline Find More Posts by helipilot23
Reply With Quote
Old Jan 23, 2013, 02:12 PM
A&P in training
ASTREA1's Avatar
United States, CA, Vacaville
Joined Dec 2008
1,258 Posts
It is somewhere in the settings..Maybe this will help a bit.

DX7 programming part 2 (12 min 43 sec)
ASTREA1 is offline Find More Posts by ASTREA1
Reply With Quote
Old Jan 23, 2013, 02:38 PM
Unregistered User
helipilot23's Avatar
Joined Oct 2012
379 Posts
I found it. Under "swashplate" on my dx7s. The swashplate works now. Also, Do you know some noob settings? I can fly basic 3d on my nano cpx so i need a basic setup.

thanks
helipilot23 is offline Find More Posts by helipilot23
Reply With Quote
Old Jan 23, 2013, 02:45 PM
banging head on wall
skyeblu's Avatar
Joined Feb 2010
1,200 Posts
In the video above at about 3:45 it starts to explain the swash mix and changing from plus to positive just the pitch mix!. Also at this point the numbers also adjust total swash travel on a trex450 its about 60% as a start equal both sides. For your bird watch for binding at the top and bottom of pitch range and adjust numbers for no binding. Good video explains the setup pretty clearly.
skyeblu is offline Find More Posts by skyeblu
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Need a Bad A$$ Engine set up for Ultra Stck 40 Dale 813 Engines 22 Jan 30, 2013 01:39 PM
Help! Need to know the set up for a Hydro Plane Foamie. SHoffman1971 Power Systems 13 Jan 15, 2013 07:25 PM
Discussion Need Advise on what C rating for this system set up! chopper52 Electric Ducted Fan Jet Talk 1 Jan 12, 2013 01:09 PM
Discussion Need help setting up Devo 10 w gimbal and f450! floete Multirotor Talk 4 Jan 07, 2013 03:27 PM
Help! Need help setting up Walkera V120D02S... LucidSoul Micro Helis 6 Jan 04, 2013 10:46 AM