Espritmodel.com Telemetry Radio
Reply
Thread Tools
Old Nov 02, 2012, 02:13 PM
Note - Self Destruct - OFF
Arcorsai's Avatar
United States, FL, Miami
Joined Jun 2012
65 Posts
Haven't had time to set mine up but from the RC timer web site for their Item:

MWC-Bluetooth

Default parameter

·Baudrate : 115200

·Module name : CRIUS_BT

·Pair code : 0000
Arcorsai is online now Find More Posts by Arcorsai
Reply With Quote
Sign up now
to remove ads between posts
Old Nov 04, 2012, 02:01 PM
Registered User
South Africa, GP, Alberton
Joined Jul 2011
5 Posts
Quote:
Originally Posted by marvin081 View Post
Sadly I damage my board and attempting to configure the gps module i connected it to the board with the vcc and gnd wires inverted and burn the board. i have to check if its repairable.

Thanks.
Hi,
I'm not sure my GPS module is working correctly or if I damaged mine too. Using MultiWiiConf, it reports up to 11 sats but if I walk around with the plane the distance to home updates VERY slowly (about once per minute) or does not update at all.. Also ground speed is always 0. Any ideas what could be wrong or is this normal?.. PS BAUD is set to 115200.
I have the FC fitted in a plane and stable mode works perfectly, but cannot seems to get RTH working...
cupraSA is offline Find More Posts by cupraSA
Reply With Quote
Old Nov 10, 2012, 09:10 PM
Registered User
Joined May 2010
75 Posts
Quote:
Originally Posted by cupraSA View Post
Hi,
I'm not sure my GPS module is working correctly or if I damaged mine too. Using MultiWiiConf, it reports up to 11 sats but if I walk around with the plane the distance to home updates VERY slowly (about once per minute) or does not update at all.. Also ground speed is always 0. Any ideas what could be wrong or is this normal?.. PS BAUD is set to 115200.
I have the FC fitted in a plane and stable mode works perfectly, but cannot seems to get RTH working...
Load WinGui 2.1 to a laptop (connected to the internet so you can download the applicable Google map data) and enable bluetooth so you can monitor your board remotely. If GPS is working properly, you should be able to actually "see" on the GPS tab the Google map data where you are located. When you move around, you should see your board moving around too. Read up on EOSBandi's write up on MWC GPS (posted on the HK site under files for this board) and what you need to do to make it work correctly including properly setting your magnetic declination.

When you say Plane do you mean Airplane? I do not know if the RTH function in MWC was programmed to work for airplanes as MPNG works with waypoints. I cannot imaging an airplane travelling backwards as my quad would do when RTH is activated.
majik01 is offline Find More Posts by majik01
Reply With Quote
Old Nov 18, 2012, 10:06 AM
Too Many Thread Subscriptions
TheFernMan's Avatar
United States, FL, Miami
Joined Jul 2012
2,114 Posts
I finally place an order for this board! Let's do it!
TheFernMan is online now Find More Posts by TheFernMan
Reply With Quote
Old Nov 28, 2012, 08:44 PM
Registered User
Joined Jan 2012
55 Posts
GPS LED always solid and no data in multiwiiconf

Hi,

I tried using a bunch of settings to get the GPS going in Multiwii, but I've been unsuccessfull in doing it, here is my post about it.

Anyone else have GPS issues, with a solid red light (I believe indicating no satellite fix).

Thanks,
Eric
funx is offline Find More Posts by funx
Reply With Quote
Old Nov 28, 2012, 09:30 PM
Registered User
Joined May 2010
75 Posts
Quote:
Originally Posted by funx View Post
Hi,

I tried using a bunch of settings to get the GPS going in Multiwii, but I've been unsuccessfull in doing it, here is my post about it.

Anyone else have GPS issues, with a solid red light (I believe indicating no satellite fix).

Thanks,
Eric
HK Multiwii Pro Flight Controller with MKT 3329/BT PH, Alt H and RTH Tests (7 min 25 sec)


There is Post#126 and several other GPS related posts in this thread. GPS works great but the 3329 has to be configured correctly.
majik01 is offline Find More Posts by majik01
Last edited by majik01; Dec 06, 2012 at 07:44 AM.
Reply With Quote
Old Nov 29, 2012, 01:31 AM
Registered User
Joined May 2010
14 Posts
yes, ok!
But how do you configure that GPS?
My first did not work, so, i've bought another one, and so on: no result!
Please, tell us what to do from a to Z.
Thanks a lot for your help.
Pierre
PierHenri62 is offline Find More Posts by PierHenri62
Last edited by PierHenri62; Dec 03, 2012 at 03:40 AM.
Reply With Quote
Old Nov 29, 2012, 09:37 PM
Registered User
Joined Jan 2012
55 Posts
The GPS works in mutliwii after reflashing!

Quote:
Originally Posted by majik01 View Post
http://youtu.be/eanOM6MqegA

There is Post #126 and several other GPS related posts in this thread. GPS works great but the 3329 has to be configured correctly.

Hi!

You the man! It worked after reflashing the GPS with my FTDI cable/mini gps app. Next step will trying it out (anyone actually use Turnigy Plush on this board or is everyone using reflashed simonK ECSs?)

PS Nice video. I subscribed after seeing a while ago.

Cheers,
Eric
funx is offline Find More Posts by funx
Reply With Quote
Old Nov 29, 2012, 11:49 PM
Registered User
Joined May 2010
75 Posts
Quote:
Originally Posted by funx View Post
Hi!

You the man! It worked after reflashing the GPS with my FTDI cable/mini gps app. Next step will trying it out (anyone actually use Turnigy Plush on this board or is everyone using reflashed simonK ECSs?)

PS Nice video. I subscribed after seeing a while ago.

Cheers,
Eric
Great job funx. When testing RTH, move the model forward to allow the model to come "back" to you without turning around when you engaged RTH.

I use the TGY 9x (ER9x) and have the three position switch for PH and RTH. I have programmed Aux 1,2,3 and 4 with the radio using 8 channels. Only one model setting for all my quads - does not matter what board. Reduces complexity big time.

You can flash your Turnigy Plush with SimonK firmware and get noticeably smoother performance - no gitters or stutters. Stock is good but SimonK is awesome.
majik01 is offline Find More Posts by majik01
Reply With Quote
Old Dec 03, 2012, 03:23 AM
Registered User
Joined Dec 2012
2 Posts
Hi

I'm using multiwii_dev_r1240 got the GUI working easily GPS is working but took a while. GPS seems to drift about 10 meters under a tin roof without base/ground plate. Gyro's and Acc seem excellent. baro drifts about .4m without light cover (no prop wash to worry about yet) which I think is fine.

Ive built a singlecopter with this board. I can't seem to get the PWM output for the 3rd servo. I think that's because the pin D12 or servo(3) isn't connected.
How do I know which pin is which servo or change the output pin? They don't seem to correspond to the pin numbers printed on the circuit board.

What would happen if I program one servo to a motor output? IE instead of
servo(3) = midvalue + roll_from_gyro_PID + stick input; make it:
motor(2) = midvalue + roll_from_gyro_PID + stick input;
Not real code btw just an example.

Am I just confusing myself? Any help will be greatly appreciated. I plugged my fourth servo into every port and still couldn't find anything. There is a small chance that I plugged my esc into a servo port but then I can't find my motor output.

My board is placed on one of the vanes on the singlecopter. I have already changed the sensor orientation so that it is aligned with the craft.
Dubles is offline Find More Posts by Dubles
Reply With Quote
Old Dec 04, 2012, 08:50 AM
Registered User
Bigmic's Avatar
Norway, Sogn og Fjordane, Askvoll
Joined Aug 2012
60 Posts
Has anyone tried to programm "failsafe" in the tx with RTH function on? So that the Copter is RTH activated when loss of signal?
Bigmic is offline Find More Posts by Bigmic
Reply With Quote
Old Dec 04, 2012, 08:54 AM
Registered User
United States, CA, Auburn
Joined Jan 2009
636 Posts
need help

my first multiwii i have and don't have a clue where to start..i have succesfully flashed kk boards but i cant figure out this multiwii..if some one just show me by video or point me out where to start..
pinoydad is online now Find More Posts by pinoydad
Reply With Quote
Old Dec 04, 2012, 09:23 AM
Too Many Thread Subscriptions
TheFernMan's Avatar
United States, FL, Miami
Joined Jul 2012
2,114 Posts
Quote:
Originally Posted by pinoydad View Post
my first multiwii i have and don't have a clue where to start..i have succesfully flashed kk boards but i cant figure out this multiwii..if some one just show me by video or point me out where to start..
i found this useful but not for our board
TheFernMan is online now Find More Posts by TheFernMan
Reply With Quote
Old Dec 04, 2012, 01:31 PM
Registered User
Joined May 2010
75 Posts
Quote:
Originally Posted by TheFernMan View Post
i found this useful but not for our board
This is very different from the KK board even the Atmel 328 boards. I wish somebody would write a how-to for this board .....

Anyway - let's try to cover the basics and go from there. If anybody sees an error or correction needed PLEASE jump in.

Pull all the files below into one folder to keep your sanity and for version control (you will easily end up with several versions that can be used for similar boards)

a) Download Arduino from here: http://arduino.cc/en/Main/Software Chose the version for your OS.

Unzip and familiarize yourself with the program. The tools section will need the "Board" Atmega 2560 and "Serial Port" is whatever Com port is active for your USBSerial connection [could change so Control Panel > * > * >Device Manager > Ports (LPT COM) is your friend]. Note where the open, save, verify, compile/upload buttons/commands are.

b) Download Multiwii code from here: http://code.google.com/p/multiwii/downloads/list Safest choice is to go with the official release - as of 12/04 Ver 2.1.

Unzip and familiarize yourself with the files. Under Mutliwii_ver*** there is going to be a Multiwii *_ver.ino file which is the file you want to "open" within Arduino - forget you even "see" the other files for now. Remember it's the *.ino okay?

c) Download WinGui 2.1 at http://code.google.com/p/mw-wingui/d...1.zip&can=2&q= Get the latest version.

You will need this after you upload. Familiarize yourself with the tabs (see that "map" tab ??? wait 'til you see your "house" on it ...) Read through the wiki for this program - very helpful. Note the Com port drop down and Connect/Disconnect buttons - same Com port to use with Arduino.

d) Download and install the latest Java for your system to make sure Arduino and the GUI do not hiccup. No brainer here - disregard if you get the auto updates.

e) Download and install the Silab chip driver here :http://www.silabs.com/products/mcu/P...CPDrivers.aspx I did not have to install anything on my Win7 64 bit machine for this board as I was using it for other FC's already.

f) Reference documents are as follows:

For your pinouts and config.h parameters -

http://www.hobbyking.com/hobbyking/s...2X19082X23.pdf

For your motor spin and pinout numbers -

http://www.hobbyking.com/hobbyking/s...2X19082X44.pdf

For your stick commands (if you do not use the GUI)

http://www.hobbyking.com/hobbyking/s...52X19082X2.pdf

To get to know your GPS better -

http://www.hobbyking.com/hobbyking/s...2X19082X46.pdf

Pause and catch your breath ...... coffee will be good too..
=====================================
Part 1 - Uploading the Multiwii sketch The programs are set to run as admin and the USBserial chip is installed ... let the fun begin.

Connect the board via MicroUSB to your computer - board LED's should blink.

Start Arduino as administrator.

On Arduino > Tools (see above) chose Atmega 2560 and Com Port X (remember Device Manager ?)

On Arduino > Files. "Open" the "*ino" files you looked at earlier within the Mutliwii sketch.

Within the sketch (aka program) move several tabs to the right until you get to the "config.h" - scroll down a bit until you get to "Basic Setup" and chose what frame you want. Delete those two "//" slashes in front of the line - this is called uncommenting and you will use this a lot ! Chose Quad x or whatever. This will dictate what pinouts to use and the motor and prop sense.

On the "Sensors" section uncomment the "//#define FFIMUv2" line which would be "#define FFIMUv2" (no quotes) after you are done. (Different boards will have different Sensors). For now leave everything else as default. (GPS you will do later dude ...)

Save, Compile/Verify

If no errors appear - push that Upload button. Your board LED's will blink and keep blinking until the upload completed message comes out in Arduino. Give yourself a pat on the back!

Side note: I personally like to enable "motor stop" which means the motors do not start up like the KK boards - just my preference so you do not panic when you arm your boards.

Next would be configuring the board within WinGui 2.1 for the Aux controls, GPS, etc. but that will be much easier to understand if you have had KK board exposure.

But if you want to connect those motors just be warned NOT to put the props on yet ... SAFETY, SAFETY, SAFETY ...
majik01 is offline Find More Posts by majik01
Last edited by majik01; Dec 06, 2012 at 07:39 AM.
Reply With Quote
Old Dec 04, 2012, 05:49 PM
Too Many Thread Subscriptions
TheFernMan's Avatar
United States, FL, Miami
Joined Jul 2012
2,114 Posts
I received my board today. I was able to set up the GPS using a tip from the MPNG thread for the board.

Used MultiwiiGUI and I was seeing 10 sats
TheFernMan is online now Find More Posts by TheFernMan
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Hobbyking KK board VS MultiWii for a simple quad? carl1864 Multirotor Talk 7 Jan 03, 2014 01:47 PM
For Sale X250 MWC Quadcopter new MWC Mega with gps, diy kit terriwang Aircraft - Electric - Multirotor (FS/W) 32 Jan 02, 2013 03:17 PM
Discussion Crius NEO-6M Ublox GPS+Nano Mini Board+ Multiwii Control Board I2C GPS Kit godwisper Multirotor Electronics 5 Aug 25, 2012 04:03 AM
Sold Ardupilot mega with compass, GPS and Disto board!!!! tc3wins Aircraft - Electric - Multirotor (FS/W) 4 Jan 02, 2012 03:22 PM
Mini-HowTo Straight USB Connect to MTK 3329 GPS larry baraniuk UAV - Unmanned Aerial Vehicles 8 Apr 17, 2011 10:29 PM