SMALL - espritmodel.com SMALL - Telemetry SMALL - Radio
Reply
Thread Tools
Old Jul 15, 2013, 03:49 PM
AMA # 75962
Jim Lee's Avatar
United States, WA, Port Orchard
Joined Apr 2007
1,070 Posts
runner2323,

Here's the mating plug for the Zippy Li-Po, If you ordered the same one as I did, It should come with a XT60 female connector on the battery.

http://www.valuehobby.com/accessorie...connector.html


I used The EC3 connector on mine, But I have several different heli's that use this Zippy Li-Po. http://www.hobbyking.com/hobbyking/s...arehouse_.html

Plus they are much easier for me to solder. http://www.valuehobby.com/accessorie...ir-5-sets.html

J
Jim Lee is offline Find More Posts by Jim Lee
Reply With Quote
Sign up now
to remove ads between posts
Old Aug 15, 2013, 03:17 PM
Registered User
Joined Jun 2013
14 Posts
Does anybody lose signal while flying with the 2.4 I've been having the problem every time I fly at least 1-2 times while flying luckily I haven't had it to high when it's happened , but it starts right up afterwards. Thanks for any help
runner2323 is offline Find More Posts by runner2323
Reply With Quote
Old Aug 15, 2013, 07:36 PM
AMA # 75962
Jim Lee's Avatar
United States, WA, Port Orchard
Joined Apr 2007
1,070 Posts
Oregoncoast,

Was having problems with his 2.4GHz S33 losing signal and I think he said that the on/off switch was intermittent.

You might check the switch and spray some contact cleaner in it, or better yet get rid of the switch and make a arming plug for it.

J
Jim Lee is offline Find More Posts by Jim Lee
Reply With Quote
Old Aug 15, 2013, 07:53 PM
Registered User
Joined Jun 2013
14 Posts
Thanks jim But do you mean some sort of male female connection so you just plug it in.plus after waiting for a month finally got my lipo and it does make a big difference Thanks for recommendation
runner2323 is offline Find More Posts by runner2323
Reply With Quote
Old Aug 15, 2013, 10:17 PM
AMA # 75962
Jim Lee's Avatar
United States, WA, Port Orchard
Joined Apr 2007
1,070 Posts
Yes,
That's what I'd try, if you want to eliminate the switch as a possibility of causing your signal loss. If you have a known good switch, you could also try that.

I'm glad the new Li-Po works for you. I know they sure made a difference in my Heli'

J
Jim Lee is offline Find More Posts by Jim Lee
Reply With Quote
Old Sep 02, 2013, 09:09 AM
Registered User
United States, IL, Oak Lawn
Joined Nov 2012
213 Posts
I have the s33 2.4ghz problem. It will take off fine and fly for about 2-3min. Then when i try fwd flight it will loose altitude and then will have a hard time to regain it.. It will also start to spin slightly clockwise and need trim adjustment. Keeps bouncing up and down a few feet off the ground.
I have a larger blade on the tail motor. It's almost as if the tail motor is taking away current from the main lift motors.
Battery looks good. Drive gear screws are tight. Gears have a little play but lock on to the shafts ok.
Could it be one of the main motors are drawing to much current ?? A 3-4min flight is very short.
Full charged battery is 8.48v
Any help appreciated.
bobwrgt is offline Find More Posts by bobwrgt
Last edited by bobwrgt; Sep 02, 2013 at 11:24 AM.
Reply With Quote
Old Sep 02, 2013, 11:27 PM
AMA # 75962
Jim Lee's Avatar
United States, WA, Port Orchard
Joined Apr 2007
1,070 Posts
You didn't say how many flights you have on the motors, They are prone to eating up brushes and bearings rather quickly, Especially if not allowed to cool out between flights.

One or both motors may be ready to be replaced. The good part, is that they are fairly inexpensive, the bad part, is having to replace one or both of them.

http://www.xheli.com/56p-s33-23.html

http://www.xheli.com/56p-s33-24.html

J
Jim Lee is offline Find More Posts by Jim Lee
Reply With Quote
Old Feb 01, 2015, 12:46 PM
Registered User
Joined Jan 2015
106 Posts
Ok I have only got to fly the o33g about 6 times and started having signal problems. The last 2 time I tried to fly was only about 2 foot off the ground because it would just drop like you cut to power completely off. I can be 2 foot or 20 and it loses single. Kind of a bummer to have a heli you are afraid to fly. Any help is greatly appreciated.
freebird1 is offline Find More Posts by freebird1
Reply With Quote
Old Feb 01, 2015, 03:09 PM
AMA # 75962
Jim Lee's Avatar
United States, WA, Port Orchard
Joined Apr 2007
1,070 Posts
Quote:
Originally Posted by freebird1 View Post
Ok I have only got to fly the o33g about 6 times and started having signal problems. The last 2 time I tried to fly was only about 2 foot off the ground because it would just drop like you cut to power completely off. I can be 2 foot or 20 and it loses single. Kind of a bummer to have a heli you are afraid to fly. Any help is greatly appreciated.
Sadly, the electronics in these aren't very good. If you're handy with a soldering iron, you could go over all of the solder connections in your Transmitter and also the power board in the heli. Flyers have had better signal reception after doing this.
The only real cure is to buy a heli that doesn't have these problems. If you've read through this thread or any thread about either the old 033G (which you have) or the newer S33 which is on 2.4GHz and isn't any better (it suffers signal loss also) as they all have the same problems.

I have a heli that is similar to my S33 and it's a Double Horse DH9118 and it needs to be modified to fly decent,(it doesn't have enough clearance between the upper and lower blades, so lower blades needs to be flipped upside down to help avoid the problem of frequent blade strikes with the upper set of blades,) but it doesn't suffer from the signal dropout that the S33 and 33G have.

J
Jim Lee is offline Find More Posts by Jim Lee
Reply With Quote
Old Feb 01, 2015, 04:19 PM
Registered User
Joined Jan 2015
106 Posts
Thanks Jim! True, I regret buying this heli. Had high hopes that it would fly decent, but never imagined the thing would lose signal. I did read a lot of the thread. I checked all connections and switch. Sad thing is it did not fly that bad after I put a 2200Mah in on the third flight. I guess I will scrap it or give it to a kid. Thanks again!!
freebird1 is offline Find More Posts by freebird1
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Thought I'd share some pics of my new eAVA FPV ship kajakmannen FPV Talk 7 Jul 15, 2014 03:57 PM
Build Log If You Have !New!,Different,Interesting Plane Models In Your Head You Can Share Here RcLento Foamies (Scratchbuilt) 19 Nov 25, 2011 03:57 PM
For Sale Super scale 500E 70-90 sized RTF trades! bmosconi Aircraft - Fuel - Helis (FS/W) 3 Apr 14, 2011 11:37 AM
Sold ABC Hobbies 36" Super Hawaii RC boat New Old Stock Ostrichsized Boats (FS/W) 1 Aug 13, 2010 12:57 PM
Sold Palm sized 3 channel Syma s010, and Havoc Heli peg-leg Aircraft - Electric - Helis (FS/W) 3 May 06, 2009 12:10 PM