HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Jan 29, 2012, 08:54 AM
Registered User
Australia, TAS, Devonport
Joined May 2011
146 Posts
Discussion
Connect battery & motor starts, dodgy ESC?

Hi, hopefully someone can confirm whether my ESC is broken..

I've got an 18-20A Hobbyking SS speed controller to connect to a Tek Sumo flying wing. When the battery is plugged in the speed control makes the usual start-up beeps, but then the motor starts spinning all by itself. The throttle and throttle trim are all the way back. Moving the throttle forwards a bit, then back off again stops the motor spinning.

The ESC doesn't have any throttle calibration so don't think that could be it.

Is there another alternative to it being faulty?

Hope someone can help, Cheers.
Heliosphere is offline Find More Posts by Heliosphere
Reply With Quote
Sign up now
to remove ads between posts
Old Jan 29, 2012, 09:01 AM
An itch?. Scratch build.
eflightray's Avatar
South Wales U.K.
Joined Mar 2003
13,397 Posts
Does the ESC instructions mention setting the 'throttle range' ?
eflightray is online now Find More Posts by eflightray
Reply With Quote
Old Jan 29, 2012, 05:13 PM
Fly it like you STOL it!
Endlesslag's Avatar
United States, FL, Daytona Beach
Joined Jan 2011
4,045 Posts
Center the throttle trim, see if that helps.
Endlesslag is online now Find More Posts by Endlesslag
Reply With Quote
Old Jan 29, 2012, 06:27 PM
Registered User
Australia, TAS, Devonport
Joined May 2011
146 Posts
Quote:
Originally Posted by eflightray View Post
Does the ESC instructions mention setting the 'throttle range' ?
Nah nothing like that, it's very basic with only settings for different battery types and brake.

Quote:
Originally Posted by Endlesslag View Post
Center the throttle trim, see if that helps.
Ok will try thanks. I've got another one of these ESCs though and it doesn't seem to be a problem having the trim down..
Heliosphere is offline Find More Posts by Heliosphere
Reply With Quote
Old Oct 09, 2012, 10:32 PM
Registered User
Canada, ON, Ottawa
Joined Sep 2012
1 Posts
I got have the same problem with the same configuration (same ESC for my Tek Sumo), my motor start spinning as soon as I open the receiver with the trottle trim all the way down.

Heliosphere, did you find a solution to that or was it really broken?
james74 is offline Find More Posts by james74
Reply With Quote
Old Oct 10, 2012, 07:58 PM
Registered User
Doug Bartley's Avatar
Canada, ON, Owen Sound
Joined Oct 2008
2,813 Posts
Try setting the throttle endpoint on your tx to say 112%.Several times myJR radioswon't recpgnize the low end with this adjustment. May be worth trying on your SS. Doug B
Doug Bartley is online now Find More Posts by Doug Bartley
Reply With Quote
Old Oct 10, 2012, 08:05 PM
Registered User
Australia, TAS, Devonport
Joined May 2011
146 Posts
Never found a solution James74, I think I tried changing the endpoint as Doug has suggested, but my memory isn't that good so worth a try for sure!

I'm using it to power a servo tester now so it wasn't a total loss.
Heliosphere is offline Find More Posts by Heliosphere
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion ESC Battery Easy Connect Board Katch Multirotor Talk 9 Aug 09, 2011 07:30 AM
Question How to connect motor, ESC, battery and receiver? xkubr Beginner Training Area (Aircraft-Electric) 7 May 20, 2011 11:27 AM
Discussion Eliminate Huge Spark when Connect ESC to Battery Super_Hornet DIY Electronics 11 Dec 27, 2009 08:21 PM
Discussion Eliminate Huge Spark when Connect ESC to battery Super_Hornet Scale Helicopters 7 Dec 20, 2009 10:51 PM
Discussion How do I connect Motor, ESC, RX & Battery??? jzcode49 Beginner Training Area (Aircraft-Electric) 14 Nov 15, 2008 12:31 PM