HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Dec 15, 2012, 05:56 PM
The Sequel
mustflynow2's Avatar
Australia, VIC
Joined Sep 2011
1,206 Posts
Quote:
Originally Posted by fastfwd View Post
I took her out for a flight today, everything worked great, new esc has brake enabled. solid control rods were good. I noticed the tail (not elevator) is loose at the front edge ? it moves left and right quite a bit,screws are tight it is right at the tip where it sits on fuselage. i put tape on to hold it still today,but going to use glue or something to keep it there has anyone else seen this on theres ? I had the Go pro on my head but guess i didnt get it turned on correctly was very cold and windy !
Yep mine did too, the screws don't quite pull it up far enough. I laid a strip of spongey 2mm doublesided tape down before I screwed it up, solid now. Don't overscrew off course, soft screws.
mustflynow2 is online now Find More Posts by mustflynow2
Reply With Quote
Sign up now
to remove ads between posts
Old Dec 15, 2012, 06:04 PM
Registered User
United States, ID, Burley
Joined Mar 2012
3,282 Posts
Quote:
Originally Posted by mustflynow2 View Post
Yep mine did too, the screws don't quite pull it up far enough. I laid a strip of spongey 2mm doublesided tape down before I screwed it up, solid now. Don't overscrew off course, soft screws.
ahh i see... that should do the trick, thanks !
fastfwd is offline Find More Posts by fastfwd
Reply With Quote
Old Dec 15, 2012, 09:35 PM
High Altitude Flyer
viking60's Avatar
Fairplay, South Park, CO
Joined Sep 2005
1,608 Posts
Fast,

I glued my tailgroup on solid- wasn't at all happy with the movement.

Robo,

the stock motor can perform very adequately IF you simply open up the air venting holes in the layers of the nose & motor mount that are not opened when the kit is delivered. Also add cooling air exit holes. Mine flies fine with it; (you can check my posting & photos back a few pages starting on page 163, post 2435.)

My stock ESC is also working fine once the cooling airflow is opened up & the extra heat shrink was cut away from certain areas on the ESC. The info on turning on the prop Brake on the stock ESC is also repeated within the last few pages following page 163. Since the setting tones are different than shown in an earlier video, I expect that the ESC has been upgraded / replaced with a different model than what was included in earlier kits. Bottom line- mine from the version III kit is performing fine to date; neither the motor or the ESC are showing more than slight warming at the end of a flight. And I'm flying slightly larger prop blades on my stock motor & ESC than what are included with the kit. So this reported weakness in the earlier versions of the Phoenix 2000 may have been improved upon.

(I did replace the stock kit servos before flying my Phoenix 2000; too many reports of sudden failure in flight for me to take a chance with them.)

VIKING
viking60 is offline Find More Posts by viking60
Last edited by viking60; Dec 15, 2012 at 09:48 PM.
Reply With Quote
Old Dec 15, 2012, 10:46 PM
Registered User
United States, ID, Burley
Joined Mar 2012
3,282 Posts
Quote:
Originally Posted by viking60 View Post
Fast,

I glued my tailgroup on solid- wasn't at all happy with the movement.

Robo,

the stock motor can perform very adequately IF you simply open up the air venting holes in the layers of the nose & motor mount that are not opened when the kit is delivered. Also add cooling air exit holes. Mine flies fine with it; (you can check my posting & photos back a few pages starting on page 163, post 2435.)

My stock ESC is also working fine once the cooling airflow is opened up & the extra heat shrink was cut away from certain areas on the ESC. The info on turning on the prop Brake on the stock ESC is also repeated within the last few pages following page 163. Since the setting tones are different than shown in an earlier video, I expect that the ESC has been upgraded / replaced with a different model than what was included in earlier kits. Bottom line- mine from the version III kit is performing fine to date; neither the motor or the ESC are showing more than slight warming at the end of a flight. And I'm flying slightly larger prop blades on my stock motor & ESC than what are included with the kit. So this reported weakness in the earlier versions of the Phoenix 2000 may have been improved upon.

(I did replace the stock kit servos before flying my Phoenix 2000; too many reports of sudden failure in flight for me to take a chance with them.)

VIKING
You know what i appreciate about your posts is they are informative without coming off as a know it all I will look back and do the vent holes,and yes sir i ended up gluing the forward part of stabilizer to fuse,there is no excuse for it to move like that and has got to cause the plane to move with it when it does A side note... I found that a hot air blow dryer take to the front of the canopy lets you curve it in quite nice so the prop no longer catches Now i just need to start from front and push it down and it clips on tight and snug ..
fastfwd is offline Find More Posts by fastfwd
Last edited by fastfwd; Dec 15, 2012 at 10:55 PM.
Reply With Quote
Old Dec 16, 2012, 04:32 AM
Registered User
HoosierGuy's Avatar
United States, IN
Joined Jan 2012
785 Posts
I managed to get the rest of my LED lights back on. Supposed to be warmer Sunday evening so hope to do another and longer night flight! I love flying at night!
HoosierGuy is offline Find More Posts by HoosierGuy
Reply With Quote
Old Dec 16, 2012, 06:38 AM
Registered User
RoboSerg's Avatar
Joined Sep 2011
478 Posts
Quote:
Originally Posted by viking60 View Post
Robo,

the stock motor can perform very adequately

VIKING
I bought an ARF w/o any electronics. So I was asking what max KV motor can the plane handle. Also what thrust should I get if I want fly vertically.
RoboSerg is offline Find More Posts by RoboSerg
Reply With Quote
Old Dec 16, 2012, 07:59 AM
Registered User
France, PCh, Marcillac-Lanville
Joined Sep 2012
25 Posts
Help with setting up

Hi
Have only ever flown a RC cessna, and am new to the hobby.
Would like some help in setting up my Phoenix. Am using Hitec optic 6 control, and would like to know what should be the maximum movement of the flaps, ailerons, rudder and elevator.
If someone is using the same Tx could they please tell me what settings they have used for their CROW function.

Not sure if I will see my Phoenix when its up in the air and wondered if its safe to iron on some bright red solar film patches under the wings, or would it damage the foam.
johnmarcillac is offline Find More Posts by johnmarcillac
Reply With Quote
Old Dec 16, 2012, 03:13 PM
Registered User
United States, ID, Burley
Joined Mar 2012
3,282 Posts
Quote:
Originally Posted by johnmarcillac View Post
Hi
Have only ever flown a RC cessna, and am new to the hobby.
Would like some help in setting up my Phoenix. Am using Hitec optic 6 control, and would like to know what should be the maximum movement of the flaps, ailerons, rudder and elevator.
If someone is using the same Tx could they please tell me what settings they have used for their CROW function.

Not sure if I will see my Phoenix when its up in the air and wondered if its safe to iron on some bright red solar film patches under the wings, or would it damage the foam.
i paint several black stripes on bottom of all my wings. used acrylic latex enamel paint,no problems.as far as the flaps go i set mine so when they are down there is no binding of servos.
fastfwd is offline Find More Posts by fastfwd
Reply With Quote
Old Dec 16, 2012, 05:26 PM
Member #1
Teamsherman's Avatar
Australia, NSW, Picnic Point
Joined Aug 2011
6,783 Posts
Quote:
Originally Posted by mustflynow2 View Post
3s teamsherman? You got to go to 4s and it will come alive!
Hmm, 4s you say? I have got some 4s 2200mah's here that i have no use for at the moment, i'll give them a try! This thing on 3s is pretty quick so i can see that 4s is going to be fun!!!

Quote:
Originally Posted by fastfwd View Post
is the motor that was heating up the stock setup ? I have only had mine in the air for around 10 minutes but everything was cool to the touch,using a 45 amp esc with 6 amp sbec . So now im wondering if i need to put in some vent holes or what if stock setup is heating up ?
Yeah, i ditched the stock motor and esc after its 2nd flight as they were coming down super hot and smelling slightly burnt, and that was only using bursts of 15 seconds or less with a rest period between squirts of the throttle.

Im now using the 3639 750kv as suggested by mustflynow2 a little while ago and with the full carbon 13x7 folding prop it is great! Its quickly become one of my top 3 favourite planes with this setup. And as mustflynow2 just suggested i'll give it a crack on 4s this week sometime and let you all know my result.
Teamsherman is offline Find More Posts by Teamsherman
Reply With Quote
Old Dec 16, 2012, 07:14 PM
Registered User
HoosierGuy's Avatar
United States, IN
Joined Jan 2012
785 Posts
I flew my Phoenix Evolution tonight with my leds on. I rearranged the lights some. I put the blue ones on the bottom leading edge and then had green led legs running down. So it was blue and green on the bottom of the wings with lights on top of the wings and lights running the length of the fuselage.

Plus - I had my first UFO report! A kid in a truck came down the road and got out. I heard the door slam and for a second I thought to myself "I hope it's not a county police officer" lol. Anyway, my brother talked to him and he said his Grand Pa saw my glider and also believes in UFO's and so he (grandson) came down to check it out. My brother exclaimed it's basically a flying styrofoam cooler with Christmas lights on it. lol.

I'm discovering there is no lift/wind at night. When I cut my motor my glider with all the lights and junk inside wants to drop and drop quick. I flew for more than ten minutes with the motor on. I tried cutting the motor and gliding but I could not glide for more than five seconds or so.

The ESC LVC kicked in too but luckily it happened near me. So I landed it OK. I've discovered I can get a good fifteen to twenty minutes in the day flying with the motor on 2/3 of the time and off 1/3 of the time. But at night I have to keep the motor running and that cuts my time down by a large amount.

All in all - a nice night!
HoosierGuy is offline Find More Posts by HoosierGuy
Reply With Quote
Old Dec 16, 2012, 09:14 PM
Registered User
HoosierGuy's Avatar
United States, IN
Joined Jan 2012
785 Posts
Can't really see much but here's my proof! Used an 808 key chain camera with fish eye lens.

Phoenix Evolution Night Flight (1 min 6 sec)
HoosierGuy is offline Find More Posts by HoosierGuy
Reply With Quote
Old Dec 16, 2012, 09:35 PM
The Sequel
mustflynow2's Avatar
Australia, VIC
Joined Sep 2011
1,206 Posts
Nice one HG! Are they changing colors ther under the wing?
mustflynow2 is online now Find More Posts by mustflynow2
Reply With Quote
Old Dec 16, 2012, 09:41 PM
Registered User
HoosierGuy's Avatar
United States, IN
Joined Jan 2012
785 Posts
Quote:
Originally Posted by mustflynow2 View Post
Nice one HG! Are they changing colors ther under the wing?

No. The lights on the bottom of the wing stay on. The top too. But the fuselage has led lights that I can turn on and off from my dx6i. I purchased some leds with a controller from Hobbyking that has six or seven (or eight) different settings: Blue/green/white/flashing/etc... I have those lights running the length of the fuselage.
HoosierGuy is offline Find More Posts by HoosierGuy
Reply With Quote
Old Dec 16, 2012, 09:47 PM
The Sequel
mustflynow2's Avatar
Australia, VIC
Joined Sep 2011
1,206 Posts
Ah must be a reflection i was seeing.
mustflynow2 is online now Find More Posts by mustflynow2
Reply With Quote
Old Dec 16, 2012, 09:52 PM
Registered User
HoosierGuy's Avatar
United States, IN
Joined Jan 2012
785 Posts
Quote:
Originally Posted by mustflynow2 View Post
Ah must be a reflection i was seeing.

One of the settings for the leds lights on the fuselage is blinking and I did have them blinking a few times.

Here are the led lights I use on the fuselage:

http://www.hobbyking.com/hobbyking/s...dProduct=23792

I need a new TX. This DX6i simply isn't doing it for me anymore. It's a great first TX. But I need something that vibrates when the timer hits zero and also has a back-light.
HoosierGuy is offline Find More Posts by HoosierGuy
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
For Sale HK Phoenix 2000 glider blk822 Aircraft - Electric - Airplanes (FS/W) 4 Aug 23, 2011 07:21 PM
Discussion Still having electric problems with my hobbyking Phoenix 2000, Crashvideo kyrkbymannen Electric Sailplanes 3 Jul 09, 2011 07:34 PM
Discussion Ohhh noo, 2nd flight on the HobbyKing Phoenix 2000 KillerCut Electric Sailplanes 14 Jun 06, 2011 09:57 AM
Discussion hobby king Phoenix 2000 EPO Composite R/C Glider doomracing Electric Sailplanes 3 May 31, 2011 10:09 PM