HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Sep 17, 2014, 03:40 AM
Registered User
Australia, VIC, Kilmore
Joined Nov 2008
9 Posts
Help!
Issue with OSD Pro + Guardian + Serial PPM

Hi All

I am having a problem with my OSD Pro and Guardian when using Serial PPM

Wing type is Elevon
Receiver is a FrSky D8R-XP, set to CPPM mode.
Receiver type in OSD is set to PPM with no F/S
All firmware is at current levels.

I have sucessfully setup serial PPM mode and all controls work as normal.

The issue is that when I enable stabilization, all elevator and aileron controls stop working. Throttle continues to function normally.

If I go back into the Serial PPM setup screen I can see that the control inputs are still registering.

Disabling stabilization enables all the controls again.

The servo analysis wizard has been run multiple times from both the Data Recorder software and directly in the OSD, with no effect.

The OSD Pro has been reset back to factory defaults with the same result.

If I disable Serial PPM and wire in all the channels the old way, stabilization works correctly. It would appear that my issue only occurs when SPPM is being used.

It has been mentioned in this thread that applying someone else's configuration can fix it, but I don't have one of those and would prefer to know what the issue is.
http://www.rcgroups.com/forums/showthread.php?t=1589117

Any ideas would be appreciated.
Daz74 is offline Find More Posts by Daz74
Reply With Quote
Sign up now
to remove ads between posts
Old Sep 17, 2014, 09:13 AM
JohnET's Avatar
United States, NC, Charlotte
Joined Apr 2013
435 Posts
Hello,

Try the below and if it doesn't fix the issue, open a support ticket on our website and we will help you get it sorted.

Be sure you are using our latest software, from here; www.eagletreesystems.com/software

Connect the eLogger (with no other devices connected to the eLogger) to your computer and update the firmware even if it says it has the latest already installed.

Disconnect the eLogger and connect the OSD Pro to it and reconnect to your computer. Then reset the OSD to factory defaults (you will lose your settings so make a backup to restore later) and then update the firmware even if it says it has the latest already installed.

Disconnect the eLogger from your computer and connect the Guardian Stabilizer Expander to the OSD Pro and reconnect it to your computer and update the firmware even if it says it has the latest already installed.

Disconnect the eLogger from your computer and connect any other sensors and reconnect it to your computer and update any other firmware even if it says it has the latest already installed.

Configure one parameter on the OSD, enable PPM and setup you model type, stabilization, run the servo analysis wizard etc. Does it work correctly?

Restore your OSD configuration and test the system.

If this works initially but stops again after restoring your OSD settings, you will need to reset all your OSD settings manually as opposed to restoring it from the backup file.

Regards, John
JohnET is offline Find More Posts by JohnET
Site Sponsor
Reply With Quote
Old Sep 18, 2014, 02:07 AM
Registered User
Australia, VIC, Kilmore
Joined Nov 2008
9 Posts
Thanks for the prompt response John.

I have followed your instructions and updated all firmware. Running Data Recorder 10.52

I am now consistently getting the following error when I click "Finish" in the Servo Analysis Wizard. It does not matter if I have Serial PPM enabled or not.
Name: Error1.png
Views: 5
Size: 10.9 KB
Description:

I have also seen this error occur occasionally when opening the OSD config in Data Recorder.
Name: Error2.png
Views: 3
Size: 8.3 KB
Description:

I have rebooted my PC and tried a different USB cable.

Let me know if there is anything else I can try or if I should just log a ticket.
Daz74 is offline Find More Posts by Daz74
Reply With Quote
Old Sep 18, 2014, 08:32 AM
JohnET's Avatar
United States, NC, Charlotte
Joined Apr 2013
435 Posts
Hello,

Try running the Servo Analysis Wizard from the OSD screen via the stick menus without the system connected by usb. If you can't get it working, open a support ticket and we will help you get it sorted.

Regards, John
JohnET is offline Find More Posts by JohnET
Site Sponsor
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Sold EagleTree OSD Elogger v4 OSD pro gps and guardian expander wootenelli FPV Equipment (FS/W) 0 Nov 13, 2013 10:46 AM
Sold EagleTree OSD Elogger v4 OSD pro gps and guardian expander wootenelli FPV Equipment (FS/W) 2 Oct 14, 2013 11:04 AM
Discussion D/R and expo tx setting with eagletree osd pro & guardian? T_flyoo4 Eagle Tree Systems 1 Oct 01, 2013 07:50 AM
Sold OSD Pro Pkg with eLogger v4, OSD Pro, GPS, Guardian Stabilizer, & Airspeed Sensor HansAuf FPV Equipment (FS/W) 5 Jun 16, 2013 12:58 PM
Discussion OSD pro with guardian issue sidewinderFSK Eagle Tree Systems 1 Jan 30, 2013 04:34 PM