New Products Flash Sale
Thread Tools
Old May 14, 2015, 12:19 PM
Jasen40 is online now
Find More Posts by Jasen40
Registered User
United States, CA, San Jose
Joined Jun 2012
1,563 Posts
I picked up a 300x for a good price in the classifieds. It has a hobbymate hb800 V2 gyro, full cnc head and tail. Plus metal gear servos. I hope getting one with a clone of beast gyro does not get me into issues.
Jasen40 is online now Find More Posts by Jasen40
Last edited by Jasen40; May 14, 2015 at 01:05 PM.
Reply With Quote
Sign up now
to remove ads between posts
Old May 14, 2015, 03:29 PM
Jasen40 is online now
Find More Posts by Jasen40
Registered User
United States, CA, San Jose
Joined Jun 2012
1,563 Posts
Does any one have a Devitation V4 file they would be willing to share. I have a couple models for my 130x, mcpx bl, and nano. Can those be used?
Jasen40 is online now Find More Posts by Jasen40
Reply With Quote
Old May 19, 2015, 12:22 PM
Jasen40 is online now
Find More Posts by Jasen40
Registered User
United States, CA, San Jose
Joined Jun 2012
1,563 Posts
Please help me while I still have some hair left. I got the Helicopter yesterday, all it wants to do is spin at full throttle once the ESC arms . No control from the Tx. I have gotten the servo to twitch a bit, but no control via the TX(Devo 10 with Deviation). I fly all my UMX planes and blade helicopters with it. The other extra wrinkle is it came with a hobbymate H800 V1 beast clone and AR6115E.
Jasen40 is online now Find More Posts by Jasen40
Last edited by Jasen40; May 19, 2015 at 04:45 PM.
Reply With Quote
Old May 19, 2015, 08:58 PM
mejmea is offline
Find More Posts by mejmea
Always trying to learn
mejmea's Avatar
United States, IL, Batavia
Joined Feb 2011
722 Posts
Quote:
Originally Posted by Jasen40 View Post
Please help me while I still have some hair left. I got the Helicopter yesterday, all it wants to do is spin at full throttle once the ESC arms . No control from the Tx. I have gotten the servo to twitch a bit, but no control via the TX(Devo 10 with Deviation). I fly all my UMX planes and blade helicopters with it. The other extra wrinkle is it came with a hobbymate H800 V1 beast clone and AR6115E.
I don't have personal knowledge about the Devo or the Hobbymate clone but I'll try to offer some general thoughts:

1) First things first - hopefully by now you've taken both main and tail blades off, and preferably the head too, until you get this sorted out.
2) Have you checked the voltage that current BEC is supplying? Do you have a stand-alone BEC that you could use to power the RX/FBL unit (rather than from the esc) to see if/how they respond?
3) Try powering only the Rx with only a servo plugged directly into it and see if things respond in a normal manner. Repeat for all channels to determine if the Rx is behaving normally.
4) What ESC does it have? Have you checked its programming? Does it go through a normal arming sequence before it goes to full throttle? Do you have a spare ESC sitting around to try in place of the one acting strangely?
5) Not knowing anything about this FBL unit, does it have any interaction with the ESC (such as a governor) that could be playing a role? Have you checked the programming in the FBL unit?

The bottom line is to isolate components and try to test them individually and then start adding pieces back in to try and figure out where the problem lies.

Good luck and let us know what you figure out.
mejmea is offline Find More Posts by mejmea
Reply With Quote
Old May 19, 2015, 11:36 PM
The_Reaper_83 is offline
Find More Posts by The_Reaper_83
Registered Flight Addict
The_Reaper_83's Avatar
Australia, WA, Ellenbrook
Joined Aug 2013
616 Posts
You haven't accidentally reversed the throttle input in the TX?.
The_Reaper_83 is offline Find More Posts by The_Reaper_83
Reply With Quote
Old May 19, 2015, 11:50 PM
Jasen40 is online now
Find More Posts by Jasen40
Registered User
United States, CA, San Jose
Joined Jun 2012
1,563 Posts
Thanks guys for the replies, I finally got my settings on the TX, and esc low high points dialed in correctly. It was a frustrating two days, but the reward was I got hover in the drive way. I need to smooth out light shaking before let her rip though the field. The blades aligned, and not to tight. Can an overly tight belt cause shaking? I guess I need to skim through 281 pages, and get some knowledge on this heli.
Jasen40 is online now Find More Posts by Jasen40
Reply With Quote
Old May 20, 2015, 12:52 AM
erkq is online now
Find More Posts by erkq
Registered User
United States, CA, Sebastopol
Joined Dec 2010
9,564 Posts
Quote:
Originally Posted by Jasen40 View Post
Please help me while I still have some hair left. I got the Helicopter yesterday, all it wants to do is spin at full throttle once the ESC arms . No control from the Tx. I have gotten the servo to twitch a bit, but no control via the TX(Devo 10 with Deviation). I fly all my UMX planes and blade helicopters with it. The other extra wrinkle is it came with a hobbymate H800 V1 beast clone and AR6115E.
Is "idle up" on? "stunt" mode?
erkq is online now Find More Posts by erkq
Reply With Quote
Old May 20, 2015, 06:26 AM
mejmea is offline
Find More Posts by mejmea
Always trying to learn
mejmea's Avatar
United States, IL, Batavia
Joined Feb 2011
722 Posts
Quote:
Originally Posted by Jasen40 View Post
Thanks guys for the replies, I finally got my settings on the TX, and esc low high points dialed in correctly. It was a frustrating two days, but the reward was I got hover in the drive way. I need to smooth out light shaking before let her rip though the field. The blades aligned, and not to tight. Can an overly tight belt cause shaking? I guess I need to skim through 281 pages, and get some knowledge on this heli.
Glad to hear it's working. I believe there have been reports of vibration issues due to the belt being to tight.
mejmea is offline Find More Posts by mejmea
Reply With Quote
Old May 20, 2015, 07:21 AM
Tim Wolff is online now
Find More Posts by Tim Wolff
Gravity is a harsh mistress.
Tim Wolff's Avatar
United States, MI, Temperance
Joined Sep 2002
6,702 Posts
Quote:
Originally Posted by mejmea View Post
Glad to hear it's working. I believe there have been reports of vibration issues due to the belt being to tight.
Or too loose, or looked at wrong

If it still has the stock tail hub, that is the first place to look for tail vibes.
Tim Wolff is online now Find More Posts by Tim Wolff
RCG Plus Member
Reply With Quote
Old May 20, 2015, 08:20 AM
Pen is offline
Pen
Find More Posts by Pen
Pen
FPWhat?
Pen's Avatar
United States, AL, Huntsville
Joined Sep 2008
1,659 Posts
I had to play with adding small pieces of tape to tail blades to get rid of vibes. Add a small piece to a tail blade, spool up, if vibe gets worse move tape to other blade, adjust till vibe is minimized, trial and error.
Pen is offline Find More Posts by Pen
Reply With Quote
Old Yesterday, 02:56 PM
Jasen40 is online now
Find More Posts by Jasen40
Registered User
United States, CA, San Jose
Joined Jun 2012
1,563 Posts
Turning down pot 1 on the Hobbymate h800 v2 was the answer, not there is almost no shaking.
Flew two packs this morning through her, I can tell I going to enjoy flying this big heli.
Jasen40 is online now Find More Posts by Jasen40
Reply With Quote


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
For Sale Trex 700E FBL BeastX BNF 1600$ Shipped trevjonez Aircraft - Electric - Helis (FS/W) 1 Aug 15, 2011 08:04 PM
For Sale Outrage 550 FBL W/BeastX BNF KenM Aircraft - Electric - Helis (FS/W) 2 Jul 09, 2011 07:20 AM
Found BeastX FBL controller Hellsiege Aircraft - Electric - Helis (FS/W) 0 Jan 28, 2011 02:24 PM
Sold BeastX, Spektrum Satellite, BeastX Satellite Adapter, 450 Sport FBL Head NovaCX12 Aircraft - Electric - Helis (FS/W) 1 Jan 22, 2011 08:07 AM
Sold Microbeast BeastX FBL unit NEW never used Z06 Tony Aircraft - Electric - Helis (FS/W) 0 Dec 07, 2010 05:23 PM