SMALL - espritmodel.com SMALL - Telemetry SMALL - Radio
Reply
Thread Tools
Old Mar 11, 2011, 06:39 PM
Smoke on , go !
zaguruinzasky's Avatar
Verona - Italy
Joined Jan 2007
2,527 Posts
Discussion
Flight Control Board Servo Problem

Hi have a problem with my new Mikrokopter, the only servo output that works is the camera roll, all other 3 servo outputs are not working, I tried to set the camera nick to POTI1 (assigned to ch5) and moving channel 5 on my radio but the NICK doesn't move at all, I tried to assigned a position instead of a POTI but same problem, the servo is not even mataining position, it's just off.

Servos are ok (tested with servo tester..)

What can be the problem ?


Thanks
zaguruinzasky is offline Find More Posts by zaguruinzasky
Reply With Quote
Sign up now
to remove ads between posts
Old Mar 11, 2011, 08:56 PM
Suspended Account
Joined Dec 2010
11,763 Posts
Did you plug them into proper sockets?
Bottom of SV3 socket, is roll
Bottom of SV2 socket, is pitch.
Also note rotation of the plugs.
http://gallery.mikrokopter.de/main.p...tions.gif.html
timecop is offline Find More Posts by timecop
Reply With Quote  (Disabled)
Old Mar 11, 2011, 08:57 PM
Smoke on , go !
zaguruinzasky's Avatar
Verona - Italy
Joined Jan 2007
2,527 Posts
yes yes I have two copters and did the same as the other one..
zaguruinzasky is offline Find More Posts by zaguruinzasky
Reply With Quote
Old Mar 14, 2011, 08:58 AM
Smoke on , go !
zaguruinzasky's Avatar
Verona - Italy
Joined Jan 2007
2,527 Posts
ah I just found the problem,

the company I paid for the boards assembly work not just made a wrong esc assignment (esc 2 and 3 both assigned as esc 3), also forgot to solder the servo plug.

You guys think it's correct to pay €600 for this work ?
zaguruinzasky is offline Find More Posts by zaguruinzasky
Reply With Quote
Old Mar 14, 2011, 09:59 AM
Suspended Account
Joined Dec 2010
11,763 Posts
Soldering looks weird just like on ESC... Like iron is not hot enough or too hot, can't tell.. But the color / shininess is wrong. Maybe not using flux, too... That could do it.
timecop is offline Find More Posts by timecop
Reply With Quote  (Disabled)
Old Mar 14, 2011, 10:10 AM
Smoke on , go !
zaguruinzasky's Avatar
Verona - Italy
Joined Jan 2007
2,527 Posts
Yup, btw the servo plug is actually not soldered at all, there is just som solder on the pads, but no contact with the plug
zaguruinzasky is offline Find More Posts by zaguruinzasky
Reply With Quote
Old Mar 14, 2011, 10:12 AM
Suspended Account
Joined Dec 2010
11,763 Posts
When I do those, usually use small pliers to bend the pins slightly so they have full contact with the pads then solder. that makes sure stuff like this doesn't happen...
timecop is offline Find More Posts by timecop
Reply With Quote  (Disabled)
Old Mar 14, 2011, 10:40 AM
Smoke on , go !
zaguruinzasky's Avatar
Verona - Italy
Joined Jan 2007
2,527 Posts
thata's a good idea
zaguruinzasky is offline Find More Posts by zaguruinzasky
Reply With Quote
Old Mar 14, 2011, 01:34 PM
Registered User
Joined Feb 2011
472 Posts
were this you buy that thing?! resolder alle connections... that are cold solder points!
V_Okto is offline Find More Posts by V_Okto
Reply With Quote
Old Mar 14, 2011, 01:36 PM
Smoke on , go !
zaguruinzasky's Avatar
Verona - Italy
Joined Jan 2007
2,527 Posts
Bought it here http://shop.jet-1a.com/
zaguruinzasky is offline Find More Posts by zaguruinzasky
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion problem with RC Tech 6 CH Flight Simulator Remote Control volto Nitro Planes 7 Feb 14, 2011 04:53 PM
Discussion CPU board + Servo board to control servos for Bicycle Deraillur project Z06kal UAV - Unmanned Aerial Vehicles 1 Nov 17, 2009 06:25 PM
Careful! A Problem with Control Board R/CJohn RC Tanks 2 Jul 31, 2008 09:34 AM
Help! New HV-2 control board (voltage detect problem). Paul X Castle Creations 5 Aug 23, 2007 07:44 AM
Aerohawk Control Board Problem JackR Micro Helis 17 Jul 12, 2004 06:49 PM