Espritmodel.com Telemetry Radio
Closed Thread
Thread Tools
Old Jan 06, 2013, 01:23 PM
Registered User
UDO999's Avatar
United States, MN, Minneapolis
Joined Jul 2010
248 Posts
Help!
5.8 video help needed

Name: ImageUploadedByTapatalk1357499653.919438.jpg
Views: 34
Size: 92.6 KB
Description: Name: ImageUploadedByTapatalk1357499685.122387.jpg
Views: 31
Size: 107.6 KB
Description: Name: ImageUploadedByTapatalk1357499703.434674.jpg
Views: 37
Size: 101.3 KB
Description:

I'm having trouble getting my Fatshark 5.8 system working. I have Fatshark Predators with an Immersion 600mw tx using CP antennas. The video looks good but when I get about 50 feet away the video breaks up a lot. When I turn the quad around to return home I loose signal completely. Should I have the antenna on the tx pointing down? I don't have any type of filters on the power, do I need one? I've tried a different tx, different antennas, all channels and I'm ready to just order up a 1.3 system. Could someone please tell me if they see something wrong? I've spent many hours pulling my hair out on this.
UDO999 is online now Find More Posts by UDO999
Sign up now
to remove ads between posts
Old Jan 06, 2013, 06:04 PM
Project Tormentor is flying!
United States, WA, White Salmon
Joined Nov 2005
1,990 Posts
You will have much better luck getting help for this in the FPV section
philthyy is online now Find More Posts by philthyy
Old Jan 07, 2013, 05:32 AM
Registered User
Beerwiser's Avatar
Canada, AB, Mundare
Joined Mar 2011
599 Posts
I am guessing your battery is blocking the signal. 5.8 has very poor penetration, but like the previous poster put this in the fpv section for more help.
Beerwiser is offline Find More Posts by Beerwiser
Old Jan 07, 2013, 11:43 AM
Registered User
UDO999's Avatar
United States, MN, Minneapolis
Joined Jul 2010
248 Posts
Thanks for the replies. I will try that.
UDO999 is online now Find More Posts by UDO999
Closed Thread


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion 72 mhz, 5.8 video, 1.2 video & 900mhz DJI datalink. What do you think? Any glitches? djdaveq FPV Talk 0 Jul 11, 2012 11:50 PM
Wanted immersion 5.8 ghz video tx 200mw-600mw flohio117 FPV Equipment (FS/W) 3 Mar 24, 2012 04:27 PM
Discussion video relay from GS - both on 5.8, how far apart? BCSaltchucker FPV Talk 1 Mar 21, 2012 05:49 AM
Help! Frequency selection help please, 5.8 or 900mhz. Need to decide which one to get jasper7821 FPV Talk 12 Mar 15, 2012 04:59 PM
Help! fatshark aviator 5.8 video splits,wavy,rolls?? barok FPV Talk 1 Mar 10, 2012 08:00 AM