HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Jan 28, 2015, 07:50 PM
Registered User
Saugus, Ca.
Joined Dec 2008
288 Posts
Help!
9958 keeps losing connection

Long story short, been out of the hobby for a few years and got back in for a little fun in doors with the 9958.

Flew great for 2 days. Now when I charge the lipo (stock), turn on radio, plug in lipo, it blinks fast, then stops (like it should). As soon as I touch the main rotor throttle, the rapid blink starts again. All other servos work fine unless I touch that main throttle. Haven't had a any big crashes or anything, just charged it after a flight and now it's doing this.
bubblebass is offline Find More Posts by bubblebass
Reply With Quote
Sign up now
to remove ads between posts
Old Jan 28, 2015, 08:18 PM
V911, V912 and micro coax
Joined Dec 2014
90 Posts
Have you tried plugging in lipo first, then when the light is blinking, turn on the radio?
OldLady is offline Find More Posts by OldLady
Reply With Quote
Old Jan 28, 2015, 09:10 PM
Registered User
Saugus, Ca.
Joined Dec 2008
288 Posts
Yes. Both ways. Blinks fast, then connects. Touch throttle, lose connection.
bubblebass is offline Find More Posts by bubblebass
Reply With Quote
Old Jan 28, 2015, 09:21 PM
V911, V912 and micro coax
Joined Dec 2014
90 Posts
Bugger... well, while we're waiting for more experienced replies... I found this post... it's not about your particular model but has a suggestion for checking battery wires... the guy can't talk English well but:

"Theses are symptom from bad battery connection to the board, plug and deplug battery make them loose after It bind on the table but in the air you loose signal when shaking..also You can experiment some hard take off due to lack of power, and switch battery doesnt change anything itsannoying Very easy to detect, shake the battery lead and if the light start blinking you have loose the connection/bind Those tiny silicone wire you cant see but inside they may have disconnect or soo, it took 5min to repair with 60W iron. "

http://www.helifreak.com/showthread.php?t=622743
OldLady is offline Find More Posts by OldLady
Reply With Quote
Old Jan 29, 2015, 08:04 AM
Registered User
Tucson, Az
Joined Feb 2007
10,001 Posts
9958 comes with cheap battery. Try E-flite 150 ma 25 c. Good sign os heli loses bind.
dankar04 is offline Find More Posts by dankar04
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Hubsan x4 Led, Transmitor loses connection Levandrium Mini Multirotors 6 Jan 23, 2015 07:43 AM
Help! Walkera Qr x350 FPV losing GPS signal with fpv connected. mjk5963 Multirotor Talk 3 Dec 14, 2014 12:18 PM
Question Keep losing RCG Log In Piper J3 Site Suggestions / Complaints 2 Jul 14, 2014 08:26 PM
Help! KK2.1 board keeps losing it's settings between flights! harrymc Multirotor Electronics 5 Jul 09, 2014 04:27 AM
Question Can RC airplanes lose connection near the airport? aleksa6767 Crash Discussion 3 Jan 16, 2014 10:13 PM