HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Aug 02, 2014, 05:44 PM
Registered User
UDO999's Avatar
United States, MN, Minneapolis
Joined Jul 2010
248 Posts
Yes, I did. I'm going to try to recover it tonight. Wish me luck, I haven't had to recover anything yet. And pointers Steve?
UDO999 is online now Find More Posts by UDO999
Reply With Quote
Sign up now
to remove ads between posts
Old Aug 02, 2014, 05:54 PM
I fly, therefore, I crash!!!
SteveT.'s Avatar
San Jose, CA
Joined Jan 2008
26,374 Posts
If I was there, I could show you a few tricks, but kind of hard to explain....however, there are many good videos on the net that will help..

Personally, I don't like covering with Ultracote, I much prefer the older Monokote, but even today's Monokote is not what it used to be...But of course since the plane was originally covered in Ultracote, that is what you have to deal with..

SteveT.
SteveT. is online now Find More Posts by SteveT.
RCG Plus Member
Latest blog entry: My hangar...
Reply With Quote
Old Aug 02, 2014, 05:58 PM
Registered User
UDO999's Avatar
United States, MN, Minneapolis
Joined Jul 2010
248 Posts
Yeah, that makes sense. Thanks for the link, I'll post some pics when I'm done.
UDO999 is online now Find More Posts by UDO999
Reply With Quote
Old Aug 04, 2014, 08:02 AM
Registered User
UDO999's Avatar
United States, MN, Minneapolis
Joined Jul 2010
248 Posts
Back in business! It's not perfect but good enough for a first attempt at recovering.


Name: uploadfromtaptalk1407157325713.jpg
Views: 20
Size: 53.7 KB
Description: Name: uploadfromtaptalk1407157336637.jpg
Views: 22
Size: 49.4 KB
Description: Name: uploadfromtaptalk1407157351373.jpg
Views: 18
Size: 41.1 KB
Description:
UDO999 is online now Find More Posts by UDO999
Reply With Quote
Old Aug 04, 2014, 08:55 AM
Registered User
UDO999's Avatar
United States, MN, Minneapolis
Joined Jul 2010
248 Posts
I know I'm missing a piece of white and blue on there. When I find a cowl I'll get it finished up.
UDO999 is online now Find More Posts by UDO999
Reply With Quote
Old Aug 04, 2014, 09:17 AM
Registered User
Canada, ON, Mississauga
Joined Nov 2012
8 Posts
Hi....well I have been flying my extra for about a month now and love it!! The only thing I have noticed is that for about the first minute of flight I get a knocking sound coming from the motor/esc. The sound is rhythmic with a definite frequency about 3hz but it only happens at full throttle. Almost sounds like a mechanical sound but it isn't since I have eliminated that. I started with 19x10 prop then went to 19x8 and it made no difference. Played with timing and seemed to make no diff. Set current limit to insensitive and no diff. The only thing I haven't tried is to go from 8 to 12 kHz pwm. Has anyone had these problems??? I have an 8s setup with motrolfly 4330 298 using Castle Edge 100. Separate Western Robotics BEC. Doesn't seem to affect performance at all but I want to find out what it is.......after about 1 min of flight it is ok...at least I no longer can hear it. So it must have something to do with battery voltage being higher at start?? One thing I had to do was to extend the esc wire harness to the receiver by about 6 inches....maybe the increased length is causing problems??? Any ideas??....Thanks!!
kman240 is offline Find More Posts by kman240
Reply With Quote
Old Aug 04, 2014, 09:19 AM
Barefoot Birkinsomething
rcbirk21's Avatar
United States, CA, Hayward
Joined Aug 2004
9,388 Posts
Quote:
Originally Posted by kman240 View Post
Hi....well I have been flying my extra for about a month now and love it!! The only thing I have noticed is that for about the first minute of flight I get a knocking sound coming from the motor/esc. The sound is rhythmic with a definite frequency about 3hz but it only happens at full throttle. Almost sounds like a mechanical sound but it isn't since I have eliminated that. I started with 19x10 prop then went to 19x8 and it made no difference. Played with timing and seemed to make no diff. Set current limit to insensitive and no diff. The only thing I haven't tried is to go from 8 to 12 kHz pwm. Has anyone had these problems??? I have an 8s setup with motrolfly 4330 298 using Castle Edge 100. Separate Western Robotics BEC. Doesn't seem to affect performance at all but I want to find out what it is.......after about 1 min of flight it is ok...at least I no longer can hear it. So it must have something to do with battery voltage being higher at start?? One thing I had to do was to extend the esc wire harness to the receiver by about 6 inches....maybe the increased length is causing problems??? Any ideas??....Thanks!!
there was a knocking problem a while back with the old reaper motors on castle esc's. try hooking up your esc to a castle link and disable the logging. if that does not fix it, i would try soldering a capacitor bank to the esc due to the extended battery wires, but i wouldnt think that would cause the knocking
rcbirk21 is offline Find More Posts by rcbirk21
RCG Plus Member
Latest blog entry: Joe's Battery Contraption
Reply With Quote
Old Aug 04, 2014, 09:45 AM
Registered User
Dennis C's Avatar
Grass Valley California
Joined Jun 2004
2,467 Posts
I think he extended signal wires to the receiver not the battery wires. If it is the wire from the ESC to receiver extended with a servo wire extension then there should be no problem.

Dennis
Dennis C is offline Find More Posts by Dennis C
Reply With Quote
Old Aug 04, 2014, 02:05 PM
I fly, therefore, I crash!!!
SteveT.'s Avatar
San Jose, CA
Joined Jan 2008
26,374 Posts
Quote:
Originally Posted by UDO999 View Post
Back in business! It's not perfect but good enough for a first attempt at recovering.


Attachment 6986553Attachment 6986554Attachment 6986555
Looks good from here!!

SteveT.
SteveT. is online now Find More Posts by SteveT.
RCG Plus Member
Latest blog entry: My hangar...
Reply With Quote
Old Yesterday, 09:29 PM
Registered User
ChiTownFlyer's Avatar
United States, IL, Elmhurst
Joined May 2013
245 Posts
Gentleman, A buddy had a little mishap at the field and crashed his 72" 330 He gave me the frame and wings.. The tail section is perfect and the motor box up front is great.. But the middle section were the wing tube enters is in bad shape on both sides.. But I am enthusiastic about doing a repair.. Now I am new to the hobby and have replaced a motorbox before so I have a little experience with balsa.. With that being said I am looking for a crashed frame with the middle section in tact I would pay for shipping and a little extra for your troubles. Please let me know what you have as I do have the electronics for this size plane and already own the 57" 330SC which I love but already have too many planes to justify buying this frame new at $439.00
ChiTownFlyer is online now Find More Posts by ChiTownFlyer
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Build Log 3D Hobby Shop 57" Extra 330 SC -Build Thread- flyinhigh025 3D Flying 13787 Today 11:08 PM
Sold 3D Hobby Shop 47" Extra SHP V2 ctraut5 Aircraft - Electric - Airplanes (FS/W) 3 Sep 20, 2009 12:08 PM
Sold 3D Hobby Shop Extra 300SR silent_guru Aircraft - Electric - Airplanes (FS/W) 8 Sep 19, 2009 02:21 PM
Video 3D Hobby Shop 103" Extra 330 SC sukhoi26mx Fuel Plane Talk 7 Feb 27, 2009 08:37 AM