SMALL - SMALL - Telemetry SMALL - Radio
Thread Tools
Old Dec 10, 2013, 04:25 PM
Registered User
Joined Dec 2013
6 Posts
KK 2.0 Flight controller board error

Hello all.

I'm trying to build my first Quadcopter and was trying to do a ECS calibration where i remove the M1 cable to the KK 2.0 card and plug the battery in and then puts the M1 cable back on. Which probably wasn't the smartest way of doing it.

I accidentally moved the M1 cable a bit to the right so it connected the pin 2 and 3 in the cables pin 1 and 2 slot. And there was a little (very little) bit of smoke. Unplugged the battery right away and saw my mistake.

I sat the M1 cable correct and tried to plug the battery back in. However now the board won't go to SAFE screen.

When i plug the power in it just beeps once every second and blink the red Led1. It keeps doing that. on the screen it keeps flashing the firmware version.

It flashes the Safe screen in like an millisecond and then goes back to the firmware version when the battery is plugged into it.

Have I ruined the board?

I have tried to search around for error codes and stuff but can't find any that matches my error.

Was just wondering as the board still seems to try and power up with sound and display. Not sure i'd fried it.

I'm completely a noob in this field so please have patience with me

Hope you can help me fix this, or just help me figur out if the board is history.

Best regards
Crowdedlight is offline Find More Posts by Crowdedlight
Reply With Quote
Sign up now
to remove ads between posts
Old Dec 10, 2013, 04:47 PM
Registered User
I wish it was somewhere over the rainbow
Joined Feb 2011
18 Posts
Smoke is not good, can you get to the main screen on the board. Or are you locked in on that screen. Basically what you did way put power to the signal pin of the board. Can that cause damage, Cant tell you unless you can maneuver through the board screen.
If not, most likely the board fried.

FalconEddie is offline Find More Posts by FalconEddie
Reply With Quote
Old Dec 10, 2013, 04:51 PM
Registered User
Joined Dec 2013
6 Posts
Nope. When i plug the battery in it just keep beeping each second and blinking with the lcd screen only showing the current firmware version :/

So I guess it's fried. As i can't get to the main screen of the board. Can't do anything with it. -_-'

That was expensive to learn not to do that xD

Kind of good it was only an "cheap" kk 2.0 card anyway :P
Crowdedlight is offline Find More Posts by Crowdedlight
Last edited by Crowdedlight; Dec 10, 2013 at 04:58 PM.
Reply With Quote

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion KK Pro Multi-rotor Flight Control Board franko_ Multirotor Electronics 2 Jan 10, 2014 10:38 AM
Sold KK 2.0 Flight Controller Stitch1615 Aircraft - Electric - Multirotor (FS/W) 4 Dec 01, 2013 01:19 PM
Sold KK 2.0 board with 1.6 firmware and buzzer harfordhawk Aircraft - Electric - Multirotor (FS/W) 1 Nov 26, 2013 01:45 PM
Sold New KK 2.0 Flight Controller garben Aircraft - Electric - Multirotor (FS/W) 1 Nov 13, 2013 10:02 PM
Sold KK 2.0 LCD Board Controller Brand NEW Bonestockz06 Aircraft - Electric - Multirotor (FS/W) 1 Feb 06, 2013 09:07 AM