SMALL - SMALL - Telemetry SMALL - Radio
Thread Tools
Old Sep 12, 2014, 12:30 PM
Registered User
Joined Jan 2010
64 Posts
Phantom Vision - Not Receiving GPS or Battery Status Anymore

Everything was working fine and my Phantom is about 5 month old since purchase. Recently my Phantom 2 Vision copter is connecting to the GPS indicator on copter is flashing green during start-up and during flight and receiving video just fine. When the app connects, I see video preview and the status for SD card icon and Wifi Extender, Wifi Signal full and are BLUE, but GPS # and Battery are greyed out. Telemetry showing Distance N/A and Speed N/A. I'm using a recent Droid Maxx phone running Android 4.4.4 RAM 2GB ROM 32 GB.

I've tried..
- Verifying power to camera/wifi connected both stereo plug and power.
- Trying uninstall app and reinstall.
- Tried recent update to app.
rcflyer112 is offline Find More Posts by rcflyer112
Reply With Quote
Sign up now
to remove ads between posts

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Alert deal expired subpixel Hot Online Deals 2 Sep 17, 2014 05:34 AM
For Sale Maytech Carbon Fiber Props for Phantom 2, Phantom Vision or Phantom Vision 2+ klautzsch Aircraft - Electric - Multirotor (FS/W) 3 Jun 02, 2014 09:33 PM
Help! DJI Phantom or Phantom vision rcpilot_971 Multirotor Talk 16 Apr 23, 2014 05:44 AM
Found Found for a phantom V1.1.1 or phantom 2 not vision anotherdebt Aircraft - Electric - Multirotor (FS/W) 1 Jan 23, 2014 12:33 PM
Discussion Phantom 2/Vision: Gimball or iPhone downlink but not both ? Al P Multirotor Talk 0 Jan 22, 2014 05:32 PM