HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Apr 13, 2012, 06:43 PM
Registered User
Joined Jul 2011
13 Posts
Discussion
Turnigy 9x v2 & stk500v2 (SFAR Multitool)

I come back with a topic I've tried to solve a while back. So, to start:

================================================== ===============================
Started AVRDUDE
E:/Program Files (x86)/eePe/avrdude.exe -c stk500v2 -p m64 -B 100 -v -P com2 -U eeprom:r:C:/Users/Sandman/AppData/Local/Temp/temp.hex:i
================================================== ===============================

avrdude.exe: Version 5.10, compiled on Jan 19 2010 at 10:45:23
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2009 Joerg Wunsch

System wide configuration file is "E:\Program Files (x86)\eePe\avrdude.conf"

Using Port : com2
Using Programmer : stk500v2
Setting bit clk period : 100.0
AVR Part : ATMEGA64
Chip Erase delay : 9000 us
PAGEL : PD7
BS2 : PA0
RESET disposition : dedicated
RETRY pulse : SCK
serial program mode : yes
parallel program mode : yes
Timeout : 200
StabDelay : 100
CmdexeDelay : 25
SyncLoops : 32
ByteDelay : 0
PollIndex : 3
PollValue : 0x53
Memory Detail :

Block Poll Page Polled
Memory Type Mode Delay Size Indx Paged Size Size #Pages MinW MaxW ReadBack
----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
eeprom 4 20 64 0 no 2048 8 0 9000 9000 0xff 0xff
flash 33 6 128 0 yes 65536 256 256 4500 4500 0xff 0xff
lfuse 0 0 0 0 no 1 0 0 9000 9000 0x00 0x00
hfuse 0 0 0 0 no 1 0 0 9000 9000 0x00 0x00
efuse 0 0 0 0 no 1 0 0 9000 9000 0x00 0x00
lock 0 0 0 0 no 1 0 0 9000 9000 0x00 0x00
calibration 0 0 0 0 no 4 0 0 0 0 0x00 0x00
signature 0 0 0 0 no 3 0 0 0 0 0x00 0x00

Programmer Type : STK500V2
Description : Atmel STK500 Version 2.x firmware
Programmer Model: STK500
Hardware Version: 2
Firmware Version Master : 2.10
Topcard : Unknown
Vtarget : 4.9 V
SCK period : 82.5 us
Varef : 0.0 V
Oscillator : Off

avrdude.exe: stk500v2_command(): command failed
avrdude.exe: stk500v2_command(): unknown status 0xc9
avrdude.exe: stk500v2_program_enable(): cannot get connection status
avrdude.exe: initialization failed, rc=-1
Double check connections and try again, or use -F to override
this check.


avrdude.exe done. Thank you.


================================================== ===============================
AVRDUDE done - exit code 1
================================================== ===============================

And this is what I keep getting.

I have a windows 7 x64, everything else is as per topic.

I've soldered (about 3 times already) a connector to the board. The connections are correct and working (checked for impendance from each atmega pin to the connector pin).

I've tried:
  • powering the board through the programmer (5V) and through a lipo.
  • -B 100
  • testing the programmer on other IC (attiny25-20PU, seemed to read the signature fine (empty, at the moment))
  • desoldering the capacitor above the RST solder point
  • reading with different switches on (ail d/r, thr cut) - some success here earlier. Since then I've resoldered the connectors and been so far unable to replicate this 'success'. Right now, when I try to repeat it, I get the 0xc9 and after that a switch error on t9xv2. Anyway, to be specific, this "success" looked like this: ================================================== =============================== Started AVRDUDE C:/Program Files/eePe/avrdude.exe -c stk500v2 -p m64 -B 200 -P com1 -U eeprom:r:C:/Users/ONEIRO~1/AppData/Local/Temp/temp.hex:i ================================================== =============================== avrdude.exe: AVR device initialized and ready to accept instructions Reading | ################################################## | 100% 0.08s avrdude.exe: Device signature = 0x000000 avrdude.exe: Yikes! Invalid device signature. Double check connections and try again, or use -F to override this check. avrdude.exe done. Thank you. ================================================== =============================== AVRDUDE done - exit code 1 ================================================== ===============================

So far, I've been unable to pinpoint the problem. I'm starting a separate thread, because the conversation around here died. If You've got any ideas, please share them. Thanks!
xazzaxas is offline Find More Posts by xazzaxas
Reply With Quote
Sign up now
to remove ads between posts
Old Apr 15, 2012, 03:39 PM
Registered User
Joined Jul 2011
13 Posts
just a bump. Anybody?
xazzaxas is offline Find More Posts by xazzaxas
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Benefits of buying FlySky TH9x (v2) over Turnigy 9x (v2) wwfisher Radios 71 Nov 06, 2014 09:02 PM
Discussion Turnigy 9x v2 mode 2 trouble with throttle and rudder Huginn81 Beginner Training Area (Aircraft-Electric) 1 Mar 24, 2012 10:19 AM
Sold Turnigy 9X V2 transmitter w backlight mod, Corona 2.4 module and 4 Corona receivers jgpncll Aircraft - General - Radio Equipment (FS/W) 3 Mar 20, 2012 08:01 AM
Sold New Turnigy 9x v2 board ER9x installed TyCarp Aircraft - General - Radio Equipment (FS/W) 2 Feb 28, 2012 09:42 AM
Wanted Turnigy 9x receivers v2 (8ch) simplefly Aircraft - General - Radio Equipment (FS/W) 2 Feb 26, 2012 05:27 PM