SMALL - espritmodel.com SMALL - Telemetry SMALL - Radio
Reply
Thread Tools
Old Nov 13, 2010, 09:55 PM
Registered User
St Louis, MO USA
Joined Apr 2006
151 Posts
Discussion
Problems with Cellpro 10 charging 4S

The CP10s software showed that there was a new version of firmware, v2.30. I loaded it on one of my 10s chargers and proceeded to try to charge a 4S pack. This was the first time ever for me charging a 4S pack, so I followed the manual closely. I could not get it to work. I kept getting a cell count error. I'm using balance connector (with 6 pin to 5 pin adapter) and discharge cables (single pack so the outside banana plugs).

In a little bit of desperation, I try my other 10s that still had the v2.29 firmware and it works first time!

Unless there is something different that needs to be done with the v2.30 firmware, it seems like there may be a bug in the v 2.30 firmware.

Any help is appreciated.

Ed
rc404 is offline Find More Posts by rc404
Reply With Quote
Sign up now
to remove ads between posts
Old Nov 14, 2010, 01:57 AM
President, FMA, Inc.
Tim Marks's Avatar
Joined Mar 2008
1,059 Posts
Quote:
Originally Posted by rc404 View Post
The CP10s software showed that there was a new version of firmware, v2.30. I loaded it on one of my 10s chargers and proceeded to try to charge a 4S pack. This was the first time ever for me charging a 4S pack, so I followed the manual closely. I could not get it to work. I kept getting a cell count error. I'm using balance connector (with 6 pin to 5 pin adapter) and discharge cables (single pack so the outside banana plugs).

In a little bit of desperation, I try my other 10s that still had the v2.29 firmware and it works first time!

Unless there is something different that needs to be done with the v2.30 firmware, it seems like there may be a bug in the v 2.30 firmware.

Any help is appreciated.

Ed
Hi:

Sorry to hear about your troubles. Here are some things to check:

1) First, I doubt that it is the firmware update that's causing the error.

2) Have you tried using the same adapters that you used with the other charger successfully running v2.29 firmware on the v2.30 firmware charger? Often times, a cell count error message is due to a problem with the wiring between the battery pack and the charger itself; either the balance connector on the pack or the adapters.

3) You can always revert back to the older firmware and try again. If you go back to v2.28 and you are successful, please report back to me.

Otherwise, you can contact Howard Matos during business hours next week. Email him at howard@fmadirect.com or phone 301-668-4280 for more assistance.

Tim Marks
Tim Marks is offline Find More Posts by Tim Marks
Reply With Quote
Old Nov 14, 2010, 09:34 AM
Registered User
St Louis, MO USA
Joined Apr 2006
151 Posts
I charged 2 different packs. One successfully charged on the second charger with v2.29. The other pack charged on the first charger after I changed it from v2.30 back to v2.29. No change in the wiring or adapters. Both chargers use independent adapters. The only difference I can see was v2.30 vs v2.29. Both packs are well balanced with consistent IR's.

Everything works fine with v2.29. If I get some time, I'll go back to v2.30 and see if I can reproduce the problem.
rc404 is offline Find More Posts by rc404
Reply With Quote
Old Nov 20, 2010, 09:52 AM
Registered User
St Louis, MO USA
Joined Apr 2006
151 Posts
All,

I finally got some time to get back to this. Tim was correct, the problem was not the firmware as I originally thought. After quite a bit of fooling around, I'm pretty sure I traced the problem to an intermittent balance adapter.

Whatever the problem really is, I'm pretty sure I confirmed it is not the firmware version.

Sorry for the confusion.

Ed
rc404 is offline Find More Posts by rc404
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Anyone having problems with FMA's Cellpro 4S Charger? mondo1948 Batteries and Chargers 17 Jul 30, 2011 04:45 PM
Sold FMA Cellpro 4S racerxky Aircraft - Electric - Batteries & Chargers (FS/W) 1 Nov 11, 2010 06:19 PM
Discussion First time charging 3s lipo with new cellpro 4s QinMD Batteries and Chargers 6 Jul 12, 2008 11:19 PM
Discussion Cellpro 4s or Cellpro 10s for charging multiple packs?? windisevil!! Batteries and Chargers 16 Mar 25, 2008 03:57 PM
Discussion Charging in parallel with the Cellpro 4S possible? JT_Redmist Batteries and Chargers 4 May 25, 2007 04:45 PM