HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Mar 17, 2014, 03:57 AM
Registered User
Rpinto's Avatar
Almada - Portugal
Joined Oct 2004
100 Posts
Discussion
H4 Charger - Problem

I bought the H4 because I needed a good charger, unfortunately Iím getting some kind of strange behavior when charging, sometimes the charge stops at 80% of the capacity, or when the battery is half charged it stops after 5 minutes. My guess is that thereís a software bug, it seems that the charger mixes the charge mode with the storage mode. My friendís H4 charger acts the same way, is there any kind of explanation for this?

Thanks in advance.
Rpinto is offline Find More Posts by Rpinto
Reply With Quote
Sign up now
to remove ads between posts
Old Mar 17, 2014, 02:15 PM
Registered User
Joined Aug 2002
5,811 Posts
Quote:
Originally Posted by Rpinto View Post
I bought the H4 because I needed a good charger, unfortunately Iím getting some kind of strange behavior when charging,
sometimes the charge stops at 80% of the capacity, or when the battery is half charged it stops after 5 minutes.
My guess is that thereís a software bug, it seems that the charger mixes the charge mode with the storage mode.
My friendís H4 charger acts the same way, is there any kind of explanation for this?
Thanks in advance.
Standard behaviour for cheap or dying battery packs and of course the 80% rule kicks in especially if NiMH/NiCD chemistry.
. Cycler - FAQ , especially Hobbico Accu adjustment
refer sub section:
"Battery Care, Performance & DIY Battery Packs." below
"Radio Systems, Accessories, Alterations and FAQ" at
Alan's Hobby, Model & RC FAQ Web Links

Alan T.
A.T. is offline Find More Posts by A.T.
Reply With Quote
Old Mar 17, 2014, 03:03 PM
Registered User
Rpinto's Avatar
Almada - Portugal
Joined Oct 2004
100 Posts
Thank you Alan for your help. I'm using LIPO batteries, they are not the cheap or the oldest that I have, I'm not using NiMH/NiCD those are history.

I have also a Robbe and a Multiplex chargers and this behavior doesn't happen, the same batteries, the same charging method... even on an X4 this problem doesn't happen.

Please talk to the hitec technicians I'm sure that I'm not the only one to have the same problem. I just want to contribute to a solution, don't blame the batteries please. The H4 is not a cheap charger.

Thanks again.
Rpinto is offline Find More Posts by Rpinto
Reply With Quote
Old Mar 17, 2014, 04:44 PM
Registered User
Joined Aug 2002
5,811 Posts
Quote:
Originally Posted by Rpinto View Post
Thank you Alan for your help. I'm using LIPO batteries, they are not the cheap or the oldest that I have, I'm not using NiMH/NiCD those are history.
I have also a Robbe and a Multiplex chargers and this behavior doesn't happen, the same batteries, the same charging method... even on an X4 this problem doesn't happen.
Please talk to the hitec technicians I'm sure that I'm not the only one to have the same problem. I just want to contribute to a solution, don't blame the batteries please. The H4 is not a cheap charger.
Thanks again.
A faster response will be obtained by email/phone service direct:
Hitec Warranty & Service - homepage.
Note: Hitec USA only services North/South America and Canada.
"Hitec USA customer service department is available Monday through Friday*
from 7am- 4:30 pm Pacific time. Reach us at 858.748.8440 or
service@hitecrcd.com any time you have a question"
ē If you are from a country that is outside North and South America, please contact the
Hitec distributor in your country for service.

Alan T.
Alan's Hobby, Model & RC FAQ Web Links
A.T. is offline Find More Posts by A.T.
Reply With Quote
Old Mar 21, 2014, 01:05 PM
stvinvegas's Avatar
United States, NV, Las Vegas
Joined Dec 2006
505 Posts
I just started using the H4 yesterday. Mine went to 94% and then I charged them again and it went into balance mode. On the older X4 you could choose balance mode. I have not seen this option (yet) on the H4, but as I said when I charged the second time in said balance mode and I got a higher percentange and 4.20 out of all of the cells.
stvinvegas is offline Find More Posts by stvinvegas
Site Sponsor
Reply With Quote
Old Apr 12, 2014, 10:46 AM
Registered User
knight2hug's Avatar
United States, CA, Anaheim
Joined Oct 2011
73 Posts
Repeated Problems With Hitech H4

My Hitech Smart Charger H4 had a problem new out of the box. I use quality Eflite batteries and fly with a Jeti receiver with voltage telemetry so I always land with the charge between 20-25% capacity.

The rear ports of my H4, A and C, would always stop charging at 81%. The front ports, B and D, always went to 99%. Hitech tech support gave me a RMA to return it to them. When I got it back a note on the invoice said they calbrated the unit.

It has worked fine now on all ports for the last two months, but recently it has started doing it again but worst. All 4 ports are stopping at any charge capacity. Stopping at 35%, stopping at 56%, etc.

Once again Hitech tech support gave me a RMA number for returning. It this happens again after this second repair I'll get a different brand charger.

Anyone else having this problem?
knight2hug is offline Find More Posts by knight2hug
Reply With Quote
Old Apr 15, 2014, 03:34 AM
Registered User
Rpinto's Avatar
Almada - Portugal
Joined Oct 2004
100 Posts
My H4 has the same problem on A and B port. I hope Hitec looks into it asap.
Rpinto is offline Find More Posts by Rpinto
Reply With Quote
Old Jun 11, 2014, 09:45 AM
Registered User
United States, WI, West Bend
Joined Jan 2014
53 Posts
I got my Hitec H4 charger and had the same problem as many users - it wouldn't charge to full capacity or the voltage reading would be off.

I contacted Hitec support who said it needed to be recalibrated. After sending it in, they had to wait for a new firmware release from Hitec for this unit.

It was flashed with the newest firmware, 1.03, and recalibrated. Now the charger works fantastic. Charges batteries extremely well and is spot on with voltage.
M3Man03 is offline Find More Posts by M3Man03
Reply With Quote
Old Jun 17, 2014, 03:59 PM
Registered User
Rpinto's Avatar
Almada - Portugal
Joined Oct 2004
100 Posts
Nice to hear that
Rpinto is offline Find More Posts by Rpinto
Reply With Quote
Old Jun 20, 2014, 06:27 AM
Registered User
marcin.gala's Avatar
Joined Jun 2010
420 Posts
possible to update H4 with 1.03 at home ?? this is my second charger and shows crap instead of real numbers !!
marcin.gala is offline Find More Posts by marcin.gala
Reply With Quote
Old Jun 20, 2014, 02:52 PM
Registered User
Joined Aug 2002
5,811 Posts
Quote:
Originally Posted by marcin.gala View Post
possible to update H4 with 1.03 at home ??
this is my second charger and shows crap instead of real numbers !!
Yes, copy of manual attached or download from:

.H4 PC Update Program Manual

Alan T.
Alan's Hobby, Model & RC FAQ Web Links
A.T. is offline Find More Posts by A.T.
Reply With Quote
Old Jun 27, 2014, 08:03 AM
Registered User
United States, WI, West Bend
Joined Jan 2014
53 Posts
That will update the firmware, but what is needed is called "Calibration" from what the H4 Support told me.

They said the only way to do this is to send it in.
M3Man03 is offline Find More Posts by M3Man03
Reply With Quote
Old Jul 01, 2014, 05:19 AM
Registered User
marcin.gala's Avatar
Joined Jun 2010
420 Posts
ok give up with that c...p charger...I got another one and was same s...t straight from box..finish charging at 80% 87% 90% whatever ..Check with multimeter and voltage was different ,cells ,all up etc:.

so I but turnigy reaktors instead £38 chargers ....well I must admit H4 was mistake for that price ,lost time and nerves.
Now I'm happy reaktor user !!!
marcin.gala is offline Find More Posts by marcin.gala
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
New Product BRAND NEW! Hitec H4 Smart Charger in stock at ServoCity ServoCity ServoCity.com 72 Jun 20, 2014 06:55 AM
Discussion Which Charger Hitec H4 or Icharger 308? plpflyboy Batteries and Chargers 11 Feb 18, 2014 09:00 PM
Discussion Hitec H4 Charger Tengler Batteries and Chargers 2 Feb 11, 2014 11:23 PM
For Sale HK H4 quadcopter Flywithmerc Aircraft - Electric - Multirotor (FS/W) 1 Dec 03, 2013 01:38 PM
Discussion hitec H4 opinions? plpflyboy Batteries and Chargers 1 Nov 01, 2013 08:19 AM