HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Jun 27, 2013, 12:56 PM
Registered User
E-Challenged's Avatar
United States, CA, Garden Grove
Joined Oct 2000
12,197 Posts
Discussion
My Cellpro 10S Has Become Unstable

My Cellpro 10S is 3-4 years old and has become unstable with alarms and cryptic random safety codes and error messages that eventually clear by disconnecting and reconnecting balancing adapters, battery packs, crossing fingers and toes, etc., Example Channel 1 No add up, Channel 2 No add up, Safety code 70, etc. It is becoming warm and humid in my garage, is that a possible factor?

I suspect that it is the tiny female connector sockets and male pins on the charger node and balance charge adapters and battery packs have less than perfect continuity. I tried Isopropyl alcohol on pins and sockets, connecting and disconnecting, etc. No real improvement in stability. Don't now how to clean tiny connector sockets effectively other than disconnecting and re-connecting.

Is it time to buy new balance/charge adapters or send the otherwise working charger in for repairs.? It has V2.26 software update installed. I have not opened it up and removed diodes, the fuse between center banana plugs is good per my ohmeter.

PS: I updated software to V2.30 after finding out that V2.26 was not last update for my original 10S charger. Finally remembered that charger needs power supply to download software, etc.(LOL)
E-Challenged is offline Find More Posts by E-Challenged
Last edited by E-Challenged; Jun 27, 2013 at 03:07 PM.
Reply With Quote
Sign up now
to remove ads between posts
Old Jun 28, 2013, 01:29 PM
AR-15 BRD!
Howard Matos's Avatar
Frederick, MD
Joined May 2002
1,043 Posts
Quote:
Originally Posted by E-Challenged View Post
My Cellpro 10S is 3-4 years old and has become unstable with alarms and cryptic random safety codes and error messages that eventually clear by disconnecting and reconnecting balancing adapters, battery packs, crossing fingers and toes, etc., Example Channel 1 No add up, Channel 2 No add up, Safety code 70, etc. It is becoming warm and humid in my garage, is that a possible factor?

I suspect that it is the tiny female connector sockets and male pins on the charger node and balance charge adapters and battery packs have less than perfect continuity. I tried Isopropyl alcohol on pins and sockets, connecting and disconnecting, etc. No real improvement in stability. Don't now how to clean tiny connector sockets effectively other than disconnecting and re-connecting.

Is it time to buy new balance/charge adapters or send the otherwise working charger in for repairs.? It has V2.26 software update installed. I have not opened it up and removed diodes, the fuse between center banana plugs is good per my ohmeter.

PS: I updated software to V2.30 after finding out that V2.26 was not last update for my original 10S charger. Finally remembered that charger needs power supply to download software, etc.(LOL)
Hi,

The error 70 indicates series switch closure timeout. You could have a coule of blown diodes causing this, D15 & D16. Since the charger is no longer under warranty, I would check these diodes and remove them. No need to replace them as they are now DNI. Let me know how you make out and if you, you can send the charger in for service. Thanks.
Howard Matos is offline Find More Posts by Howard Matos
Reply With Quote
Old Jun 29, 2013, 07:05 PM
Registered User
E-Challenged's Avatar
United States, CA, Garden Grove
Joined Oct 2000
12,197 Posts
Where Do I Send It for Service

I opened the charger up, slid circuit board out of heat sink case and saw what looked like tiny diodes but could not read the tiny markings. I decided that the components and markings are too small with my eyesight to attempt to remove them.
Where do I send charger for removal of offending diodes and checkout to resolve nuisance errors and warnings? Should I send balance charge adapters too? Will there be an $80.00 flat fee for service?
E-Challenged is offline Find More Posts by E-Challenged
Reply With Quote
Old Jul 02, 2013, 09:28 AM
AR-15 BRD!
Howard Matos's Avatar
Frederick, MD
Joined May 2002
1,043 Posts
Quote:
Originally Posted by E-Challenged View Post
I opened the charger up, slid circuit board out of heat sink case and saw what looked like tiny diodes but could not read the tiny markings. I decided that the components and markings are too small with my eyesight to attempt to remove them.
Where do I send charger for removal of offending diodes and checkout to resolve nuisance errors and warnings? Should I send balance charge adapters too? Will there be an $80.00 flat fee for service?
Hi, Please send the unit to 3520 Sugarloaf Parkway, Suite F-03-121, Urbana MD, 21704. There is a flat $60 repair fee which includes the diagnosis, parts, labor, and return shipping as long as you live inside the US. The fee does not cover the microprocessor, which if damaged, is not cost effective to replace. If this is the case, we do not charge the repair fee. Please add a note as to the problem along with a form of payment to expedite the process. Thanks.
Howard Matos is offline Find More Posts by Howard Matos
Reply With Quote
Old Jul 15, 2013, 12:18 PM
Registered User
DonA's Avatar
United States, CA, Placerville
Joined Feb 2006
658 Posts
Quote:
Originally Posted by Howard Matos View Post
Hi,

The error 70 indicates series switch closure timeout. You could have a coule of blown diodes causing this, D15 & D16. Since the charger is no longer under warranty, I would check these diodes and remove them. No need to replace them as they are now DNI. Let me know how you make out and if you, you can send the charger in for service. Thanks.
A friend has a 10S with the same issues. I located D16 but don't see D15. Where is it located?

thanks
Don
DonA is online now Find More Posts by DonA
Reply With Quote
Old Jul 19, 2013, 09:34 PM
Registered User
E-Challenged's Avatar
United States, CA, Garden Grove
Joined Oct 2000
12,197 Posts
Finally sent my 10S in for service, two days ago, hope to get it back soon, my old Hobbico Elite Dual charger can only do up to 3S lipos.
E-Challenged is offline Find More Posts by E-Challenged
Reply With Quote
Old Aug 09, 2013, 10:54 AM
Registered User
E-Challenged's Avatar
United States, CA, Garden Grove
Joined Oct 2000
12,197 Posts
My 10S has been recalibrated and tested charging two test packs and is on its way back.FMA advised that my two balance adapters had worn 3S pack connectors, so I ordered new ones, also on their way. Hopefully charger will be good as new without nuisance error messages and no need for fiddling.

Satisfied Customer: Got charger and new balance adapters. Charger and adapters are working well together, very stable. I think that my old worn balance adapters were largely to blame for error messages, etc.
E-Challenged is offline Find More Posts by E-Challenged
Last edited by E-Challenged; Aug 26, 2013 at 01:15 AM.
Reply With Quote
Old Aug 19, 2013, 10:01 AM
AR-15 BRD!
Howard Matos's Avatar
Frederick, MD
Joined May 2002
1,043 Posts
Quote:
Originally Posted by DonA View Post
A friend has a 10S with the same issues. I located D16 but don't see D15. Where is it located?

thanks
Don
Hi,

D15 is located just below the big cap (C25) and just below the fan.
Howard Matos is offline Find More Posts by Howard Matos
Reply With Quote
Old Aug 26, 2013, 09:21 PM
Registered User
DonA's Avatar
United States, CA, Placerville
Joined Feb 2006
658 Posts
Thanks Howard
Don
DonA is online now Find More Posts by DonA
Reply With Quote
Old Nov 18, 2013, 06:55 PM
Registered User
bdp3822's Avatar
Honolulu, HI
Joined Jun 2007
175 Posts
I am looking for D16. Where is that one?

Thanks,
Bryon

Quote:
Originally Posted by DonA View Post
A friend has a 10S with the same issues. I located D16 but don't see D15. Where is it located?

thanks
Don
bdp3822 is offline Find More Posts by bdp3822
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion My Cellpro 10S Charger Is Losing It's Mind. E-Challenged Batteries and Chargers 3 Jun 27, 2013 12:27 PM
Discussion Once Effective, The Tea Party Has Become Toxic Broken Wings Life, The Universe, and Politics 31 Apr 07, 2013 08:44 PM
Sold Cellpro 10s pogoods Aircraft - Electric - Helis (FS/W) 0 Mar 29, 2013 01:39 PM
Discussion CellPro 10S Unstable Power and/or <10V DonA FMA Direct 12 Oct 17, 2010 07:45 PM
Has anyone else noticed their receiver becomes unstable in the cold ? Darn Servo ! Parkflyers 6 Feb 14, 2002 06:53 PM