HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Mar 27, 2012, 08:50 PM
Jim in Santee
jshelton's Avatar
United States, CA, Santee
Joined Oct 2001
194 Posts
Discussion
Burnt-out throttle channel in Optima-6 receiver

I have an Omega 1.8M electric sailplane. It has about about 65 flights on it with an Optima 6 receiver. No problems at all, but I put in a new motor - Hyperion 2213-14 - and it wouldn't run - just shake. The servos still moved. I replaced the speed control - same behavior.

Then the receiver stopped coming on. I then jiggled the wire from the ESC to Ch3 and the receiver would flash on and off. And yes, the connector was fully inserted into the slot.

I then tested the same ESC and motor with a new Optima 6 receiver - binding to the same model memory in my Aurora - and everything works fine.

My conclusion is that the throttle/BEC channel in the other receiver burned-out or for some other reason malfunctioned.

Does that sound right? Is this common? Is there something that could have caused this such as using a servo extension between the ESC and the receiver?

Jim
jshelton is offline Find More Posts by jshelton
Reply With Quote
Sign up now
to remove ads between posts
Old Mar 27, 2012, 10:35 PM
Registered User
Joined Aug 2002
5,799 Posts
Quote:
Originally Posted by jshelton View Post
I have an Omega 1.8M electric sailplane. It has about about 65 flights on it with an Optima 6 receiver. No problems at all, but I put in a new motor - Hyperion 2213-14 - and it wouldn't run - just shake. The servos still moved. I replaced the speed control - same behavior. Then the receiver stopped coming on. I then jiggled the wire from the ESC to Ch3 and the receiver would flash on and off. And yes, the connector was fully inserted into the slot.I then tested the same ESC and motor with a new Optima 6 receiver - binding to the same model memory in my Aurora - and everything works fine.My conclusion is that the throttle/BEC channel in the other receiver burned-out or for some other reason malfunctioned. Does that sound right? Is this common? Is there something that could have caused this such as using a servo extension between the ESC and the receiver? Jim
Quite possible that one of the pins has been pushed and separated from the board,
not all plugs on ESC have the same internal dimensions
After Market Accessories - Leads, Modules & Switches - Cautions. - refer to picture attached

Please refer direct to:
Hitec Warranty & Service
Note: Hitec USA only services North/South America and Canada.
All other countries see appropriate distributor for service.
• If you are from a country that is outside North and South America, please contact the
Hitec distributor in your country for service.


Alan T.
Alan's Hobby, Model & RC FAQ Web Links
A.T. is offline Find More Posts by A.T.
Reply With Quote
Old Mar 28, 2012, 01:43 PM
Registered User
union township clermont county Ohio, United States
Joined Jan 2001
158 Posts
jshelton, Had a simular problem on an Optima 6. No signal on channel 1. Sent it to Hitec for repair. Turned out to be a cold solder joint on the channel I pins. George
little nail is offline Find More Posts by little nail
Reply With Quote
Old Mar 29, 2012, 04:51 AM
Jim in Santee
jshelton's Avatar
United States, CA, Santee
Joined Oct 2001
194 Posts
Thanks Alan, George

I'm thinking you're right - that it's probably not a burnt-out channel but a damaged or defective connection. I'll see about sending it in to Hitec for repair.
jshelton is offline Find More Posts by jshelton
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help! Burnt out Paraboard, WHAT HAPPENED. The fuse didn't burn out, the board was smoking jasper7821 Batteries and Chargers 61 Apr 23, 2012 02:18 PM
Discussion Futaba 6J channel 6 = throttle as well as channel 3 jazznuts Multirotor Talk 3 Mar 10, 2012 06:25 PM
Discussion Battery Telemlery in the Aurora 9 with Optima 6 receiver Timewarp Radios 8 Dec 26, 2011 06:08 PM
Sold Hitec Optima 6 and Optima 7 Receivers daskip87 Aircraft - General - Radio Equipment (FS/W) 3 Oct 31, 2011 02:16 PM
Sold Hitec Aurora 9 with 9 channel Optima and 6 channel Optima reciever stangman67 Aircraft - General - Radio Equipment (FS/W) 1 Feb 22, 2011 03:19 PM