HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Dec 02, 2012, 11:51 PM
Registered User
Joined Oct 2011
3 Posts
Help!
Blade B450/ZYX Servo Travel Issues

Hi All,Went through the ZYX conversion last week, using the B450x head conversion since I have a 450x as well and want to keep spare parts to a minimum. The conversion went well, followed step by step through setup videos and all was working well when it was completed. Weather was crap though, so no maiden. Tomorrow is supposed to be better, so I thought I would double check my settings tonight.
My cyclic servo travel is a fraction of what it should be. Instead of 6.5 - 7 degrees of elevator and aileron deflection, I am getting maybe 1.5 - 2. Servos move in the correct directions, just not very much! Rudder servo is working normally. Using John_nz software for programming.

Swash travel limits adjusted from 20-120 with no effect.
RC deadband limits: Main - 40 Tail - 40
Servo trims are the same as before and everything is good at midstick, getting 10 degrees +/- on pitch range.
Dx7s transmitter settings are good, servo travel at least 100%, some slightly higher due to adjustments made at monitor screen to acheive 100% on limits. Small subtrim adjustments to achieve 0 on monitor screen.
DR/Expo 100/40 on aile and elevator100/25 on rudder
Used a new model on setup, no mixing.
Gyro @ 40%
(All settings used on switch positions 1 & 2).
Re-seated all connections at ZYX and receiver.
Battery used during testing fully charged.
Rebound receiver multiple times and to two different receivers (see below) with same results.
I have even pulled out my old dx6i and done a quick setup from scratch with the same results. Stock receiver and ESC for B450. Bad ZYX? Bad receiver? Something I am missing? 

Thanks!

Shawn
Shawndiver is offline Find More Posts by Shawndiver
Reply With Quote
Sign up now
to remove ads between posts
Old Dec 03, 2012, 03:54 PM
Registered User
Dr.M's Avatar
United States, WA, Issaquah
Joined May 2011
1,522 Posts
Are your servos trying to move and binding, or they just have very limited throw?
Dr.M is offline Find More Posts by Dr.M
Reply With Quote
Old Dec 03, 2012, 08:14 PM
Registered User
Joined Oct 2011
3 Posts
No binding, only a few degrees of movement with cyclic input to aile or elevator. Servos would all move normally for pitch inputs and idle up.

Final solution was to do a factory default reset using the radio and flashes on the gyro. Resetting data values to default in the software did nothing to clear the problem. Once I reset the ZYX, servos returned to full range movement. Good news was I simply had to reload my .ini file and all my settings were restored, and servo movement is normal again. Should be ready to go! Oh, yeah, gotta work tomorrow...
Shawndiver is offline Find More Posts by Shawndiver
Reply With Quote
Old Dec 06, 2012, 04:38 PM
Registered User
Dr.M's Avatar
United States, WA, Issaquah
Joined May 2011
1,522 Posts
Glad to see you've worked it out.

I hope you've been reading on the ZYX and have taken the necessary precautions for the maiden. In particular, setting your cyclic gains to 25 to prevent the possibility of violent oscillations. Make sure you check compensation directions and stick input response on all axes before every flight. Good luck!
Dr.M is offline Find More Posts by Dr.M
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion New Tarot ZYX/ZYX-S/ZYX-S2 Flybarless System beenflying Mini Helis 11898 Jul 23, 2014 10:51 PM
Discussion Blade MSR - how to center servo travel? dedfish Micro Helis 0 Oct 05, 2012 08:27 PM
Sold Blade B450 3D New Parts BattleDude Aircraft - Electric - Helis (FS/W) 0 Sep 25, 2012 12:09 PM
Sold ***SOLD***Blade/E-Flite B450 3D CF Main Blades***SOLD*** acftmx Aircraft - Electric - Helis (FS/W) 1 Jul 22, 2012 04:45 PM