Thread Tools
Old Jul 17, 2016, 05:21 PM
RcScottie is offline
Find More Posts by RcScottie
Registered User
Joined Jul 2016
2 Posts
Discussion
Hitec Eclipse 7 problems

Hi guys.
I've been out of the rc game for a couple years. I pulled out my Zagi XT twin brushless set up the other day. I charged all my batteries. Found that my TX battery was bad so I made a lead to have one of my plane batteries to power it up and get set up. I powered up TX and then plane. I wasn't getting much of a response so I verified I was on the correct model setting. I went through parameters and still nothing. When I tried changing the throw to reverse still nothing. I have elevens on. I get some movement in 1 elavon when I turn the flap dial. Elavons on ch 1 and 2 throttle on 3. Any help would be appreciated. Spectrum module and receiver on ch 16. Also when I reversed 3 it goes full throttle with no control on stick. Thank you, Scott
RcScottie is offline Find More Posts by RcScottie
Reply With Quote
Sign up now
to remove ads between posts


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Sold Hitec Eclips 7 with the Spectra Module and lipo battery rcrube Aircraft - General - Radio Equipment (FS/W) 1 Mar 03, 2016 09:56 AM
Sold Hitec eclips 7 updat to 2.4 come with hitec 2.4 6ch mrreb Aircraft - General - Radio Equipment (FS/W) 0 Jan 08, 2014 06:08 AM
For Sale HiTec Eclipes 7 Spectra Module (NEW) mikefaith Aircraft - General - Radio Equipment (FS/W) 1 May 29, 2005 08:55 PM
Question Hitec Eclips 7 Radio Question mikefaith Electric Heli Talk 4 Apr 22, 2005 06:11 AM
Hitec Eclipe-7 with Eco-8 curtqn Electric Heli Talk 6 Jan 07, 2003 11:25 PM