HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Sep 19, 2012, 12:59 PM
Registered User
United States, CA, Yosemite Lakes
Joined Jan 2008
687 Posts
Quote:
Originally Posted by nebstress View Post
The default PID's should be OK for a 450 size Quad & it doesn't sound like its the Gains, if it was it would spin up & take off but just oscillate (wobble/shake) while hovering.

A video & maybe a photo as well showing how the Board is actually mounted would help .
You got it. Ill will take some and a vid tonight.
Thanks
scribble007 is offline Find More Posts by scribble007
Reply With Quote
Sign up now
to remove ads between posts
Old Sep 19, 2012, 02:22 PM
NDw
Registered User
Ireland, Limerick, Kilmallock
Joined Aug 2010
2,123 Posts
Quote:
Originally Posted by Quadframes View Post
dont reverse your channels in the mission planner as if you upgrade your software you could forget to redo this and well could crash or worse! reverse the channels on your radio that way they are always done
Thanks. And thanks for the manuals .

So the gps I'm trying needs 3.3 v. Is there any 3.3v pin on the board?
NDw is offline Find More Posts by NDw
Reply With Quote
Old Sep 19, 2012, 05:41 PM
Registered User
KevinBuckley70's Avatar
Oxfordshire, UK
Joined Jul 2001
279 Posts
I finally have bluetooth, GPS etc. running using the latest MPNG on the bench on my Crius AIOP & extender board - after taking the advice I was given at the very start and using a uBEC, rather than trying to power it directly from a 3s LiPo.

It would really help me to know a couple of things before I try to install this on my FlameWheel F450 & try to get airborne:
  • There are many, many parameters it's possible to fiddle with using the Mission Planner. Before making that first flight, is there anything I NEED to fiddle with, apart from configuring the flight modes & the Tx controls if I am using a brand new copy of the latest MPNG (I already did the changes in the APM_Config to set it up for the AIOP)?
  • The USB connector fell off the AIOP for the second time tonight, probably terminally. Can I do everything I need to do to get this flying just using Mission Planner over bluetooth?
  • Is it possible to load new versions of firmware (MPNG) using bluetooth, or will that have to wait until my new board arrives?

I'm not yet familiar with the detailed config of MPNG so knowing what I HAVE to setup, & what I can leave until later, will be really helpful.
KevinBuckley70 is offline Find More Posts by KevinBuckley70
Reply With Quote
Old Sep 19, 2012, 05:54 PM
Registered User
United States, CA, Yosemite Lakes
Joined Jan 2008
687 Posts
Failed flights

Here is the video of my quad failing to fly. In multiwii config on my phone I can see the motor values jumping around wildly even though my throttle is staying the same and I'm not really trying to correct the unwanted movement.

Quad fails to fly (0 min 21 sec)
scribble007 is offline Find More Posts by scribble007
Reply With Quote
Old Sep 19, 2012, 06:13 PM
Registered User
KevinBuckley70's Avatar
Oxfordshire, UK
Joined Jul 2001
279 Posts
Quote:
Originally Posted by scribble007 View Post
Here is the video of my quad failing to fly. In multiwii config on my phone I can see the motor values jumping around wildly even though my throttle is staying the same and I'm not really trying to correct the unwanted movement.

http://www.youtube.com/watch?v=TrpOc0cTx_g&feature=plcp
You don't seem to be using the DJI stock F450 ESC's. Any reason why not?
KevinBuckley70 is offline Find More Posts by KevinBuckley70
Reply With Quote
Old Sep 19, 2012, 06:34 PM
Registered User
United States, CA, Yosemite Lakes
Joined Jan 2008
687 Posts
It was the RC timer kit. Not DJI.
So, Never had them. That's why
scribble007 is offline Find More Posts by scribble007
Reply With Quote
Old Sep 20, 2012, 02:22 AM
NDw
Registered User
Ireland, Limerick, Kilmallock
Joined Aug 2010
2,123 Posts
Quote:
Originally Posted by KevinBuckley70 View Post
I finally have bluetooth, GPS etc. running using the latest MPNG on the bench on my Crius AIOP & extender board - after taking the advice I was given at the very start and using a uBEC, rather than trying to power it directly from a 3s LiPo.

It would really help me to know a couple of things before I try to install this on my FlameWheel F450 & try to get airborne:
  • There are many, many parameters it's possible to fiddle with using the Mission Planner. Before making that first flight, is there anything I NEED to fiddle with, apart from configuring the flight modes & the Tx controls if I am using a brand new copy of the latest MPNG (I already did the changes in the APM_Config to set it up for the AIOP)?
  • The USB connector fell off the AIOP for the second time tonight, probably terminally. Can I do everything I need to do to get this flying just using Mission Planner over bluetooth?
  • Is it possible to load new versions of firmware (MPNG) using bluetooth, or will that have to wait until my new board arrives?

I'm not yet familiar with the detailed config of MPNG so knowing what I HAVE to setup, & what I can leave until later, will be really helpful.
One thing I noticed is my pitch does need to be reversed in my radio from what it is showing in mission planner. All the other directions are fine.

I think I read earlier in the thread that firmware can't be updated via bluetooth but not 100% about that.
NDw is offline Find More Posts by NDw
Reply With Quote
Old Sep 20, 2012, 02:26 AM
NDw
Registered User
Ireland, Limerick, Kilmallock
Joined Aug 2010
2,123 Posts
Quote:
Originally Posted by scribble007 View Post
Here is the video of my quad failing to fly. In multiwii config on my phone I can see the motor values jumping around wildly even though my throttle is staying the same and I'm not really trying to correct the unwanted movement.

http://www.youtube.com/watch?v=TrpOc0cTx_g&feature=plcp
I'd try just getting it a few feet off the ground and see if it sorts itself out.

I'm using the same frame but nvr tried the multiwii firmware. The megapirate defaults work really well with it.
NDw is offline Find More Posts by NDw
Reply With Quote
Old Sep 20, 2012, 03:14 AM
Registered User
United States, SC, Ridge Spring
Joined May 2012
110 Posts
My board finally arrived and I'm trying to upload MegaPirateNG V2.7 R4. I have set the board and com port, made the changes in Arducopter recommended by quadframes, and I'm now trying to upload to the board. It compiles the sketch, starts uploading, then near the end of the upload, everything just stops and the upload never seems to complete. I have a yellow light on the board, and below that red and green. All are solid with nothing blinking. Any ideas what's going on?

update: now I have timeout errors and the message: timeout communicating with programmer. What am I doing wrong?
Boykintom is offline Find More Posts by Boykintom
Reply With Quote
Old Sep 20, 2012, 03:43 AM
Registered User
janekx's Avatar
Czech Republic, South Moravian Region, Brno
Joined Aug 2012
134 Posts
Did you install lattest drivers from FTDI?
janekx is offline Find More Posts by janekx
Reply With Quote
Old Sep 20, 2012, 03:47 AM
Registered User
United States, SC, Ridge Spring
Joined May 2012
110 Posts
Quote:
Originally Posted by janekx View Post
Did you install lattest drivers from FTDI?
no, what do I need to get? BTW, I'm using usb hookup to communicate with the computer.
Boykintom is offline Find More Posts by Boykintom
Reply With Quote
Old Sep 20, 2012, 03:48 AM
Advanced Monkey
nebstress's Avatar
United Kingdom, England
Joined Nov 2011
1,605 Posts
Quote:
Originally Posted by scribble007 View Post
Here is the video of my quad failing to fly. In multiwii config on my phone I can see the motor values jumping around wildly even though my throttle is staying the same and I'm not really trying to correct the unwanted movement.

http://www.youtube.com/watch?v=TrpOc0cTx_g&feature=plcp
That is very strange, it looks like the throttle is being pumped, as long as all your settings are correct I would double check/re-run the ESC's throttle calibration & try sticking the CRIUS AIOP just on the white foam without the velco, sometimes too much vibration dampening will cause even more problems.
nebstress is offline Find More Posts by nebstress
Reply With Quote
Old Sep 20, 2012, 03:51 AM
Advanced Monkey
nebstress's Avatar
United Kingdom, England
Joined Nov 2011
1,605 Posts
Quote:
Originally Posted by KevinBuckley70 View Post
I finally have bluetooth, GPS etc. running using the latest MPNG on the bench on my Crius AIOP & extender board - after taking the advice I was given at the very start and using a uBEC, rather than trying to power it directly from a 3s LiPo.

It would really help me to know a couple of things before I try to install this on my FlameWheel F450 & try to get airborne:
  • There are many, many parameters it's possible to fiddle with using the Mission Planner. Before making that first flight, is there anything I NEED to fiddle with, apart from configuring the flight modes & the Tx controls if I am using a brand new copy of the latest MPNG (I already did the changes in the APM_Config to set it up for the AIOP)?
  • The USB connector fell off the AIOP for the second time tonight, probably terminally. Can I do everything I need to do to get this flying just using Mission Planner over bluetooth?
  • Is it possible to load new versions of firmware (MPNG) using bluetooth, or will that have to wait until my new board arrives?

I'm not yet familiar with the detailed config of MPNG so knowing what I HAVE to setup, & what I can leave until later, will be really helpful.
I wouldn't fiddle with any of the parameters until after your first flight/testflight, I think you will find that a couple might need lowering then.

You can use Bluetooth to do everything except upload firmware.
nebstress is offline Find More Posts by nebstress
Reply With Quote
Old Sep 20, 2012, 03:52 AM
Registered User
United States
Joined Dec 2010
221 Posts
"USB. connector fell off ....."

I assume you guys know that Crius didn't solder the frame of the connector to the PCB but if you do (with a small solder penci) it's pretty robust. I've had no problems since doing that.

Forgive me if you already knew about that.

Cheers
Wingspinner
wingspinner is offline Find More Posts by wingspinner
Reply With Quote
Old Sep 20, 2012, 03:58 AM
Registered User
United States, SC, Ridge Spring
Joined May 2012
110 Posts
Quote:
Originally Posted by Boykintom View Post
no, what do I need to get? BTW, I'm using usb hookup to communicate with the computer.
OK, figured out the drivers and the upload worked. Now the upper red light is blinking, and the lower red and green are solid. Not sure what this means.
Boykintom is offline Find More Posts by Boykintom
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Mini-HowTo Arduino and HobbyKing Multi-Rotor Control Board V3.0 or KKmulticontroller v5.5 pprioverde Multirotor Talk 30 May 14, 2014 09:52 AM
Discussion New updated Crius Multiwii SE flight controller SGsoar Multirotor Electronics 72 May 15, 2013 08:36 PM
Discussion Jim, any plans for more multi rotor flight controller? chris24g Xtreme Power Systems 12 Jun 25, 2012 08:11 PM
Sold One New, one used ArduPilot 2560 APM1.0 Flight Controlls/autopilots wingspinner FPV Equipment (FS/W) 3 May 28, 2012 12:55 AM
Question Quad Build Using HobbyKing Multi-Rotor Control Board V3.0 (Atmega328 PA) SJackson Multirotor Talk 27 Apr 30, 2012 08:51 PM