SMALL - espritmodel.com SMALL - Telemetry SMALL - Radio
Reply
Thread Tools
Old Mar 27, 2012, 10:30 PM
Registered User
Eugene, Oregon
Joined Apr 2009
1,979 Posts
Quote:
Originally Posted by aeromaniac View Post
Some say the servo's get hot on 2s, and if you read specs they 1s servo's with a max of 4.8v and the turnigy esc's bec puts out 5v, when I checked mine it was putting out with no load 4.95v, to be on the safe side I am putting a 4004 diode in the red rx wire to drop voltage by about .6.
some say, I been lucky never had problem with 5320... in dozens. This plane is so fast, the motor screams coming at you, WOT more than any model I fly. This is the litest fastest for size I've seen, flown. "handles" wind, more-like overpowers wind just an angry mean little flyer this thing! fly it most in crappy overcast windy weather
elvill is offline Find More Posts by elvill
Reply With Quote
Sign up now
to remove ads between posts
Old Mar 28, 2012, 04:41 AM
Glow 😡 no no no
Australia, SA, Evanston Park
Joined Mar 2010
4,799 Posts
Quote:
Originally Posted by elvill View Post
some say, I been lucky never had problem with 5320... in dozens. This plane is so fast, the motor screams coming at you, WOT more than any model I fly. This is the litest fastest for size I've seen, flown. "handles" wind, more-like overpowers wind just an angry mean little flyer this thing! fly it most in crappy overcast windy weather
Well if you read the reviews on the 5320, quite a few mention it getting hot on 5v, anyway each to there own, I prefer to drop the voltage by .6 to give a safety margin.
aeromaniac is offline Find More Posts by aeromaniac
Reply With Quote
Old Mar 28, 2012, 12:02 PM
Registered User
Eugene, Oregon
Joined Apr 2009
1,979 Posts
Quote:
Originally Posted by aeromaniac View Post
Well if you read the reviews on the 5320, quite a few mention it getting hot on 5v, anyway each to there own, I prefer to drop the voltage by .6 to give a safety margin.

thought I had 'jittery servo' on this 420, upon further inspection it was decal rubbing bottom of cs, good to be safe drop voltage - I've been lucky all mine have been flawless this morning I ran 10 straight 2S180 420 WOT servos were cool as ice... chronically flying 420 took dome shot got smashed - last lipo of the morning urrrgggghhhh
elvill is offline Find More Posts by elvill
Reply With Quote
Old Mar 28, 2012, 12:13 PM
Glow 😡 no no no
Australia, SA, Evanston Park
Joined Mar 2010
4,799 Posts
Diode in place so now to move forward and put the rx in for the weekend lol.
aeromaniac is offline Find More Posts by aeromaniac
Reply With Quote
Old Mar 31, 2012, 09:58 PM
Glow 😡 no no no
Australia, SA, Evanston Park
Joined Mar 2010
4,799 Posts
Well tried to maden my 420 with rec CofG, it was uncontrollable, seemed really tail heavy with the lipo pushed back, luckily it arrived well, pulled lipo forward and it sorta flew ok to start but when the speed increased it went horrible again. Got it down without arriving to hard,

Ended up putting as per instructions in manual and she flew well, a tad nose heavy I feel but will try battery further back on next flight.
aeromaniac is offline Find More Posts by aeromaniac
Reply With Quote
Old Apr 01, 2012, 08:49 PM
Southern Pride
everydayflyer's Avatar
Haralson County GA. USA
Joined Oct 2004
34,812 Posts
Maidened mine today, six flights using Turnigy nano tech 25C 2S 180s. Frisbee launches at 2/3 throttle same as I use with my mini Stryker.

I checked RPMs and it is identical to the MinI Stryker which explains why it seems to be the same speed. I was getting 5 min. flights and still landed with cells at 3.7 to 3.8V.

Like mentioned earlier recomended CG is to far back. Recomended is like 9-1/4" and 8-1/2 to 8-3/4 is closer to correct. Elevator is extremely effecient (touchy) I ended up rate set to 25% and it is still a bit to sensitive. Inverted requires very little down but rolls are not axil but look like a mixed ail. and rubber roll.It may need some ail. differential

Charles
everydayflyer is offline Find More Posts by everydayflyer
Last edited by everydayflyer; Apr 02, 2012 at 06:22 AM.
Reply With Quote
Old Apr 02, 2012, 12:08 PM
Southern Pride
everydayflyer's Avatar
Haralson County GA. USA
Joined Oct 2004
34,812 Posts
Two more flights this morning and I left the Lipooy connected for closte to 5 min. following a 6 min. flights and the servos are not heating up. I have not made any modifications to the ESC's Bec output.

Charles
everydayflyer is offline Find More Posts by everydayflyer
Reply With Quote
Old Apr 02, 2012, 02:29 PM
Glow 😡 no no no
Australia, SA, Evanston Park
Joined Mar 2010
4,799 Posts
Hey Charles did you test your voltage under load, maybe the turnigy 6acant hold 5v under load, the reason I'm being so anal is I am converting my park zone micro's over to 2s brushless and the ar6400 is the same deal, while easily replaced, I don't want to until I really need to.
aeromaniac is offline Find More Posts by aeromaniac
Reply With Quote
Old Apr 02, 2012, 03:03 PM
Southern Pride
everydayflyer's Avatar
Haralson County GA. USA
Joined Oct 2004
34,812 Posts
Nope I just purchased the Rad jet 420 plus a reciver, cut the JST connector off and replaced with a E Flite 2S UMX type connector as I have many LiPoys for them and flew it. I was unaware of the servo heating issue until I read it here yesterday so I did a test at the field this morning. LiPolys was connected for approx. 13 minutes total (before during and after one flight) and I could not feel any heating of either servo.

Charles
everydayflyer is offline Find More Posts by everydayflyer
Reply With Quote
Old Apr 02, 2012, 05:26 PM
Glow 😡 no no no
Australia, SA, Evanston Park
Joined Mar 2010
4,799 Posts
If you do get around to checking please report back, for now im going with the diode, its a little bit of work and the diode is far cheaper than replacing burnt out bits lol, which from your report is unlikely to happen, I got 8 diodes for $1 mighty aussie dollar.
aeromaniac is offline Find More Posts by aeromaniac
Reply With Quote
Old Apr 05, 2012, 05:22 PM
high flyer
stalyoni's Avatar
Sydney, Australia
Joined May 2008
3,183 Posts
can someone post a picture of there correct CG lipo placement inside this bird please. I will be using 2s zippy 180's and will be putting in an order any day now.

thanks in advance
stalyoni is offline Find More Posts by stalyoni
Reply With Quote
Old Apr 05, 2012, 08:15 PM
Southern Pride
everydayflyer's Avatar
Haralson County GA. USA
Joined Oct 2004
34,812 Posts
SOP is to place the battery where it needs to be so the CG is correct. If you had the aircraft I could tell you and you would understandt but. LiPoly goes in vertical (laying on narrow edge ,not flat) and about half and half in the vertical slot near rear of cavity area.

Balance point is in the area of the launch grip area. Specified CG is way to far back. This thing needs very little elevator. On my DX7 Elevator is set at 15% and it is still way more than needed.

Charles
everydayflyer is offline Find More Posts by everydayflyer
Reply With Quote
Old Apr 06, 2012, 04:17 PM
high flyer
stalyoni's Avatar
Sydney, Australia
Joined May 2008
3,183 Posts
I would really like to see some pics of the CG battery placement. A picture tells a thousand words.
stalyoni is offline Find More Posts by stalyoni
Reply With Quote
Old Apr 11, 2012, 10:45 AM
Mike
miketre's Avatar
Joined Dec 2010
749 Posts
I replaced my left occasionally jittery servo for a new 5320 and it tracks so much better after that. I have also just replaced the right servo as there is some slop in the center position. it causes the plane to lose trim in mid flight.
It was a mistake waiting for the problematic servos to completely fail.
miketre is offline Find More Posts by miketre
Reply With Quote
Old Apr 11, 2012, 07:23 PM
Southern Pride
everydayflyer's Avatar
Haralson County GA. USA
Joined Oct 2004
34,812 Posts
Quote:
Originally Posted by stalyoni View Post
I would really like to see some pics of the CG battery placement. A picture tells a thousand words.
Surely you can see the grip points on the bottom intended for a launch grip. Just place the battery where it balances on this point. It is a mistake to asume all of them are going to require the battery to be in the same location, IMO.Find the balance point and and adjust battery to achive correct CG.

Charles
everydayflyer is offline Find More Posts by everydayflyer
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion RadJet from the KING! vettster Foamy EDFs 1 Jun 01, 2014 06:00 PM
Discussion HK Skyfun or Radjet?? nogas Pusher Prop Jet Models 5 Feb 17, 2014 01:51 AM
Wanted Wtb wtb hk radjet lectroglide Aircraft - Electric - Jets (FS/W) 0 Feb 27, 2012 09:49 PM
Help! Turnigy 420 Charger Problem LukeSkywalker Batteries and Chargers 6 Feb 26, 2012 09:35 PM
New Product New Funjet clone- HobbyKing Radjet Kmart FPV Talk 7 Oct 20, 2011 10:33 AM