New Products Flash Sale
Thread Tools
Old Apr 05, 2016, 09:27 AM
ErnieV is online now
Find More Posts by ErnieV
Registered User
Itegem
Joined Jan 2006
3 Posts
Discussion
Aurora 9 blanc screen after changing model

When I select an other model, it somethimes happens that after the question 'Ready to transmit?' then screen remains blanc. When I turn the transmittor off, the light on the front stays on, but on the back, the light of the module goes off. When I turn the transmittor back on, the screen remains blanc.
The only thing I can do is remove the battery and plug it back in, then I can switch it on again, the model is still the first one, the change didn't happen.
What can be wrong?
Thanks
ErnieV is online now Find More Posts by ErnieV
Reply With Quote
Sign up now
to remove ads between posts
Old Apr 05, 2016, 10:38 AM
Xpress.. is offline
Find More Posts by Xpress..
Team Hitec, Customer Support
Xpress..'s Avatar
United States, CA, Poway
Joined Oct 2007
23,068 Posts
There is an internal issue with your transmitter, it will have to be sent in for repair. You will want to contact the service center nearest you (looks like Multiplex):

http://hitecrcd.com/contact-us/inter...l-distributors
Xpress.. is offline Find More Posts by Xpress..
Reply With Quote


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Aurora 9 locked on screen "Version Changed" BretC Hitec/Multiplex USA 6 Feb 02, 2013 10:33 AM
Help! No throttle response Aurora 9 when changeing Models -S- Hitec/Multiplex USA 1 Jul 09, 2012 10:53 PM
Help! Dimensions of Aurora 9 screen? Garret H Radios 62 Sep 13, 2011 03:13 PM
For Sale NEW! Screen protector for Hitec Aurora 9!! Garret H Aircraft - General - Radio Equipment (FS/W) 2 Sep 08, 2010 09:20 PM