HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Aug 21, 2014, 10:21 AM
Registered User
United States, WA, Seattle
Joined Dec 2012
240 Posts
Help!
IMAX B6 not charging 1s batteries fully.

Hi. Recently I've got a 15-20c 1s lipo pack. It consists of 2 1200mah cells in parallel. When I try to charge it on my IMAX b6 it starts at 2.4 amps (or whatever I set) then immediately drops to 0 and says it's finished. When I try to storage charge the same thing happens. Does anyone know why this might be happening? Thanks
elmtree is offline Find More Posts by elmtree
Reply With Quote
Sign up now
to remove ads between posts
Old Aug 21, 2014, 10:33 AM
Registered User
So. Cal.
Joined Oct 2004
7,950 Posts
Bad battery or bad connection is the most likely culprit. If you've checked the integrity of all connections and found them to be acceptable, you likely have a battery that is a candidate for disposal.

What is the voltage of the battery prior to attempting to charge? Have you tried to use it in your intended application? Are you sure that your charger is not defective (e.g. - charger works as expected with other batteries)?

Try to charge at very low current (~.1A) to see if the battery will accept a charge.
mrforsyth is offline Find More Posts by mrforsyth
RCG Plus Member
Reply With Quote
Old Aug 21, 2014, 10:59 AM
Registered User
United States, WA, Seattle
Joined Dec 2012
240 Posts
I tried charging at .1 amps and got the same result. Haven't had a chance to test connections because I need a fuse for my multimeter, but it certainly works in the intended application (multicopter). I soldered the pack up myself, but I'm fairly certain it is connected. My little voltage checker/alarms give me different voltages (3.3 and 3.9) and the copter itself reads 3.8 right now. Really I just need to find a multimeter I guess


EDIT: yes it works with other batteries
elmtree is offline Find More Posts by elmtree
Reply With Quote
Old Aug 21, 2014, 03:24 PM
Registered User
ggcrandall1's Avatar
USA, GA, Marietta
Joined Aug 2005
5,596 Posts
Quote:
Originally Posted by elmtree View Post
I tried charging at .1 amps and got the same result. Haven't had a chance to test connections because I need a fuse for my multimeter, but it certainly works in the intended application (multicopter). I soldered the pack up myself, but I'm fairly certain it is connected. My little voltage checker/alarms give me different voltages (3.3 and 3.9) and the copter itself reads 3.8 right now. Really I just need to find a multimeter I guess


EDIT: yes it works with other batteries
At those voltages you battery is completely discharged. If it won't take a charge then the battery is ready for the trash.

Discharge the battery to zero volts and discard it.

Glen
ggcrandall1 is offline Find More Posts by ggcrandall1
Reply With Quote
Old Aug 21, 2014, 05:45 PM
Registered User
United States, WA, Seattle
Joined Dec 2012
240 Posts
3.8 is too low? I meant to imply that i though the voltage reader that had 3.3 was broken, sorry if I wasn't clear. Also the charger starts at 3.8 and then jumps to 4.2 when charging like it thinks it is already charged and is finishing it off
elmtree is offline Find More Posts by elmtree
Reply With Quote
Old Aug 21, 2014, 07:13 PM
Registered User
ggcrandall1's Avatar
USA, GA, Marietta
Joined Aug 2005
5,596 Posts
Quote:
Originally Posted by elmtree View Post
3.8 is too low? I meant to imply that i though the voltage reader that had 3.3 was broken, sorry if I wasn't clear. Also the charger starts at 3.8 and then jumps to 4.2 when charging like it thinks it is already charged and is finishing it off
LiPo at 3.0V is discharged to zero energy. LiPo at 3.3V is almost zero energy. LiPo at 3.7V to 3.8V is discharged to about 20% energy. But if the battery starts at 3.8V and it immediately goes to 4.2V on the charger that says to me that the battery is shot. I say that since you say the charger is not at fault as it properly charges other batteries.

Glen
ggcrandall1 is offline Find More Posts by ggcrandall1
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Hard time Charging LiFe battery in Imax B6 rainless Batteries and Chargers 3 Aug 12, 2014 01:00 PM
For Sale New Style XT60 2-6 Cells Li-Po Battery Chargeing Adaptor Board for IMAX B6 B6AC davidwills FPV Equipment (FS/W) 0 Jun 09, 2014 11:43 PM
Sold New Style XT60 2-6 Cells Li-Po Battery Chargeing Adaptor Board for IMAX B6 B6AC davidwills Aircraft - Electric - Batteries & Chargers (FS/W) 0 Jun 09, 2014 11:30 PM
Question Charging multiple mcpx batteries with imax b6 drake29a Batteries and Chargers 4 Sep 20, 2013 09:23 PM
Discussion EOS 0606I parallel charging 1s batteries, will not charge fully have to restart over mescalinedream Batteries and Chargers 5 Apr 25, 2012 02:12 PM