New Products Flash Sale
Thread Tools
Old Apr 02, 2015, 06:09 PM
GamerEdie is offline
Find More Posts by GamerEdie
Registered User
Joined Oct 2014
7 Posts
Discussion
KK 1.2.5 HC ESC Calibration; Motors spin up

Hi all.

Trying to calibrate my ESCs on a KK 2.1.5 HC.

Here's the thing: I'm doing it right, I'm pretty sure:

1) Turn on transmitter, move throttle to full
2) Hold down buttons 1 and 4;
3) While holding down buttons, plug quad into battery;
4) Programmer screen reads "Throttle pass-through";
5) Keep holding buttons....

At this point, I should hear a beep, but what happens is all four motors turn on at full tilt but not in a smooth way but a bit like they're pulsing. They do respond to the throttle being turned down.

I've also tried the "disconnect motor 1; plug in quad; hold down 1 and 4; plug in motor 1" method. Same result.

Bad FC?
GamerEdie is offline Find More Posts by GamerEdie
Reply With Quote
Sign up now
to remove ads between posts
Old Apr 03, 2015, 10:00 PM
Oldgazer is offline
Find More Posts by Oldgazer
Registered User
Oldgazer's Avatar
United States, VA, Richmond
Joined Dec 2013
2,900 Posts
Disconnect the RX channel 3 from the KK board.
Disconnect an ESC and plug it into the RX.
Disconnect 2 motor leads from the other ESCs (this will let you hear just the ESC you are calibrating).
Turn on the TX, put the throttle stick to HIGH.
Plug in the battery.

At the double beep, lower the throttle.
The ESC should give a confirmation beep.
SLOWLY raise the throttle just enough to get the motor to spin.
Lower the throttle and unplug the battery.

Rinse and repeat for the remaining ESCs.
Oldgazer is offline Find More Posts by Oldgazer
Reply With Quote
Old May 27, 2015, 12:38 PM
pepe024 is offline
Find More Posts by pepe024
Registered User
Joined May 2015
18 Posts
Hi Oldgazer,

I have almost the same problem. I made a video of my problem:

S500 with Hobbyking KK2.1HC (1 min 32 sec)


Problems with the Hobbyking KK2.1HC Flight Control Board. The transmitter is a Futaba T6EX. The main problem is that everything is working, but the motors can't running. After many tries, nothing. I tried to press the button 1 and button 4 at Power ON, to calibrate the ESC-s but just get this text: "throttle pass through" and no beeping sound, what should be.

I tried what you write, but I can't understand. If I connect the ESC to the RX directly it spins. But after I connect back to the KK nothing happening. The Throttle doesn't work.

Please help me, I have been trying to fix this problem for hours..
pepe024 is offline Find More Posts by pepe024
Reply With Quote
Old May 31, 2015, 10:55 AM
Winston905 is offline
Find More Posts by Winston905
Registered User
Canada, ON, Hamilton
Joined Oct 2014
30 Posts
my first question to you about the kk board is what firmware is it flashed with .... some issues with the kk boards are firmware related..

would suggest flashing the board with the latest... stevies 1.19 or RC911s ++AIO rev 4

just my 2 cents.
Winston905 is offline Find More Posts by Winston905
Reply With Quote


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion kk 2.1.5 hc problems mackem54 Multirotor Electronics 12 Mar 27, 2015 10:19 PM
Sold HobbyKing FPV250 with KK 2.1.5, RCX 10A esc and DYS 1806 motors TheVIP Aircraft - Electric - Multirotor (FS/W) 6 Mar 19, 2015 06:39 PM
Sold BNF SK450, KK 2.1 Armattan FW, 20A ESCs, Turnigy 2216 motors, 10x4.5 props ianpugh Aircraft - Electric - Multirotor (FS/W) 4 Jan 25, 2015 06:43 AM
Discussion KK 2.1.5 (1.6) and emax 4 in 1 ESC Calibration scwiles Beginner Training Area (Heli-Electric) 0 Jan 19, 2015 03:38 PM
Sold KK 2.1.5 HC w/Programmer ascalise Aircraft - Electric - Multirotor (FS/W) 2 Sep 27, 2014 02:00 PM