SMALL - espritmodel.com SMALL - Telemetry SMALL - Radio
 
Thread Tools
Old May 24, 2004, 09:01 PM
Alex
Guest
n/a Posts
nikko dictator

bought myself my first real rc car a tmaxx. before all i had was radio
shack crap. But i also was given a Nikko dictator about 7 years ago. I loved
it but about a year later a i broke it. Now getting back into the hobby i
take it back out to see what is wrong and if i can fix it. I charged the
battery, and replaced the batts in the controler.

Heres whats up. The car held up in the air with no resitence will go
foreward fast and reverse about half as fast. On the ground the car will go
foreward fairly fast, but not as fast as i remember, but the car will not go
in reverse. The engine spins, but i get nothing.
I think its just the front motor has gone bad. From what i can tell the
gears are ok.

Can someone tell me where i can find a motor that will work in this car, or
a different way to solve the problem. If need be i can post pics of the car.
Its a reall cool little 4wd electro and would love to get it up and running.
thanks


Old Oct 30, 2005, 01:57 PM
its hard living in the UK
grungerguy's Avatar
Joined Oct 2005
239 Posts
Its the pinion

Hey there, I realise this thread is so old you have either found and repaired the problem, put the car away again or thrown it out. well just for referance i think i know what the the problem is. i brought one of these cars second hand a few days ago, i didnt expect it to work but after having problems identical to yours i took the front gearbox apart and found no problem. confused i put it all back together and removed the motor, to find that the pinion gear was mearly spinning when ever i touched it. this problem is apparently common in these cars, over time, i would say its because there is no screw or other fixing arangment on the pinion. So now ill get to the point.... to sort the problem out, remove the motors fixing screws, take the pinion of the motors shaft (if this is the problem it should litrally slip off) wipe off any grease and replace the pinion, gently tap the pinion on to the shaft with a screw driver handel or something (not to hard or you may damage the motor) and test that it no longer slips. If this is not the problem i do apologise but the symptoms are similar to what i experienced. best regards
grungerguy is offline Find More Posts by grungerguy
Old Dec 07, 2005, 07:03 PM
Registered User
Joined Dec 2005
2 Posts
Pinions?

Hello,

I have one of these cars from many years ago as well. It seems to have the same problem you are describing. Can you tell me where I can get new pinions for it?

Thanks!
zjdeere is offline Find More Posts by zjdeere
Old Dec 10, 2005, 06:21 PM
its hard living in the UK
grungerguy's Avatar
Joined Oct 2005
239 Posts
I re-used the pinion that came with the car, just jammed it on there better, i dont know of any where a replacement pinion would be avaliable, seen as this car is going back to 1980's i think... all I done was wiped the shaft and put the pinion back on, one way to stop it sliping is rub the shaft lightly with sand paper. this has worked before but i didnt think of it when i done mine. obviously this is a common problem, hope u sort yours out, best regards.
grungerguy is offline Find More Posts by grungerguy
Old Sep 26, 2010, 09:07 PM
Registered User
Joined Sep 2010
1 Posts
i have 3 remote control nikko cars for sale ones a dictator 4x4 ones a jet wave the others a super dictator 4x4 off roader they all work great no problems ive had them since i was a kid i bought them new and got out of the car playing and into airplanes, ill sell for a good buy if interested email me at dieselcowboy@hotmail.com or make me an offer .
thesquirrel is offline Find More Posts by thesquirrel
 


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Nikko Dictator Parts zjdeere Off-road Cars 1 Dec 10, 2005 06:45 AM