HobbyKing.com New Products Flash Sale
Reply
Thread Tools
This thread is privately moderated by RS Rogers, who may elect to delete unwanted replies.
Old Jul 19, 2011, 03:17 PM
Registered User
RS Rogers's Avatar
Clyde N.C.
Joined Oct 2003
519 Posts
Excellent - glad its all set!
RS Rogers is offline Find More Posts by RS Rogers
Reply With Quote
Sign up now
to remove ads between posts
Old Jul 19, 2011, 03:20 PM
A man with too many toys
United States
Joined Feb 2001
17,632 Posts
Quote:
Originally Posted by JetPlaneFlyer View Post
I don't want to use the 'auto' option due to the need to go to full throttle on the ground for four seconds before every flight... seems bizarre!
You got that right LOL.


Why didnt they make it come out to 100% like it does for the helicopter governor mode? I always found it goofy that they had such a different range for various throttle modes.

Even better would be a way to program for the endpoints of a standard transmitter. With the Castle Link they could just list the radio manufacturers and have you select one. They would make it sooooooooooooo much easier.

RC Man is offline Find More Posts by RC Man
Reply With Quote
Old Jul 26, 2011, 12:18 AM
LiPo Cursed but Still Electric
Northern Illinois, USA
Joined Aug 2010
368 Posts
Recommended "Set RPM" Starting Points for 450 Pro 6S Setup?

Hi Steve,

Thanks for starting this thread.

I've got my fixed end points setup on my ICE 50 and I'd like to make field tuning as painless as possible and was wondering was settings are best to start with and where other Trex 450 Pro 6S guys ended up at when doing their Set RPM setup?

These are the default settings on my Castle Link at the moment:

Govenor Gain 15
Initial Spool-Up Rate 5
Head Speed Change Rate 5

I know the numbers will vary depending on differing components and headspeed but I'm trying to at least get an idea.

I'll be using the 6S setup with a Scorpion 2010KV motor and 13T pinion. This is a popular heli and setup so I'm hoping I don't have to reinvent the wheel.

Desired Head Speeds (accepted by Castle Link software calculator)

1. 2700
2. 3000
3. 3200

Are these good head speed ranges or is 2700 too low for number 1?

Motor Start Power is default at 59
# of Poles = 6 (Scorpion Specs)
Timing 5 (Scorpion Specs)

PWM Rate. Scorpion list this as 8 Khz but I've hear others have had better results with the "Outrunner Mode" setting?

Current Limiting = Insensitive (80A) I saw this mentioned in one of the Castle PDFs

Thanks in advance for any input.

-Eric
isogloss3d is offline Find More Posts by isogloss3d
Last edited by isogloss3d; Jul 26, 2011 at 12:20 AM. Reason: typo
Reply With Quote
Old Jan 17, 2012, 05:34 PM
Registered User
Indonesia
Joined May 2007
41 Posts
Help

Hello guys, need help here with castle ice 80hv on my trex 600 epro. I setup my esc manually using transmitter stick (dsx9), my setup are :

1. Auto lipo
2. Normal current limiting.
3. Brake disabled
4. Fixed throttle
5. Standard advance
6. Hard cutoff
7. Soft start
8. Outrunner mode

The problem is now i didn't get the soft start on my heli, i flown my heli twice without setting up the esc and yes i know how castle esc soft start feel but its not there anymore. Then i calibrated my throttle, i got unusual value with my throttle EPA, now its 75 high dan 65 low. What's wrong with my setup ? Please help me.

Harya
Harya is offline Find More Posts by Harya
Reply With Quote
Old Jan 17, 2012, 05:46 PM
Registered User
RS Rogers's Avatar
Clyde N.C.
Joined Oct 2003
519 Posts
Quote:
Originally Posted by Harya View Post
Hello guys, need help here with castle ice 80hv on my trex 600 epro. I setup my esc manually using transmitter stick (dsx9), my setup are :

1. Auto lipo
2. Normal current limiting.
3. Brake disabled
4. Fixed throttle
5. Standard advance
6. Hard cutoff
7. Soft start
8. Outrunner mode

The problem is now i didn't get the soft start on my heli, i flown my heli twice without setting up the esc and yes i know how castle esc soft start feel but its not there anymore. Then i calibrated my throttle, i got unusual value with my throttle EPA, now its 75 high dan 65 low. What's wrong with my setup ? Please help me.

Harya
The minute you went to stick programming it defaulted the controller to Airplane mode. You will need to go back through all the settings being sure to set it to Heli mode for the soft start.
The minute the stick programming is entered everything is defaulted on Castle Controllers which is Airplane mode so if you make multiple attempts you always have to start from the very first setting. For your heli you need to set the following
Heli Mode, Fixed Endpoints (unless you choose gov mode) 12khz PWM & Normal Timing. Everything else you can leave at the default settings.

Hope this helps
Steve
RS Rogers is offline Find More Posts by RS Rogers
Reply With Quote
Old Jan 17, 2012, 05:50 PM
Registered User
Indonesia
Joined May 2007
41 Posts
Quote:
Originally Posted by RS Rogers View Post
The minute you went to stick programming it defaulted the controller to Airplane mode. You will need to go back through all the settings being sure to set it to Heli mode for the soft start.
The minute the stick programming is entered everything is defaulted on Castle Controllers which is Airplane mode so if you make multiple attempts you always have to start from the very first setting. For your heli you need to set the following
Heli Mode, Fixed Endpoints (unless you choose gov mode) 12khz PWM & Normal Timing. Everything else you can leave at the default settings.

Hope this helps
Steve
Steve, how do i change to heli mode withouth castle link? Still waiting one to arrived.

Harya
Harya is offline Find More Posts by Harya
Reply With Quote
Old Jan 17, 2012, 06:00 PM
Registered User
RS Rogers's Avatar
Clyde N.C.
Joined Oct 2003
519 Posts
Wow just noticed the stick programming goes to gov mode & not really an option to just set Fixed endpoints / heli mode. Been awhile sich I stick programmed!
Till you get the castle link you may have to run the gov mode to get the soft start back.
You may try putting the #7 setting to 1.
Ill work on this tomorrow to see what i can come up with.

Steve
RS Rogers is offline Find More Posts by RS Rogers
Reply With Quote
Old Jan 17, 2012, 06:14 PM
Registered User
Indonesia
Joined May 2007
41 Posts
Quote:
Originally Posted by RS Rogers View Post
Wow just noticed the stick programming goes to gov mode & not really an option to just set Fixed endpoints / heli mode. Been awhile sich I stick programmed!
Till you get the castle link you may have to run the gov mode to get the soft start back.
You may try putting the #7 setting to 1.
Ill work on this tomorrow to see what i can come up with.

Steve
Many thanks Steve, i guess i'll wait for my castle link to arrive hopefully tomorrow. Thanks for your quick respond.

Harya
Harya is offline Find More Posts by Harya
Reply With Quote
Old Jan 19, 2012, 04:57 PM
Registered User
Indonesia
Joined May 2007
41 Posts
Steve, i finally got my castle link and it is exactly like what you said. My cc is in airplane mode and the auto rotation box is disabled. Now i set it up to heli and fixed throttle then i calibrated my throttle end point, it's 98 high and 123 low now.


Harya
Harya is offline Find More Posts by Harya
Reply With Quote
Old Feb 02, 2012, 08:12 AM
Registered User
Joined Feb 2012
2 Posts
Hello guys well i am really confused and i have couple of questions

1 When i do stick calibration must be in gov mode enabled or not
2 When i fly the helicopter when i do hard movements i have a tail kick in non gov mode this is not happen so what i can do to avoid them and fix it i must play with gov settings?????


My setup is
Align 500
RCM-500l
CC 100 non HV
DS 510
Beastx
antkonstas is offline Find More Posts by antkonstas
Reply With Quote
Old Feb 02, 2012, 11:47 AM
Castle Support
Clintstone's Avatar
USA, GA, Statesboro
Joined Oct 2007
956 Posts
Quote:
Originally Posted by antkonstas View Post
Hello guys well i am really confused and i have couple of questions

1 When i do stick calibration must be in gov mode enabled or not
2 When i fly the helicopter when i do hard movements i have a tail kick in non gov mode this is not happen so what i can do to avoid them and fix it i must play with gov settings?????


My setup is
Align 500
RCM-500l
CC 100 non HV
DS 510
Beastx
If you want to fly in GOV mode then you need to calibrate in gov mode.. it is best to turn on Auto-rotation feature in the CC Link if you intend to use it as well... Make sure the throttle curve is linear and set to 0-50-100 and also make sure the throttle trim is disabled or you keep it in the same place you have it in during calibration....


You reference flying in Non-GOV mode.... the GOV settings have no affect in Non-GOV operation... as for the tail kick you may need to set the piro comp in the Beast-X...
Clintstone is offline Find More Posts by Clintstone
Reply With Quote
Old Feb 02, 2012, 12:13 PM
Team Mulikow
Zeta30's Avatar
Joined May 2007
920 Posts
Quote:
Originally Posted by Clintstone View Post
If you want to fly in GOV mode then you need to calibrate in gov mode.. it is best to turn on Auto-rotation feature in the CC Link if you intend to use it as well... Make sure the throttle curve is linear and set to 0-50-100 and also make sure the throttle trim is disabled or you keep it in the same place you have it in during calibration....


You reference flying in Non-GOV mode.... the GOV settings have no affect in Non-GOV operation... as for the tail kick you may need to set the piro comp in the Beast-X...
Hi Clint, is that a typo regarding your reference to the linear throttle curve? I was always under the impression that if you are flying in Gov Mode your throttle curve had to be a flat curve.
Zeta30 is offline Find More Posts by Zeta30
Reply With Quote
Old Feb 02, 2012, 06:38 PM
Castle Support
Clintstone's Avatar
USA, GA, Statesboro
Joined Oct 2007
956 Posts
Quote:
Originally Posted by Zeta30 View Post
Hi Clint, is that a typo regarding your reference to the linear throttle curve? I was always under the impression that if you are flying in Gov Mode your throttle curve had to be a flat curve.

No typo... you need the linear throttle curve for Calibration so you can hit 100% and -0-... if you have a flat throttle value the throttle would never move during calibration... I hope this helps...
Clintstone is offline Find More Posts by Clintstone
Reply With Quote
Old Feb 02, 2012, 07:25 PM
Team Mulikow
Zeta30's Avatar
Joined May 2007
920 Posts
Quote:
Originally Posted by Clintstone View Post
No typo... you need the linear throttle curve for Calibration so you can hit 100% and -0-... if you have a flat throttle value the throttle would never move during calibration... I hope this helps...
Got it, thanks for clarifying that for me.
Zeta30 is offline Find More Posts by Zeta30
Reply With Quote
Old Feb 03, 2012, 12:56 AM
Registered User
Joined Feb 2012
2 Posts
Quote:
Originally Posted by Clintstone View Post
If you want to fly in GOV mode then you need to calibrate in gov mode.. it is best to turn on Auto-rotation feature in the CC Link if you intend to use it as well... Make sure the throttle curve is linear and set to 0-50-100 and also make sure the throttle trim is disabled or you keep it in the same place you have it in during calibration....


You reference flying in Non-GOV mode.... the GOV settings have no affect in Non-GOV operation... as for the tail kick you may need to set the piro comp in the Beast-X...

Ok so i am dont care if i be in gov mode or not just care to have a 0-50-100 in my normal mode to do the procedure plus the auto rotation ok thats good and i am fully understand the problem with the tail was in hard changes of pitch the moment of giving and off course ESC give more power to support the desired head speed i choose for 3d (2350) so with my previous ESC (align) in non governor mode has not this problem so i suggest that is a software problem of castle and need more tuning by me

BTW
I do a flight yesterday in outrunning mode plus governor gain in 20 , get it more well but i think the head speed is not raising pretty fast so i get 23 in gain and i change PWM to 8

Are u think its ok ?
antkonstas is offline Find More Posts by antkonstas
Last edited by antkonstas; Feb 03, 2012 at 05:11 AM.
Reply With Quote
Reply


Thread Tools