HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Oct 14, 2012, 03:35 PM
Registered User
Joined Jun 2009
19 Posts
Discussion
''Neg. Term. < 0V'' Error message

My new Cellpro 10S charger has stopped working for some reason and only shows this error message. Neg. Term. < 0V. Anyone know what the problem is? I was trying to charge one single cell on a 5S battery. My other Cellpro 10S which is 4 years old does it with no problem.

Thanks
Ray

EDIT: I made a search before and didn't find anything. I remade the search using different words and found out that I have to return the charger. Yes I am mad because I bought a Cellpro 10S 4 years ago and I love it. It still works flawlessly. Recently, I bought a Hyperion 1420i and it was defective and had to return it. Then I bought a Thunder Power 1430c and it was defective and had to return it. So I tought the heck with it and I'll stick to what works for me and bought a second Cellpro 10S and now I have to return it.

So disregard this thread please, I've started the email process with FMA Direct.
mistercrash is online now Find More Posts by mistercrash
Last edited by mistercrash; Oct 14, 2012 at 03:51 PM.
Reply With Quote
Sign up now
to remove ads between posts
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
For Sale Hobbico HydriMax NiMH 5C 6.0V 4200mAh RX Batteries 5jays Aircraft - Electric - Batteries & Chargers (FS/W) 0 Mar 21, 2012 01:18 AM
Discussion Cellpro 10s Neg. Term <0v error code parkfly27 FMA Direct 5 Mar 20, 2012 10:00 PM
Discussion Cellpro 10s error code Neg. Term < 0v rixsweeney FMA Direct 5 Dec 29, 2011 10:56 PM
Question CC BEC PRO: 5.0v or 5.5v or 6.0v? popome Castle Creations 5 Jun 03, 2011 07:22 PM
Discussion A123 long term: 1st 1,000 CYCLES done, 2nd +800cycles highC done, 3rd to 0V going on armengol Batteries and Chargers 172 Jun 16, 2008 04:15 PM