Espritmodel.com Telemetry Radio
Reply
Thread Tools
Old Jan 26, 2013, 01:57 PM
Go fast, pull up.
Fidelity101's Avatar
United States, NY, Clarence Center
Joined Nov 2008
1,609 Posts
Help!
DJI NAZA with GPS - RTH issue

I configured my DJI Naza to RETURN TO HOME and land when it enters FAILSAFE mode. I have an Aurora 9 and I'm using a 7 channel receiver. I configured a mix, so when i fly a 2 way switch, the NAZA goes from GPS mode to FAILSAFE mode. I went up about 10 feet and flipped the switch. The naza went up about 20 meters and slowly flew back to the house. When it reached the
home position over the take off point, it hovered for about 10 seconds and then SLOWLY started to land. When it finally landed, it came to within 10 feet of the take off point and started to hit the ground and take off, hit the ground and take off, etc, etc. It did this for about 5 cycles until I tried to go back into GPS mode by releasing the 2 position switch...but I was unable to regain control.

I waited until it smached the ground one more time and I grabbed the battery, forced it to stay down and unplugged the battery. While doing this, the motors were going crazy trying to take off again.

Does anyone know why it did this and what I can do to fixit?

Question 2:
In manual mode, the hexacopter hovers perfectly with zero vibration. In GPS mode, it seems to have a jitter and rocks back and forth a slight amount. Any idea what causes this?
Fidelity101 is offline Find More Posts by Fidelity101
RCG Plus Member
Reply With Quote
Sign up now
to remove ads between posts
Old Jan 26, 2013, 02:44 PM
Registered User
Canada, ON, Brockville
Joined Sep 2004
700 Posts
Quote:
Originally Posted by Fidelity101 View Post
I configured my DJI Naza to RETURN TO HOME and land when it enters FAILSAFE mode. I have an Aurora 9 and I'm using a 7 channel receiver. I configured a mix, so when i fly a 2 way switch, the NAZA goes from GPS mode to FAILSAFE mode. I went up about 10 feet and flipped the switch. The naza went up about 20 meters and slowly flew back to the house. When it reached the
home position over the take off point, it hovered for about 10 seconds and then SLOWLY started to land. When it finally landed, it came to within 10 feet of the take off point and started to hit the ground and take off, hit the ground and take off, etc, etc. It did this for about 5 cycles until I tried to go back into GPS mode by releasing the 2 position switch...but I was unable to regain control.

I waited until it smached the ground one more time and I grabbed the battery, forced it to stay down and unplugged the battery. While doing this, the motors were going crazy trying to take off again.

Does anyone know why it did this and what I can do to fixit?

Question 2:
In manual mode, the hexacopter hovers perfectly with zero vibration. In GPS mode, it seems to have a jitter and rocks back and forth a slight amount. Any idea what causes this?
You have to be in Attitude or Manual mode to disengage the RTL. It won't come out in GPS mode. Try lowering your Verical gainto stop it bouncing

That is the GPS trying to Keep the multirotor in position. Try lowering your Attitude gains a little

Bob
Bob valley is offline Find More Posts by Bob valley
Reply With Quote
Old Jan 26, 2013, 02:51 PM
Go fast, pull up.
Fidelity101's Avatar
United States, NY, Clarence Center
Joined Nov 2008
1,609 Posts
160-160-160-160-150-150 was way to much for my F550. It vibrated in every mode and the vibration got worse as i tried to give more throttle up or move in any direction.

I went back to 140-140-125-140-140-140.

Flipping out of GPS mode allowed me to regain control. (THANK YOU!)

The HEX is still landing about 6-8 feet away from the start location and doesn't seem to want to stop. Also, it comes down VERY slow. I've seen a few videos of the auto landing and my hex seems to be MUCH MUCH slower. It descends really slowly...the 20 meter decent takes a good 45 seconds or so to actually reach ground level before it hits the ground and goes back up 2 feet, then back to the ground and up 2 feet.

What sets controls the rate of decent?
Fidelity101 is offline Find More Posts by Fidelity101
RCG Plus Member
Last edited by Fidelity101; Jan 26, 2013 at 04:32 PM.
Reply With Quote
Old Jan 26, 2013, 04:24 PM
Flying R/C since 1964
kallend's Avatar
United States, IL, Chicago
Joined Sep 2004
3,462 Posts
Quote:
Originally Posted by Fidelity101 View Post
I went out for another quick test flight. I lowered my settings to 140-140-140-125-125 for the NAZA. In manual, it was fine. In GPS mode, it drifted like crazy. When switching from ATT to GPS, it banked about 5 degrees and drifted back about 20 feet before drifting forward again. I can only hope that was the lower settings and I'm going to give 160-160-160-150-150 a shot now and see how that goes. Also, I had trouble locking onto a GPS signal, even though I'm in the same spot as last time. This might help explain the crazy drifting, but I'm going out for a third try and see if I can improve things any with the new numbers.
Remember that the attitude gains are doing something different than the basic gains (RTFM for details). Changing all at the same time makes it very difficult to isolate a problem.

Howe FAR did it drift in GPS mode? I am not aware of any non-military GPS that is accurate to better than 10feet or so.
kallend is offline Find More Posts by kallend
RCG Plus Member
Latest blog entry: Using a DX9 to "strobe" LED...
Reply With Quote
Old Jan 26, 2013, 05:23 PM
Go fast, pull up.
Fidelity101's Avatar
United States, NY, Clarence Center
Joined Nov 2008
1,609 Posts
Maybe I'm adding to the confusion by changing multiple settings at the same time. I went out for a 4th time with my original settings (140-140-125-140-140-140) and it no longer had the violent shakes that it had at 160-160-160-160-150-150.

The red light never flashed, so I assume it found enough satellites. I take off and hover in manual, it stays put. I switch over to ATT mode and it stays put with a bit of drift depending on the wind. When I shift to GPS mode, it begins to bank and come at me a bit, then it does a large 15-20 foot circle in the air...almost like "toilet bowl effect". That effect keeps happening, but it usually goes away when the red light stops flashing. In this case, the red light was NOT flashing, but TBE was definitely an issue. I went up about 30 feet and flipped over to GPS mode again and it stayed put. Then, I slammed it forward and built up speed and then let go of the sticks. It started to slow down and then do a big TBE pattern around a 25-30 foot circle getting faster and faster while doing the large circle.

I couldn't even test the RTH feature this time because of the TBE problem...but I would still like to know how to increase the decent rate.
Fidelity101 is offline Find More Posts by Fidelity101
RCG Plus Member
Reply With Quote
Old Jan 26, 2013, 05:46 PM
Flying R/C since 1964
kallend's Avatar
United States, IL, Chicago
Joined Sep 2004
3,462 Posts
OK, it behaves in ATTI but not in GPS mode,

Well, the usual questions are:

Did you calibrate the compass away from any magnetic disturbances?

If you give forward stick in GPS mode, does it fly straight or drift to the side?


Suggestion - if you want to fly it like a pylon racer, do it in MAN mode and not GPS.
kallend is offline Find More Posts by kallend
RCG Plus Member
Latest blog entry: Using a DX9 to "strobe" LED...
Reply With Quote
Old Jan 26, 2013, 05:53 PM
Go fast, pull up.
Fidelity101's Avatar
United States, NY, Clarence Center
Joined Nov 2008
1,609 Posts
I calibrated the GPS in my driveway because of the TBE and it made no difference. I did install a light box as a set of legs because of the snow...so maybe it threw my cg off. The compass calibration did not help, so maybe ill just remove the box.

I did the hard stick movements to see if the GPS would hold position. It usually stops on a dime, but now it just slows down the forward momentum and turns left or right as it starts a big circle around the point where I stopped it.
Fidelity101 is offline Find More Posts by Fidelity101
RCG Plus Member
Reply With Quote
Old Jan 26, 2013, 05:58 PM
Flying R/C since 1964
kallend's Avatar
United States, IL, Chicago
Joined Sep 2004
3,462 Posts
Quote:
Originally Posted by Fidelity101 View Post

I did the hard stick movements to see if the GPS would hold position. It usually stops on a dime, but now it just slows down the forward momentum and turns left or right as it starts a big circle around the point where I stopped it.
So it had been flying OK, and now it has changed its behavior?

Did you look in the NAZA GPS thread in Multirotor Electronics forum? The real experts are there.
kallend is offline Find More Posts by kallend
RCG Plus Member
Latest blog entry: Using a DX9 to "strobe" LED...
Reply With Quote
Old Jan 26, 2013, 06:12 PM
Go fast, pull up.
Fidelity101's Avatar
United States, NY, Clarence Center
Joined Nov 2008
1,609 Posts
I'll search around for more information, but it really seems as though my setup changes with every flight. Sometimes its great and sometimes it just wants to drift like crazy in gps mode. I really can't identify why it does that.

Sometimes, in ATT mode, it hovers and upon switching to gps, it banks hard and I have to give a lot of stick input to keep it level. Switching back to ATT and it levels again.

Sometimes, it takes 15 seconds to find satellites and sometimes it takes 3-5 minutes.

Someone's it finds all 8 satellites upon powering up, but this is usually when I have all the crazy drifting issues.
Fidelity101 is offline Find More Posts by Fidelity101
RCG Plus Member
Reply With Quote
Old Jan 26, 2013, 06:18 PM
Got toys?
kenhiraihnl's Avatar
pearl city, hi
Joined Feb 2005
714 Posts
I'm just a beginner, but it sounds like the arrow on your GPS puck is not pointed directly forward. A few degrees off caused my quad to behave like you described. FWIW.
kenhiraihnl is offline Find More Posts by kenhiraihnl
Reply With Quote
Old Jan 26, 2013, 06:41 PM
Go fast, pull up.
Fidelity101's Avatar
United States, NY, Clarence Center
Joined Nov 2008
1,609 Posts
I adjusted it to 8 degrees to account for magnetic vs true north. I did just turn it in slightly... Maybe that caused the issue? Ill try putting it back...thanks for the idea
Fidelity101 is offline Find More Posts by Fidelity101
RCG Plus Member
Reply With Quote
Old Jan 26, 2013, 09:06 PM
Registered User
Australia, NSW, Wollongong
Joined Aug 2011
310 Posts
try changing the direction your gps compass is pointing slightly until you find the sweet spot. Start with it straight ahead, and fly. Then adjust slightly, and try again. Eventually you'll find the spot where the TBE stops; it should be close to your 8 degree variation
slidins15 is offline Find More Posts by slidins15
Reply With Quote
Old Jan 27, 2013, 12:51 AM
Registered User
North Sweden
Joined Jun 2007
591 Posts
Heres my 550 when i try RTH first time. Jumps once when it lands but thats ok.

Hexa 550 RTH (2 min 11 sec)
cyberdog is online now Find More Posts by cyberdog
Reply With Quote
Old Jan 27, 2013, 09:37 AM
Go fast, pull up.
Fidelity101's Avatar
United States, NY, Clarence Center
Joined Nov 2008
1,609 Posts
How do you control the rate of decent? That video shows you dropping at a decent rate, where as mine drops much slower
Fidelity101 is offline Find More Posts by Fidelity101
RCG Plus Member
Reply With Quote
Old Jan 27, 2013, 10:28 AM
Triple Tree Aerodrome
heli001's Avatar
Charlotte, NC
Joined Feb 2002
406 Posts
Fidelity,

Does the weather change whan you are flyinging at different times? Like a lot of sun...then cold and cloudy? Do you fly fast? The NAZA is known to be very picky about the barometric sensor.....If you read the Multi Rotor Electronic section on the NAZA, this is covered very well. It is usually the culprit for most of the TBE's, usually a piece of tape on the side of the MC will correct it.
heli001 is offline Find More Posts by heli001
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Wanted Dji F450 Naza gps with Futaba T8J Venom93corba Aircraft - Electric - Multirotor (FS/W) 4 Mar 22, 2013 11:28 AM
Sold DJI F550 With NAZA GPS and Photohigher AV130 R Hudson Aircraft - Electric - Multirotor (FS/W) 6 Jan 29, 2013 10:31 PM
Sold SOLD DJI Naza 450 with GPS LED and Lipos Tada Aircraft - Electric - Multirotor (FS/W) 8 Jan 15, 2013 10:52 PM
Sold DJI F550 with Naza and GPS flymustangs Aircraft - Electric - Multirotor (FS/W) 3 Jan 13, 2013 12:43 PM
Discussion dji naza with gps and 1.2 ghz downlink issues? ppatron Multirotor Talk 7 Jun 22, 2012 08:26 PM