HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old May 11, 2012, 05:02 PM
Registered User
Joined Mar 2005
67 Posts
Discussion
really need help

Ok I just cant figure it out so please if anyone can help
Situation is as follows :

3 models : eaststar , magister, twin star
Tx Cockpit sx

All have Multiplex rx and speed controls.35mhz

Have them about 4 years now .

Tx recentley services by Multiplex.de


When I do a range check the motors will start of there own accord.

Just checked the easy star unpluged the servo connections just left with the bec and motor line , Rx has antenna down all trims neutral , 10ft away and the motor fires up on its own , happening with all 3 !!!

What is happening , have noticed this in flight and control lost on two occasions as flight controls jitter and motor surges .

Multiplex say Tx ok ?

Please help
b757 is offline Find More Posts by b757
Reply With Quote
Sign up now
to remove ads between posts
Old May 11, 2012, 05:37 PM
Registered User
Fla.
Joined Apr 2005
970 Posts
You said " all trims neutral ". The throttle trim should be all the way down !!! Try that. ENJOY !!! RED
redh is offline Find More Posts by redh
Reply With Quote
Old May 11, 2012, 06:11 PM
Registered User
Joined Mar 2005
67 Posts
Ok so throttle trim all the way down ok will try , thanks , never was aprop in the past will give it a go , thank you
b757 is offline Find More Posts by b757
Reply With Quote
Old May 11, 2012, 07:02 PM
Senile Member
Lnagel's Avatar
Moab, Utah, USA
Joined Apr 2003
5,887 Posts
Sounds like your receivers are loosing the transmitter's signal. Since it happens with all of the recievers it is probable that the transmitter is not putting out the required power. You need to send it back to Multiplex. It might be a good idea to send in the receivers also, just in case.

Larry
Lnagel is online now Find More Posts by Lnagel
Reply With Quote
Old May 11, 2012, 07:37 PM
Registered User
Joined Mar 2005
67 Posts
Thanks for the reply , yes all 3 , as I walk away from the models at about ten feet the controls will start to jitter and then the motor fires up , sometimes to full on and I can not stop it only by pulling batt cable other times just a quick blip , tx was recently serviced by multiplex ,nit also happens in flight the models will surge and dip
b757 is offline Find More Posts by b757
Reply With Quote
Old May 12, 2012, 12:13 AM
Registered User
San Diego
Joined May 2010
133 Posts
Did this problem start before or after the Tx was 'serviced' by Multiplex? If after, send it back.
QuadManiac is offline Find More Posts by QuadManiac
Reply With Quote
Old May 12, 2012, 04:27 AM
Registered User
Joined Mar 2005
67 Posts
before and after
b757 is offline Find More Posts by b757
Reply With Quote
Old May 12, 2012, 10:49 AM
Registered User
Joined Mar 2005
67 Posts
Tried a few things
Rxs in Magister,easy,are old Blue Hitec HFS4MG 35 MHZ have them .about 5 years. Tried the Funjet with Cockpit Tx , Funjet has Multiples 7 IPD Rx, it was fine until 10 ft and motor blipped ,but when i trimmed throttle all the way down no servo movements and no motor on range check , tried old Laser 4 tx on othe rmodels and after 10 ft motor would come alive , no odd Freq interference here as tried it in a differnet location , so to sumit up all models showing motor firing up in range check with two Tx , controls jittering with both Tx , but was better with 7ipd rx as no contols jitter but motor did turn in range check , but after trim full down it did not , would i be better of getting new Rx ? or selling cockpit Tx and getting Spektrum DX 6 with with new 2,4 Rx
b757 is offline Find More Posts by b757
Reply With Quote
Old May 12, 2012, 03:25 PM
Senile Member
Lnagel's Avatar
Moab, Utah, USA
Joined Apr 2003
5,887 Posts
You should get a range check of much farther than 10 feet. Sonething is definitely wrong somewhere. How are you routing the receiver antennae in the airplanes?

Larry
Lnagel is online now Find More Posts by Lnagel
Reply With Quote
Old May 12, 2012, 07:29 PM
Registered User
Joined Mar 2005
67 Posts
Well tried it with an old laser 4 and same problem but maybe I am getting it wrong , this all happens at about 30ft !! as i walk away at about 30 ft the motor springs to life sometimes it will shut down as i walk back sometimes it wont
b757 is offline Find More Posts by b757
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion really need some help please! mrmurder1975 Flying Wings 6 Apr 29, 2012 08:20 AM
Discussion Really? You need a freakin license to clean someone's house naked? logan5 Life, The Universe, and Politics 8 Apr 15, 2012 02:06 AM
Discussion flight sim really helping !!! genzod Electric Plane Talk 5 Mar 03, 2012 09:59 PM
Help! really need your help keya Multirotor Talk 21 Dec 29, 2011 11:38 AM