New Products Flash Sale
Thread Tools
Old Nov 21, 2015, 04:25 PM
davidbitton is online now
Find More Posts by davidbitton
Registered User
United States, NJ, Bergen County
Joined Sep 2015
342 Posts
Discussion
Turnigy Reaktor Shows Dead Cell; B6AC Shows Cell OK

I have an issue with my new Turnigy Reaktor 300W charger. I kept getting an error when attempting to charge; voltage error. The charger was showing blanks for the #2 cell voltage (see attached). I put the 8000mAh 6S LiPo on my B6AC charger, and despite dealing with a low voltage error resolved with the NiMH hack, the B6AC shows voltage on all six cells. Has anyone else dealt with this? Thanks.
davidbitton is online now Find More Posts by davidbitton
Reply With Quote
Sign up now
to remove ads between posts
Old Nov 21, 2015, 04:27 PM
BuffaloJustin is offline
Find More Posts by BuffaloJustin
Registered User
BuffaloJustin's Avatar
United States, SC, Lexington
Joined May 2014
3,239 Posts
Let's break the tie; plug a simple cell checker/low voltage alarm into its balance lead.

I have both these chargers, and for what it's worth, I'd trust the Reaktor far before the B6, but That doesn't mean either is infallible.
BuffaloJustin is offline Find More Posts by BuffaloJustin
Reply With Quote
Old Nov 21, 2015, 04:31 PM
davidbitton is online now
Find More Posts by davidbitton
Registered User
United States, NJ, Bergen County
Joined Sep 2015
342 Posts
Quote:
Originally Posted by BuffaloJustin View Post
Let's break the tie; plug a simple cell checker/low voltage alarm into its balance lead.

I have both these chargers, and for what it's worth, I'd trust the Reaktor far before the B6, but That doesn't mean either is infallible.
I do not have a cell checker; will a multimeter suffice? What am I looking for? Am I checking the voltage against the negative lead of the balance connector? Thanks!
davidbitton is online now Find More Posts by davidbitton
Reply With Quote
Old Nov 21, 2015, 04:34 PM
BuffaloJustin is offline
Find More Posts by BuffaloJustin
Registered User
BuffaloJustin's Avatar
United States, SC, Lexington
Joined May 2014
3,239 Posts
Well, at just a few bucks, I'd order one...

hobbyking.com/hobbyking/store/__67120__HobbyKing_8482_Cell_Checker_with_Low_Volt age_Alarm_2S_8S_AR_Warehouse_.html
BuffaloJustin is offline Find More Posts by BuffaloJustin
Reply With Quote
Old Nov 21, 2015, 06:53 PM
davidbitton is online now
Find More Posts by davidbitton
Registered User
United States, NJ, Bergen County
Joined Sep 2015
342 Posts
OK, but while I'm waiting, what can I do?
davidbitton is online now Find More Posts by davidbitton
Reply With Quote
Old Nov 24, 2015, 08:31 PM
davidbitton is online now
Find More Posts by davidbitton
Registered User
United States, NJ, Bergen County
Joined Sep 2015
342 Posts
Update

I used a Venom Low Voltage Monitor for 2S to 8S LiPO Batteries and it showed the first five sells at or slightly above 3.7v and cell #6 at 0.96v. So, which device do I trust; the B6AC, the Reaktor or the Venom?
davidbitton is online now Find More Posts by davidbitton
Reply With Quote
Old Dec 01, 2015, 06:28 PM
BuffaloJustin is offline
Find More Posts by BuffaloJustin
Registered User
BuffaloJustin's Avatar
United States, SC, Lexington
Joined May 2014
3,239 Posts
Honestly if you have three devices giving you three different results on the same battery, I'd trust them all and decommission the battery...

Don't know what to tell ya man, never heard of such a thing. Could be as simple as an issue with the balance lead.
BuffaloJustin is offline Find More Posts by BuffaloJustin
Reply With Quote
Old Dec 03, 2015, 08:46 AM
davidbitton is online now
Find More Posts by davidbitton
Registered User
United States, NJ, Bergen County
Joined Sep 2015
342 Posts
Quote:
Originally Posted by BuffaloJustin View Post
Honestly if you have three devices giving you three different results on the same battery, I'd trust them all and decommission the battery...

Don't know what to tell ya man, never heard of such a thing. Could be as simple as an issue with the balance lead.
I wound up draining and recharging the battery. Here are the results after baking it for 2hrs
davidbitton is online now Find More Posts by davidbitton
Reply With Quote


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help! Imax B6AC - wrong Cell count for charge SWAN808 Batteries and Chargers 12 Jul 15, 2015 06:47 AM
Wanted Turnigy 6s 2650 20c battery (bad cell ok) mmracecars Aircraft - Electric - Batteries & Chargers (FS/W) 1 Jun 08, 2012 12:39 PM
Rant Dead cell in Turnigy Li-Po? bgjames111 Batteries and Chargers 34 Mar 28, 2010 02:25 PM
Discussion DEAD CELL - Turnigy Lipo from Hobbycity/Hobbyking KLLim Batteries and Chargers 20 Dec 08, 2009 07:32 PM
Polyquest cells showing small imbalance--ok? Newberry Batteries and Chargers 13 Jul 10, 2005 04:13 PM