HobbyKing.com New Products Flash Sale
Thread Tools
Old Jul 09, 2013, 09:49 PM
Registered User
Joined May 2013
8 Posts
cellpro 10s

hi, I'm desperate, charger Cellpro 10s I get the following error, Safety code 97, push button mode.
I tried to buy the cable FMA I updated the firmware to latest version,
I tried to switch on the charger mode, with the key pressed, but nothing, I tried to change power supply, I tried to change the charge, but nothing ..
you know tell me the remedy?
hatos77 is offline Find More Posts by hatos77
Reply With Quote
Sign up now
to remove ads between posts
Old Jul 11, 2013, 09:19 AM
Registered User
Joined Jan 2002
91 Posts

Please check your e-mail. I responded this morning.

Jamie Marks
Jamie Marks is offline Find More Posts by Jamie Marks
Reply With Quote

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help! 10s2p A123 pack not charging on a Cellpro 10s Charger JoeNemo Electric Plane Talk 10 Jun 21, 2013 01:25 PM
Wanted Cellpro 10s wanted raguayo Aircraft - Electric - Batteries & Chargers (FS/W) 2 Jun 02, 2013 01:20 PM
Sold FMA Cellpro 10s firehawkzach Aircraft - Electric - Batteries & Chargers (FS/W) 0 Apr 19, 2013 10:56 AM
Sold Cellpro 10S Chargebox astropuppy Aircraft - Electric - Batteries & Chargers (FS/W) 4 Apr 14, 2013 08:54 PM
Sold Cellpro 10s pogoods Aircraft - Electric - Helis (FS/W) 0 Mar 29, 2013 12:39 PM