HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Yesterday, 11:31 AM
Registered User
United States, OK, New Cordell
Joined Oct 2014
3 Posts
Discussion
WLtoys V913 Help

Hey guys, new here, so if this is in the wrong location for this post, please correct me. (First Post)

Ok, I had recently purchased the WLtoys V913 and I'm having A LOT of problems with it at this point, the first few days of owning this heli, it flew and worked great!
Then bout the third day (maybe 6th flight) I couldn't hardly get it off the ground on a full charge, so I ran the battery out, recharged, now the motor seems to not respond, so I put it away, thinking all I need is a new motor, got a new motor (not installed yet) I thought I'd try and see if I could get it to work today, but now the receiver board isn't responding normally, the led won't even blink to show I can bind my receiver, and now when I hook up the battery to the charger, the charger light just blinks, and doesn't seem to be charging....
What's wrong with this thing!?!?
It's turning into a headache trying to figure it out, and nothing in the trouble shoot manual has prepared me for this, can anyone PLEASE HELP???

Any help MUCH appreciated!
-Derek
Heli_Pilot_THP is offline Find More Posts by Heli_Pilot_THP
Reply With Quote
Sign up now
to remove ads between posts
Old Yesterday, 12:15 PM
Registered User
holtneil's Avatar
United Kingdom, England, Central Bedfordshire
Joined Dec 2012
1,233 Posts
Hi mate if the battery charger is not working then heli will not fly on a dead battery , have you got a volt meter , can you tell us what battery voltage is reading
there is a section on here just for that heli
http://www.rcgroups.com/forums/showthread.php?t=1791676
holtneil is offline Find More Posts by holtneil
Reply With Quote
Old Yesterday, 12:29 PM
Registered User
United States, OK, New Cordell
Joined Oct 2014
3 Posts
Quote:
Originally Posted by holtneil View Post
Hi mate if the battery charger is not working then heli will not fly on a dead battery , have you got a volt meter , can you tell us what battery voltage is reading
there is a section on here just for that heli
http://www.rcgroups.com/forums/showthread.php?t=1791676
Unfortunately no, but I hooked the battery to similar heli, and the battery has a good charge, so my v913 must be the problem...
Heli_Pilot_THP is offline Find More Posts by Heli_Pilot_THP
Reply With Quote
Old Yesterday, 12:42 PM
Registered User
holtneil's Avatar
United Kingdom, England, Central Bedfordshire
Joined Dec 2012
1,233 Posts
Hi mate if battery is good , may be a motor problem is it the brushless model or older one
holtneil is offline Find More Posts by holtneil
Reply With Quote
Old Yesterday, 01:01 PM
Registered User
United States, OK, New Cordell
Joined Oct 2014
3 Posts
It's a standard brushed motor, I've got two extra replacements, but the way it's looking, I'm going to have to get a new board for it, because I still can't get a response to it, when I turn it on, the light just stays on, won't even blink once
Heli_Pilot_THP is offline Find More Posts by Heli_Pilot_THP
Reply With Quote
Old Yesterday, 02:28 PM
My other addiction!
norcalheli's Avatar
Marysville, Ca., US
Joined Jan 2007
1,709 Posts
Quote:
Originally Posted by Heli_Pilot_THP View Post
Then bout the third day (maybe 6th flight) I couldn't hardly get it off the ground on a full charge, so I ran the battery out, recharged, now the motor seems to not respond, ...When it was working, did you fly it until it could no longer stay in the air? And when you say you "ran the battery out" do you mean discharged it completely? If so you have ruined your battery. LiPo batterues can not take being discharged below about 3.3 volts per cell. Not going lower than 3.5 or 3.6 is even better.

I thought I'd try and see if I could get it to work today, but now the receiver board isn't responding normally, the led won't even blink to show I can bind my receiver, You shouldn't have to re-bind every time you fly. Are you turning on the transmitter first, then plugging in the heli? If not, then yhou are putting it into bind mode, where if you do turn the TX on first, the heli should just pair up with the TX and initialize.

and now when I hook up the battery to the charger, the charger light just blinks, and doesn't seem to be charging....This is another symptom of an over-discharged battery. The charger has to see a "safe" level of charge, and if the level of charge of the battery is below this "safe"level, most chargers will not charge the battery.-Derek
It really sounds like you have a destroyed battery. When you hooked it up to the second helicopter, did you fly it or just see if it would spin the blades? I would suggest getting a new battery, and from now on, time your flights. If the heli shows the least difficulty in flying, land immediately, let the battery cool, then recharge. If you plan to stay in this hobby you will need a decent volt meter so you can check the level of charge in your batteries accurately. And get in the habit of always turning the transmitter on before plugging in a battery to your heli. You should only ever have to bind once.
norcalheli is offline Find More Posts by norcalheli
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Mini-Review WLtoys V913 Brushless (official WLtoys release) SeByDocKy Micro Helis 12 Oct 22, 2014 04:53 AM
Sold FS WLToys v911 v912 v913 Transmitter New $14 Shipped fastmax Aircraft - General - Radio Equipment (FS/W) 1 Sep 25, 2014 02:25 PM
Mini-Review MJX F45 VS F46 ,WLtoys V912 VS V913 Aaron qin Micro Helis 127 Sep 01, 2014 11:52 AM
Sold Brand new in box Wltoys V913 $65 shipped baddb1 Aircraft - Electric - Helis (FS/W) 4 Jun 01, 2013 07:50 PM