New Products Flash Sale
Thread Tools
Old Apr 25, 2015, 08:26 AM
gtav is offline
Find More Posts by gtav
Registered User
Joined Apr 2015
2 Posts
Help!
V911 help

I bought a WL toys v911 a couple of days ago and it's been flying good.
Today i was flying it inside and had a small crash after that the control was intermittent, which i had got before when i was on low battery. So I plugged in a new battery and then it would not respond to anything.
When i put a battery in the helicopter the light on it flashes for a few seconds and then stays solid. From reading the manual it sounds like the light should only go solid when it binds to the transmitter.

Any ideas why it's not working? The crash was really small so i'm not sure if that damaged it, I can't see any physical damage to it.

If anyone else has owned one of these how long did it last you?
gtav is offline Find More Posts by gtav
Reply With Quote
Sign up now
to remove ads between posts
Old Apr 25, 2015, 08:51 AM
JW57RC is offline
Find More Posts by JW57RC
Fueled by coffee & LiPo
JW57RC's Avatar
United States, FL, Venice
Joined Apr 2014
181 Posts
Welcome new V911 flyer!

There are a couple of things to consider, as a small crash can sometimes damage these delicate control boards or wiring. So without knowing much about the crash, I can only speculate about the problems.

I know the V911 threads on this board are huge, but take some time to got through them... This isn't the first time this sort of thing happened, and this isn't a really complex Heli, but the cool thing about the V911 is all the things you get to learn! One thing I learned was that it's better to have two so you can still fly when one is in the hanger!

When you connect the battery is the transmitter turned on? After the first time you "bind"ed to this TX, do you turn the TX on before you connect the battery? If not, make sure there are no other tx in the area. If the tx is on first, and you connect the battery, once the light goes solid, do you have control of the servos? If you have servo control you've probably got a bind.

I suggest that you can also review a few other things: Is there any evidence of a wiring short at the tail motor? Is everything on the tail boom assembly intact? When you crashed did you get the motors turned off before hitting or did they run a bit? Have you examined the wiring at the PCB? Is anything disconnected or look loose?

And anytime I crash I examine the rotor linkage very closely, although it probably has nothing to do with this initialization issue. Are any of the links disconnected, or have any been pushed on too far? Does the Flybar "bounce" when you flick it (it should go up and down a couple of times, and the rotor blade pitch change appropriately)?

Fly safely, and best of luck in finding the fix for your Heli.
JW57RC is offline Find More Posts by JW57RC
Reply With Quote
Old Apr 26, 2015, 02:31 AM
gtav is offline
Find More Posts by gtav
Registered User
Joined Apr 2015
2 Posts
Thanks for replying i appreciate your advice.

I've been playing around with it and can get it to connect now but it keeps dropping out. I think the crash must have damaged somthing on the control board. I will send of for another and fly it more carefully.
gtav is offline Find More Posts by gtav
Reply With Quote


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Help!...V911 tail rotor problem floydlong Micro Helis 7 Jan 03, 2015 01:39 PM
Help! WLToys v911 upgrade help Pyro Rebel Micro Helis 8 Dec 08, 2014 11:37 AM
Help! Screwed WL V911> Spinning to death after 2 flights > Too bad > Need help RcManV911 Micro Helis 6 Apr 14, 2014 01:25 AM
Discussion help...v911 motor XxRcfansxX Electric Heli Talk 5 Nov 25, 2013 09:03 PM
Wanted help with V911 XxRcfansxX Aircraft - Sailplanes (FS/W) 1 Nov 23, 2013 10:17 PM