HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Apr 29, 2010, 01:16 PM
Registered Loser :)
mark hitchman's Avatar
New Zealand
Joined Sep 2009
1,928 Posts
Delta wing

Quote:
Originally Posted by magnetman View Post
But what if you don't have a delta wing?? You would not want the mixing in that case.
According to http://en.wikipedia.org/wiki/Delta_wing my funjet http://www.hobbyking.com/hobbyking/s...less_Motor_ARF is a delta wing and I mix aileron and elevator to fly it. With rvosd I set the radio for a standard plane and the rvosd does the mixing so you can access the menu in flight.

Mark
mark hitchman is offline Find More Posts by mark hitchman
Reply With Quote
Sign up now
to remove ads between posts
Old Apr 30, 2010, 03:07 AM
Fly the Discombooberator!
magnetman's Avatar
Joined Nov 2003
438 Posts
Ah Right ! yeah funjet is delta wing type so fine for you. If only they did a bigger version of the funjet to carry a bigger load, that would be ideal for me.
I'm intending to use a Twinstar or something similar so would just need normal controls.
magnetman is offline Find More Posts by magnetman
Reply With Quote
Old Apr 30, 2010, 03:15 AM
Registered Loser :)
mark hitchman's Avatar
New Zealand
Joined Sep 2009
1,928 Posts
If you don't need the mixing you wont have to use it, it's just for those who use delta wing mixing in their radios, if they try to access the menu up/down also gives you across and across gives you up/down because of the radio mix. If this mixing was done in the dosd+ it would solve the menu issue.

Mark
mark hitchman is offline Find More Posts by mark hitchman
Reply With Quote
Old Apr 30, 2010, 03:31 AM
Registered User
Joined Aug 2005
4,093 Posts
Would anyone like to try out the new mixing functions?

Daniel
Daniel Wee is offline Find More Posts by Daniel Wee
Reply With Quote
Old Apr 30, 2010, 03:43 AM
Registered Loser :)
mark hitchman's Avatar
New Zealand
Joined Sep 2009
1,928 Posts
I am keen, bit dark to fly tonight though but will try it out in the morning

Thanks

Mark
mark hitchman is offline Find More Posts by mark hitchman
Reply With Quote
Old Apr 30, 2010, 03:51 AM
Registered User
Joined Aug 2005
4,093 Posts
I will upload the beta firmware later.

Daniel
Daniel Wee is offline Find More Posts by Daniel Wee
Reply With Quote
Old Apr 30, 2010, 12:02 PM
Registered User
Solihull, England
Joined Jun 2004
961 Posts
Receiver Input

I have a modified GWS receiver that generates a PPM stream. The output from it is a simple transistor buffer with a 4k7 collector resistor. The output is being dragged down from a 5v swing to a 2.3v swing when I connect it to the Dragon OSD+ - is the input impedance really that low? Any suggestions as to what I could do?

regards Peter
Peter Seddon is offline Find More Posts by Peter Seddon
Reply With Quote
Old Apr 30, 2010, 12:14 PM
Registered User
Joined Aug 2005
4,093 Posts
Peter,

The impedance isn't the issue. I have a zener on the line clamping it down to 3.3V. That's what's causing the voltage to drop. If you want to avoid that - you can insert a series resistor to reduce the draw-down effect.

Edit: RacerX reminded me that if this was causing a problem for you, a unity-gain non-inverting op-amp buffer (see earlier posts on this) would solve the problem.

Daniel
Daniel Wee is offline Find More Posts by Daniel Wee
Last edited by Daniel Wee; Apr 30, 2010 at 03:42 PM.
Reply With Quote
Old Apr 30, 2010, 06:14 PM
Just clumsy. Oh, forgetful too
MikeTheCrash's Avatar
undefined
Joined Jun 2008
3,293 Posts
I'm trying to calibrate the IMU. I'm using TeraTerm VT but all I'm getting back from the IMU is b#H
8b#H򱼘Ksb# HN1b#H b#H򱼘Br`b#H qib#H)b#H+ 0

which I don't understand! I've messed with fonts and scripts but I'm still getting similar. Any ideas?

thanks
MikeTheCrash is offline Find More Posts by MikeTheCrash
Reply With Quote
Old Apr 30, 2010, 06:39 PM
Registered User
RacerX208's Avatar
Joined Apr 2004
1,354 Posts
Mike,

Have you verified baud rate, com port and other com settings? Also are you using the FTDI cable or other?
RacerX208 is offline Find More Posts by RacerX208
Reply With Quote
Old Apr 30, 2010, 07:01 PM
Just clumsy. Oh, forgetful too
MikeTheCrash's Avatar
undefined
Joined Jun 2008
3,293 Posts
Quote:
Originally Posted by RacerX208 View Post
Mike,

Have you verified baud rate, com port and other com settings? Also are you using the FTDI cable or other?
thanks Racer

I'm using
38400 baud as per Daniel's instructions
Com Port 10 - same as used for loading firmware which works OK
using same cable as for loading firmware - USB TTL, same connections


MikeTheCrash is offline Find More Posts by MikeTheCrash
Reply With Quote
Old Apr 30, 2010, 09:06 PM
Registered User
Joined Aug 2005
4,093 Posts
Mike make sure your COM port is also set for 8-bits, 1-stop-bit, No-parity-bit. Also, note that the serial connection to the ArduIMU differs from that used by the OSD board.

Daniel
Daniel Wee is offline Find More Posts by Daniel Wee
Reply With Quote
Old Apr 30, 2010, 10:58 PM
FPV flyer
Virgis21's Avatar
Kaunas, Lithuania
Joined Oct 2007
1,519 Posts
I have tried few firmware versions to install, and i can't remember which one version didn't work with specified baud rate, o changed it until it started to work. Any way, there are not so many tries
Virgis21 is offline Find More Posts by Virgis21
Reply With Quote
Old Apr 30, 2010, 11:02 PM
Registered User
Joined Aug 2005
4,093 Posts
Oh, wait - I might have increased the baud rate to 115200 in the latest one so you may want to change that to 115200 to see if that works. The code shows 38400 but I might have left it in there inadvertently.

Daniel
Daniel Wee is offline Find More Posts by Daniel Wee
Reply With Quote
Old Apr 30, 2010, 11:26 PM
Registered Loser :)
mark hitchman's Avatar
New Zealand
Joined Sep 2009
1,928 Posts
Hi guys, just flew 6.2beta and I see you have changed to 6.2beta3, what changes did you make? I switched on autopilot a couple of times but I must have had the gain too low or something set wrong because I don't think it had control. The elevon mixing works awesome thankyou. Will link to vid when it's finished uploading

Mark
mark hitchman is offline Find More Posts by mark hitchman
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Dragon OSD Level Flight FPV Talk 22 Dec 31, 2013 08:08 PM
For Sale New Intelligent Flight Dragon OSD bfischer Aircraft - General - Miscellaneous (FS/W) 7 Jul 19, 2010 11:56 AM
Discussion FS Ready to fly Intelligent Flight Dragon OSD bfischer FPV Talk 0 Mar 03, 2010 05:57 AM
Discussion RV OSD or Dragon OSD djdaveq FPV Talk 1 Feb 06, 2009 12:18 AM
Discussion RV OSD and Dragon OSD - so near to being Really good! magnetman FPV Talk 8 Nov 11, 2008 05:13 AM